New Member...... MAF CEL problem - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-17-2007, 09:02 PM
n00b
 
Join Date: Oct 2007
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
starcraft is on a distinguished road
(Thread Starter)
New Member...... MAF CEL problem

Hey guys. I am a new members and I am trying to get some answers or suggestions regarding a problem I am having with my 1992 e36. The problem started when I took the car to a car wash and it stalled out (DME got wet........ this was weeks ago so it doesnt affect whats going on now). After the car wash, one of the employees said he was a mechanic on the side and helped me try to get the car started (I knew nothing about the faulty DME housing back then and was desperate so I let him help me). Anyway he tried spraying starting fluid into the intake directly onto the MAF (wrong move........ I KNOW NOW!!!). The car eventually built up with fluid and the thing backfired almost taking the guys head off!!! When I got the car back to my house (by tow truck) I found out about the DME problem and dried it out. The car started right up after I reinstalled it but bogged terribly on idle and the CEL was on. I did a brake pedal test and it showed the code 1215 (MAF). After figuring this all out I went to a wrecker yard and got another MAF........ no change. Then I thought the new MAF was broken so I went back to the yard and got another MAF ........... no change. I decided to do some more research and I found a post that said the ICV or a vaccume leak could cause a MAF code. So, I did a ICV cleaning and checked my hoses and they all check out. Since the ICV cleaning the car runs well but the CEL is still on and there is a distinct smell of gasoline while it is running. Here is where I'm at. I dont know what else to do or to check (I also cleared all the codes in the car everytime I tried a new step and the CEL always comes on as soon as the car is started ........ always with a 1215 reading). Does anyone have any suggestions!!!!! I would really appreciate the help. thanks.

Sorry for the long post
starcraft is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-18-2007, 07:13 AM
Mr. Bacon
 
dannyb's Avatar
 
Join Date: Apr 2007
Location: Civic Nation
Posts: 3,808
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dannyb is a glorious beacon of light dannyb is a glorious beacon of light dannyb is a glorious beacon of light dannyb is a glorious beacon of light dannyb is a glorious beacon of light dannyb is a glorious beacon of light
Send a message via MSN to dannyb
Paragraph Please!!!

Quote:
Originally Posted by german-speed-demon View Post
You may now add "yes, i'm an asshole" to your sig.
Quote:
Originally Posted by AlpineSixAndSeven
that's my whore ; )
dannyb is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Desperately Need Your Help: BMW325i "Service Engine Soon" light problem CNMB250 3-Series (E46, E90) 4 12-19-2007 06:26 AM
E34 trans prog problem exacerbated electronblue 5-Series (E12,E28, E34, E39, E60) 5 03-02-2006 10:07 PM
Hi all, new member here with a question Nomad 3-Series (E36) 10 01-15-2006 11:04 PM
new member with problem orko007 3-Series (E36) 0 09-08-2003 11:13 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome