Need some help - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-23-2004, 01:04 PM   #1 (permalink)
n00b
 
Join Date: Aug 2003
Car:
Posts: 20
Photos:
Midnhtsun is an unknown quantity at this point
Hey all I got a 94 325is, the cars been idleing really rough, when iI go to accelerate the car just thumps and does not accelerate very much, occasionally it will get a boost of speed. As im cruiseing the car seems ok but when i switch gears, idle or accelerate it runs really bad.
I just replaces the o2 censor, the spark plugs appear to be ok (only about a year old), and the injectors were cleaned out about a year ago, just put some injector cleaner in it as well this week. The car is pretty much stock except for a Dinan sport chips almost 2years old and a cold air intake.

If anyone can lend me some advice I would really appreciate it!
Midnhtsun is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-23-2004, 03:43 PM   #2 (permalink)
1st Gear Member
 
Join Date: May 2004
Car:
Posts: 205
Photos:
nycbmw325is is an unknown quantity at this point
Quote:
Originally posted by Midnhtsun@Aug 23 2004, 01:44 PM
Hey all I got a 94 325is, the cars been idleing really rough, when iI go to accelerate the car just thumps and does not accelerate very much, occasionally it will get a boost of speed. As im cruiseing the car seems ok but when i switch gears, idle or accelerate it runs really bad.
I just replaces the o2 censor, the spark plugs appear to be ok (only about a year old), and the injectors were cleaned out about a year ago, just put some injector cleaner in it as well this week. The car is pretty much stock except for a Dinan sport chips almost 2years old and a cold air intake.

If anyone can lend me some advice I would really appreciate it!
things to check in no particular order... clogged catalytic converter, clogged fule filter, fuel pump, huge vacuum leak, bad coil. since you have an obd1 car, you can get the codes to read out from the check engine light to rule out a bad coil.... filter should be changed if it hasn't been done in recent memory, and cat can be rudimentarily checked by noting exhaust pressure....

start digging and let me know what you find and we can take the next step if need be
nycbmw325is is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:36 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.