Need Help please - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-08-2009, 11:59 PM
n00b
 
Join Date: Jul 2008
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
beebedl is on a distinguished road
(Thread Starter)
Need Help please

I have a 1997 328i,


I was experiencing rpm spikes and the transmission would randomly sometime go into safe mode. When the transmission was in safe mode i took it to get the codes pulled and it came back with 4 solenoid codes and torque converter clutch speed monitoring code and ODBII code of P0720(output speed sensor) since then the car will not go out of first but rather right into safe mode after 1st gear. Just yesterday i found a vacuum hose broke and fixed it.however no fix on the transmission. I can drive the car fine in all gears using the manual setting. What could this all lead up to or what should i try?

Last edited by beebedl; 10-09-2009 at 12:01 AM.
beebedl is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-09-2009, 12:05 AM
Ich bin der Modifikator
 
johnnyBgood's Avatar
 
Join Date: Sep 2007
Location: Bayonne, NJ
Posts: 3,325
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough
Garage
Quote:
Originally Posted by beebedl View Post
I have a 1997 328i,


I was experiencing rpm spikes and the transmission would randomly sometime go into safe mode. When the transmission was in safe mode i took it to get the codes pulled and it came back with 4 solenoid codes and torque converter clutch speed monitoring code and ODBII code of P0720(output speed sensor) since then the car will not go out of first but rather right into safe mode after 1st gear. Just yesterday i found a vacuum hose broke and fixed it.however no fix on the transmission. I can drive the car fine in all gears using the manual setting. What could this all lead up to or what should i try?
Do you know when it last had a trans service? Filter & Fluid Replaced?

______________________________________
_______________________97 E36|Conforti Software|M50 Manifold|AFE|Borla|H&R| Bilstein |Eibach|Rockford|3.15 LSD
____________________________________________http://www.cardomain.com/ride/3129109

Last edited by johnnyBgood; 10-09-2009 at 12:10 AM.
johnnyBgood is offline  
#3 (permalink) Old 10-09-2009, 12:09 AM
n00b
 
Join Date: Jul 2008
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
beebedl is on a distinguished road
(Thread Starter)
about 7k miles ago
beebedl is offline  
#4 (permalink) Old 10-09-2009, 12:12 AM
Ich bin der Modifikator
 
johnnyBgood's Avatar
 
Join Date: Sep 2007
Location: Bayonne, NJ
Posts: 3,325
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough
Garage
Quote:
Originally Posted by beebedl View Post
about 7k miles ago

Ok.....
other then the trans codes, are there any check engine codes.....?


jb

______________________________________
_______________________97 E36|Conforti Software|M50 Manifold|AFE|Borla|H&R| Bilstein |Eibach|Rockford|3.15 LSD
____________________________________________http://www.cardomain.com/ride/3129109
johnnyBgood is offline  
#5 (permalink) Old 10-09-2009, 12:13 AM
n00b
 
Join Date: Jul 2008
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
beebedl is on a distinguished road
(Thread Starter)
yea the check engine code is the P0720 (output speed sensor)
beebedl is offline  
#6 (permalink) Old 10-09-2009, 12:27 AM
Ich bin der Modifikator
 
johnnyBgood's Avatar
 
Join Date: Sep 2007
Location: Bayonne, NJ
Posts: 3,325
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough johnnyBgood is a jewel in the rough
Garage
Quote:
Originally Posted by beebedl View Post
yea the check engine code is the P0720 (output speed sensor)

Found this:

http://www.europeantransmissions.com...4HP24_diag.pdf


& this

http://www.ebooksquad.com/2009/01/05...diagnosis.html

______________________________________
_______________________97 E36|Conforti Software|M50 Manifold|AFE|Borla|H&R| Bilstein |Eibach|Rockford|3.15 LSD
____________________________________________http://www.cardomain.com/ride/3129109

Last edited by johnnyBgood; 10-09-2009 at 12:30 AM.
johnnyBgood is offline  
#7 (permalink) Old 10-09-2009, 09:18 AM
2nd Gear Member
 
Join Date: Jul 2008
Posts: 374
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
FCPGroton is on a distinguished road
If you can shift through all the gears fine in manual mode, the transmission is still working correctly. More then likely it is an issue with the trans computer or even just the speed sensor.

FCP Groton
877-634-0063 | info@fcpgroton.com

FCP Euro - European Car Parts Specialists
FCP Import - Import Replacement Car Parts
FCPGroton is offline  
#8 (permalink) Old 10-09-2009, 11:18 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
I would also say its the speed sensor, now on mine there are two input and output and they are located inside the tranny, you have to drop the pan, so drain the fluid 1st, then you will see the valve control body this is where they are situated, easy to remove.

But I would say check at RealOEM.com Online BMW Parts Catalog to make sure they are in the box as some I know of you can retrieve them from the outside.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#9 (permalink) Old 10-30-2009, 10:01 PM
n00b
 
Join Date: Oct 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
joseluisbaez is on a distinguished road
Transmission solenoid

Quote:
Originally Posted by beebedl View Post
I have a 1997 328i,


I was experiencing rpm spikes and the transmission would randomly sometime go into safe mode. When the transmission was in safe mode i took it to get the codes pulled and it came back with 4 solenoid codes and torque converter clutch speed monitoring code and ODBII code of P0720(output speed sensor) since then the car will not go out of first but rather right into safe mode after 1st gear. Just yesterday i found a vacuum hose broke and fixed it.however no fix on the transmission. I can drive the car fine in all gears using the manual setting. What could this all lead up to or what should i try?
Transmission solenoid can go bad. That is what makes tranny shift. Lucas oil makes a chemical that frees up solenids in the tranny, easy to use as long as tranny is not sealed, if sealed you may have to change solenoids, but check with dealership to insure you are changinging the right parts...Good Luck
joseluisbaez is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome