my car lost power! - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-17-2004, 03:39 PM
1st Gear Member
 
leobmw's Avatar
 
Join Date: Sep 2003
Location: Atlanta, GA
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
leobmw is an unknown quantity at this point
(Thread Starter)
I was on the highway doing about 70 mph and i flased my high beams to let someone through, and as soon as i did that my radio went off, so i turned my radio back on and tryed again, and the same thing happen, so i turned my radio off, and did it again, and this time my car just lost power for second and all my lights in my dash flashed. My car is 92 325i and i have a aftermarket radio, with a amp, and sub on it but i've had it installed over a year and that's never happend before.
So i was wondering if it could be my alternator, because my car cranks up fine so i doubt it's my battery....has anyone experienced this before?
ohh! another thing i just installed - about to weeks ago, a eprom chip(ebay one) but i've not had problems with it. the car has been running smooth.
If it helps my car has 105,000 miles y don't think the alternator has ever been replaced. Do you guy's think my alternator is due for replacement?
Thanks, in advance.
ps sorry for the long post!
leobmw is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-17-2004, 03:47 PM
You Can Has A Custom Title!!
 
komodo's Avatar
 
Join Date: Apr 2004
Posts: 3,509
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
komodo is an unknown quantity at this point
I don't know. I've noticed on my 328i that if I'm cruising along at a decent speed with the music blasting and I let down a window, the music stops until I let off the window button. That's happened a few times and I figured the car just didn't have enough juice in it to do everything at once.
komodo is offline  
#3 (permalink) Old 07-17-2004, 03:50 PM
Defector
 
El Presidente's Avatar
 
Join Date: Dec 2002
Location: Long Island
Posts: 5,973
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
El Presidente is an unknown quantity at this point
Send a message via AIM to El Presidente
try adding a capacitor. that will take a good deal of stress off the alt and battery.

<span style='color:gray'><span style='font-family:Courier'>1995 e36 3 Series RIP
1999 e46 3 Series BURN IN HELL
2000 MR-S Roadster= Current</span></span>
El Presidente is offline  
#4 (permalink) Old 07-17-2004, 04:02 PM
1st Gear Member
 
leobmw's Avatar
 
Join Date: Sep 2003
Location: Atlanta, GA
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
leobmw is an unknown quantity at this point
(Thread Starter)
Thank's presidente thats a good sugestion. Man i didn't know you lived here in Atl. that is cool. No wonder your car looks familiar i thought i had seen it somewere. You got a bad ass looking car ther my friend maybe you can help me out with mine sometime.
leobmw is offline  
#5 (permalink) Old 07-17-2004, 05:51 PM
Defector
 
El Presidente's Avatar
 
Join Date: Dec 2002
Location: Long Island
Posts: 5,973
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
El Presidente is an unknown quantity at this point
Send a message via AIM to El Presidente
Well I actually just moved to the area a few weeks ago. Thanks for compliments though. Drop me a PM sometime if you wanna meet up, I'd love to meet some other BMW owners on the board. The only other person I've been able to meet was thekid.

<span style='color:gray'><span style='font-family:Courier'>1995 e36 3 Series RIP
1999 e46 3 Series BURN IN HELL
2000 MR-S Roadster= Current</span></span>
El Presidente is offline  
#6 (permalink) Old 07-17-2004, 06:02 PM
1st Gear Member
 
robbins6103's Avatar
 
Join Date: Jun 2004
Location: Oklahoma City, OK
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
robbins6103 is an unknown quantity at this point
Send a message via AIM to robbins6103
time for a capacitor....easy fix

<img src='http://memimage.cardomain.net/member_images/8/web/740000-740999/740645_1_full.jpg' border='0' alt='user posted image' />
robbins6103 is offline  
#7 (permalink) Old 07-17-2004, 08:48 PM
Threadkiller
 
bitcore's Avatar
 
Join Date: Jan 2004
Location: High Point, NC
Posts: 2,907
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bitcore will become famous soon enough bitcore will become famous soon enough
Quote:
Originally posted by robbins6103@Jul 17 2004, 07:42 PM
time for a capacitor....easy fix
and or a larger alternator.

Charging system might not be up to snuff to keep the voltage up.


bitcore is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Me on my car, on the Freeway! 325eXTATIC Picture Showroom 20 01-19-2006 10:49 AM
Chip Made My Car Slower gonzonick 3-Series (E36) 12 10-25-2005 02:46 PM
problems starting car when cold... VLAD_325is 3-Series (E36) 8 09-12-2005 08:08 PM
battery lost charge..proper way to charging it wcre34 3-Series (E36) 8 09-07-2005 09:21 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome