My car is idleing weird - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-31-2007, 03:16 PM   #1 (permalink)
n00b
 
zottola325is's Avatar
 
Join Date: Nov 2006
Car: 1992 BMW 325is
Posts: 14
Photos:
zottola325is is on a distinguished road
Send a message via AIM to zottola325is
My car is idleing weird

For a couple of weeks now my car has been idleing weird and i thought maybe it was a vacuum leak but there isnt any. I then took the icv out and cleaned it up real good but it still didnt work. Would u suggest buying a new icv or is there anything else that it might be?
zottola325is is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-31-2007, 03:24 PM   #2 (permalink)
1st Gear Member
 
paco1076's Avatar
 
Join Date: Jan 2006
Location: Frederick, MD
Car: 1997 BMW M3
Posts: 130
Photos:
paco1076 is on a distinguished road
Send a message via AIM to paco1076
How many miles on your car? When was your last tune up? Last time you changed the air filter? Fuel filter? We need some more information.
__________________
1997 E36 M3 - running stocker style right now...
paco1076 is offline   Reply With Quote
Old 01-31-2007, 03:33 PM   #3 (permalink)
n00b
 
zottola325is's Avatar
 
Join Date: Nov 2006
Car: 1992 BMW 325is
Posts: 14
Photos:
zottola325is is on a distinguished road
Send a message via AIM to zottola325is
my cars got approx. 120,000miles and i changed the air filter about 2,000 miles ago. i havent changed the fuel filter, and it hasnt been tuned up since ive had the car. ive had it for about 4 months.
zottola325is is offline   Reply With Quote
Old 02-02-2007, 06:55 PM   #4 (permalink)
1st Gear Member
 
Join Date: Jul 2005
Car:
Posts: 294
Photos:
Hamfisted is on a distinguished road
Did you test the TPS?

Did you test the throttle position switch? They burn out after a while. Look in the Bentley manual there's a proceedure in there for it. Basically test for continuity in the switch when the throttle is closed, then again at WOT. It tells the computer the throttle is closed and turns over idle control to the computer. You can also unplug the TPS and see if the idle settles down. But with the TPS unplugged you won't get the bump in rpm when you turn on the A/C, and cold starts will be a little harder (you have to give it a little gas while cranking...). Test for continuity with an ohm meter (digital multimeter...) between the correct pins.

If you need the service manual download you can find it here: Service Manual Downloads






-Mike
Hamfisted is offline   Reply With Quote
Old 02-05-2007, 10:11 PM   #5 (permalink)
5th Gear Member
 
RexKing86's Avatar
 
Join Date: Mar 2005
Location: Dayton, OH
Car: 2006 Mitsubishi Lancer Evolution MR
Posts: 1,248
Photos:
RexKing86 is an unknown quantity at this point
Send a message via AIM to RexKing86
Idle Control valve is probably dirty. Clean it or buy a new one. Idk where you live, but i know my car doesnt like the 0 to sub zero temps around here in Dayton, atleast until shes warm.

~Kingo
__________________
RexKing86 is offline   Reply With Quote
Old 02-16-2007, 11:07 AM   #6 (permalink)
n00b
 
heartbreaker's Avatar
 
Join Date: Feb 2007
Location: Minneapolis, minnesota.
Car: 1993 BMW 325IS
Posts: 36
Photos:
heartbreaker is on a distinguished road
wow, i ahev the same exact problem, on my 93' 325IS. i just decided to live with it because after a 10-15 seconds of idle it runs normal, it always seems like a vacc leek but only for a bit. strange.
heartbreaker is offline   Reply With Quote
Old 02-16-2007, 11:08 AM   #7 (permalink)
n00b
 
heartbreaker's Avatar
 
Join Date: Feb 2007
Location: Minneapolis, minnesota.
Car: 1993 BMW 325IS
Posts: 36
Photos:
heartbreaker is on a distinguished road
question for rexking86. where is the idle control valve and how do you clean it?
heartbreaker is offline   Reply With Quote
Old 02-16-2007, 11:12 AM   #8 (permalink)
teh Canuck....eh
 
PhatCat's Avatar
 
Join Date: Aug 2006
Location: Calgary, Alberta
Car: '86 E30, baby! '05 Legacy 2.5GT Ltd
Posts: 3,613
Photos:
PhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond reputePhatCat has a reputation beyond repute
Send a message via MSN to PhatCat
heartbreaker...check out this thread, it might help...

http://www.bimmerwerkz.com/forum/mai...blems-601.html
__________________
All great things are simple, and many can be expressed in single words: freedom, justice, honor, duty, mercy, hope.
Sir Winston Churchill
PhatCat is offline   Reply With Quote
Old 02-22-2007, 05:01 PM   #9 (permalink)
1st Gear Member
 
Dudesky_E36's Avatar
 
Join Date: Jul 2005
Location: Jersey City, NJ
Car: Anthracite e39 530iA
Posts: 241
Photos:
Dudesky_E36 is an unknown quantity at this point
Send a message via AIM to Dudesky_E36
At 120k on the clock, your car is a prime candidate for replacing the O2 sensor, which can cause the rough idling. You may wanna check that out.
__________________
Dudesky_E36 is offline   Reply With Quote
Old 02-25-2007, 02:15 PM   #10 (permalink)
n00b
 
Join Date: Nov 2006
Car:
Posts: 5
Photos:
atanakin is on a distinguished road
screw all the assumptions, take it to the dealership and have them diagnose it for you. it can cost up to 100 dollars but it will be better than replacing parts that do not need to be replaced.
atanakin is offline   Reply With Quote
Old 02-25-2007, 06:01 PM   #11 (permalink)
General Chaos
 
SpeedInfusion's Avatar
 
Join Date: Dec 2003
Location: Plano, TX
Car: ///M3,Corolla
Posts: 13,803
Photos:
SpeedInfusion has disabled reputation
Send a message via AIM to SpeedInfusion
its most likely the ICV....i need to clean mine as welll
__________________
SpeedInfusion is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
91 m5 Parts car or parting out... trailbuilt For Sale 2 12-12-2007 10:42 AM
weird thing my car keeps doing crunkjuice 3-Series (E36) 6 02-23-2006 02:51 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:44 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.