M50B25 idle problem - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-13-2012, 12:32 AM
n00b
 
Join Date: Nov 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Krotes is on a distinguished road
(Thread Starter)
M50B25 idle problem

I've had this problem since I bought the car. When I start the car cold it runs idle pretty well and stable and doesn't smoke, but after few minutes rpm goes down a bit and it starts running so bad that the whole car is shaking and it's smoking quite a lot too...so it seems to start running on rich for some reason? So far I've changed new bosch lambda, new sparkplugs, new camshaft position sensor, checked all intake hoses for any cracks and leaks, cleaned icv and tested that it's working and also tested ignition. Still no any diffirence. Got any ideas what to do next?
Krotes is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-15-2012, 10:55 PM
n00b
 
Join Date: Jun 2012
Location: Washington State
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ElTonyo69 is on a distinguished road
I had a very rich and rough idle ad my problem ended up being the VANOS not being adjusted correctly.
ElTonyo69 is offline  
#3 (permalink) Old 11-16-2012, 01:38 PM
n00b
 
Join Date: Nov 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Krotes is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by ElTonyo69 View Post
I had a very rich and rough idle ad my problem ended up being the VANOS not being adjusted correctly.
I got non-vanos, so can't be that.
Krotes is offline  
#4 (permalink) Old 11-18-2012, 07:26 PM
1st Gear Member
 
Ivan413's Avatar
 
Join Date: Nov 2012
Location: NY
Posts: 177
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ivan413 is on a distinguished road
Garage
My e36 had an idle problem. If you haven't cleaned your MAF sensor, so and if problem continues its most likely you o2 sensor causing the problem

Just your avg 17 year old with an e36 318i as a DD!
Ivan413 is offline  
#5 (permalink) Old 11-23-2012, 08:18 PM
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Posts: 2,210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lord Vader is on a distinguished road
Quote:
Originally Posted by Ivan413 View Post
My e36 had an idle problem. If you haven't cleaned your MAF sensor, so and if problem continues its most likely you o2 sensor causing the problem
Bingo. This is most likley the problem. A bad O2 sensor can cause a host of issues as the car doesnt know what the air fuel mixture is and cant adjust properly. Bad idling and running rich is quite common.


ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW e36 m50b25 with 6speed m3 gearbox. auuu 3-Series (E36) 0 01-04-2010 09:18 PM
M50B25 from e34 to e30 problem Toninho 3-Series (E21, E30) 1 07-30-2007 12:43 PM
M50B25 from e34 to e30 problem Toninho 5-Series (E12,E28, E34, E39, E60) 0 07-19-2007 02:57 AM
Technical data of m50b25 nukeduster 3-Series (E36) 2 01-28-2007 10:58 PM
M50B25 (no vanos) conversion to 3.0? enemigo 3-Series (E36) 8 05-21-2004 12:48 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome