Loss of power under load - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-05-2011, 10:13 AM
n00b
 
Join Date: Aug 2005
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
94325is is an unknown quantity at this point
(Thread Starter)
Loss of power under load

Car is the 1994 325IS... it will start and idle fine, rev fine... it purrs... until I put it in gear and try to drive it... then it loses all power, wants to stall, etc... not sure where to start with it exactly... any ideas?
94325is is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-05-2011, 07:55 PM
n00b
 
Join Date: Mar 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mountaindewbot is on a distinguished road
I have no clue, Im actually having almost the same problem. except I just put a new motor and tranny in and its still doing it. So I'm guessing it might be an outside source. like the ECU is crapped or somthing
Mountaindewbot is offline  
#3 (permalink) Old 04-06-2011, 12:27 PM
n00b
 
Join Date: Aug 2005
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
94325is is an unknown quantity at this point
(Thread Starter)
Well if you do figure anything out, let me know, and I will do likewise... I wondered if maybe it's the Mass air flow sensor, or maybe an O2 sensor that is mucking up the air/fuel mix... as I say, it will start and idle fine, no signs of vacuum leaks etc... you wouldn't know there was any problem with it until you try to actually drive it... I have had problems with, and replaced ignightors in the past, and there is always something else going on besides power loss... rough idle, missing etc.... this one is a real mystery... one last item.... it happened initially while driving... was going along fine, them wham...
94325is is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
40 amp extra load - Power from where? (E39) RIL 5-Series (E12,E28, E34, E39, E60) 1 10-23-2010 07:55 PM
Loss of Power andrewtouron 3-Series (E36) 4 09-05-2010 01:16 AM
power loss! bimmerguy82 3-Series (E36) 7 02-28-2007 12:59 AM
Loss of power JoeMadoo 3-Series (E21, E30) 8 08-31-2006 04:59 PM
Power LOSS skawful 3-Series (E36) 4 08-09-2004 08:56 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome