highbeam issues - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-21-2006, 06:24 PM   #1 (permalink)
n00b
 
Join Date: Mar 2006
Location: Stratford, On
Car: 1996 318is
Posts: 40
Photos:
chuckz is on a distinguished road
highbeam issues

Hi guys!!
i have a problem with highbeams on 96 318is. when the car is cold, my highbeams will work for a little bit, but after a while they dont work at all;
in highbeam or when flashing. is it the switch, or something else.
thanks
chuckz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2006, 07:45 PM   #2 (permalink)
General Chaos
 
SpeedInfusion's Avatar
 
Join Date: Dec 2003
Location: Plano, TX
Car: ///M3,Corolla
Posts: 13,803
Photos:
SpeedInfusion has disabled reputation
Send a message via AIM to SpeedInfusion
check bulbs and fuses first..
__________________
SpeedInfusion is offline   Reply With Quote
Old 03-21-2006, 07:47 PM   #3 (permalink)
1st Gear Member
 
Join Date: Jul 2005
Car:
Posts: 294
Photos:
Hamfisted is on a distinguished road
Quote:
Originally Posted by chuckz
Hi guys!!
i have a problem with highbeams on 96 318is. when the car is cold, my highbeams will work for a little bit, but after a while they dont work at all;
in highbeam or when flashing. is it the switch, or something else.
thanks



I'd say it's the high beam relay going bad. Located in the relay box up under the driver's side knee bolster area. Do you hear it clicking when you hit the stalk switch? I guess you could test the stalk lever switch with an ohmmeter to see if it's working correctly too. Its a tough call, the relay or the switch... Maybe you can take the relay apart and clean the contacts and retest it before going out and buying a new one. Oh well, I guess that didn't clear up anything...








Mike
Hamfisted is offline   Reply With Quote
Old 03-23-2006, 06:24 PM   #4 (permalink)
n00b
 
Join Date: Mar 2006
Location: Stratford, On
Car: 1996 318is
Posts: 40
Photos:
chuckz is on a distinguished road
hey thanks mike. my bulbs and fuses are all good so thats why i was wondering about the switch. i will check the relay this weekend.
thanks for the ideas!
chuckz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel issues? Car bogging! ReaverJam 3-Series (E21, E30) 5 10-04-2005 10:16 PM
1992 525i Help Fixing Electrical Issues gregruby 5-Series (E12,E28, E34, E39, E60) 1 03-05-2005 11:37 AM
Lots of issues with a CPO pmolfese 3-Series (E46, E90) 2 06-14-2004 04:12 PM
2000 740i Issues vevro 1,6,7,8 - Series and Mini Cooper 1 04-21-2004 01:07 PM
2004 X5 4.4i - transmission / throttle issues rting 1,6,7,8 - Series and Mini Cooper 0 03-30-2004 02:14 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:39 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.