Help! My a/c will not turn on! - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-26-2004, 02:30 PM
n00b
 
Join Date: May 2004
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jroberts312 is an unknown quantity at this point
(Thread Starter)
My ac started acting up yesterday. It first started by me trying to turn it on. It did nothing. I tried pushing other buttons and it started. I thought it was just a fluke. Then it happened again but took even longer to start. The symptoms are not display on ac panel. Nothing at all. Now it will not start for nothing. I checked all fuses and relays. I looked in service manual for the relays related to ac. There were two, one for heater/ac and the other for compressor. I swapped with another like relay and it still would not turn on. Does anyone know what it might be? One other symptom is the display turned on but then shut off with some led's still lit up. Help! It will be a hot summer.
jroberts312 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-26-2004, 03:28 PM
ex owner/admin
 
Furious's Avatar
 
Join Date: Nov 2002
Location: Toronto-Canada
Posts: 10,839
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious
Send a message via AIM to Furious
you could be out of freeon. check your auxilury fan to make sure its not stuck or somewhat restricted in movement. lastly if all else fails you could be looking at an expensive fix (could be a faulty compressor or an electrical problem in the climate

Furious is offline  
#3 (permalink) Old 05-28-2004, 09:26 AM
n00b
 
Join Date: May 2004
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jroberts312 is an unknown quantity at this point
(Thread Starter)

Hey found a fix. Tried it and it works great.

http://www.macadamizer.com/bmwfix.html
jroberts312 is offline  
#4 (permalink) Old 05-28-2004, 10:37 AM
5th Gear Member
 
Join Date: Mar 2004
Location: Richmond Hill, Ontario
Posts: 1,169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Autotechnica is an unknown quantity at this point
When you say it isn't working, do you mean the air isn't cold or there isn't any air at all?

Go to a shop and ask them to check out the freon. If it's gone tell them to top it off and then check for leaks. I paid around $60-$70CDN for them to top it off. According to my mechanic mine isn't leaking. Yet I have to top off every 2 years. Strange.

Bry

<u>1994 M-Technic M42 Saloon - Trillium Chapter - 5130</u>
Stock - 2866lbs Current - 2670lbs
<a href='http://www.geocities.com/mtechnik42' target='_blank'>- VIEW MY MODS AND PICS</a>
<a href='http://www.automobile-technik.com' target='_blank'>- PARTS FOR SALE</a>
--------------------------------------------------------------------------------
&lt;img src=&quot;http://www.maxbimmer.com/forums/atta...tc=1&quot;&gt;
Autotechnica is offline  
#5 (permalink) Old 05-28-2004, 10:46 AM
n00b
 
Join Date: May 2004
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jroberts312 is an unknown quantity at this point
(Thread Starter)

You must not have read my previous post. It is working now. The symptoms were that the air would not turn on at all. The ac control was broken. Not led display at all. Sometimes it would turn on and shut off. Some leds would remain on but no air. Works now. I am happy.
jroberts312 is offline  
#6 (permalink) Old 05-28-2004, 11:06 AM
Neutral Member
 
Join Date: Jul 2003
Location: Chicago, IL
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
infared21 is an unknown quantity at this point
Send a message via AIM to infared21
I had this same problem when I first got my car.. it worked when it wanted to. It is really an expensive fix, forgot what they did actually.. ill see if i can find the service report.

<img src='http://infared-designs.com/misc/bmw328.jpg' border='0' alt='user posted image' />
infared21 is offline  
#7 (permalink) Old 05-28-2004, 01:46 PM
1st Gear Member
 
Join Date: May 2004
Location: New York, NY
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
fushuman is an unknown quantity at this point
Well i dunno what's wrong with my car.
The fan seems to work at any speed and temp. seems ok as well. But the problem is it just comes out from the bottom (towards my feet). I've pressed every single button on the Climate Control, but no air comes from the front or defroster or defogger ghead
Maybe is somw kind of fuse thats burned or something, i just dunno

<img src='http://www.bmw-forums.com/forum/uploads/photo-7050.jpg' border='0' alt='user posted image' />
CONQUER THE WORLD WITH YOUR <span style='color:red'>HEART</span>!!!!!
CONQUER THE RACE WITH YOUR <span style='color:blue'>SOUL</span>!!!!
fushuman is offline  
#8 (permalink) Old 05-28-2004, 03:30 PM
n00b
 
Join Date: May 2004
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Jamesr316 is an unknown quantity at this point
AC sucks in german cars. Always has, probably always will. Guess you dont really need AC when your going 100 on the autobahn...
Jamesr316 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signals not working ganjacyde 3-Series (E36) 3 05-25-2012 09:28 AM
My Abs Light Came On!? Help! Delmarco 3-Series (E36) 3 07-02-2005 08:48 PM
Turn Off This Airbag Light....help! Sickblack328 3-Series (E36) 6 06-28-2005 06:59 PM
HELP! Turn Signal not working??? kraze0g 3-Series (E36) 7 06-22-2004 12:39 PM
Interior lights will not turn off Wurzig-Drei 5-Series (E12,E28, E34, E39, E60) 2 02-02-2004 09:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome