Heater blows cold on upper vents ONLY!HELP - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-25-2009, 01:35 AM   #1 (permalink)
Neutral Member
 
Join Date: Nov 2009
Car:
Posts: 54
Photos:
92cleanbeam is on a distinguished road
Heater blows cold on upper vents ONLY!HELP

My heater works great and blows nice and hot except for when I change vents to upper level. The defrost and low vents are hot but change to cold or possibly outside air when selected to upper vents. Does anyone know if there is a quick fix?
92cleanbeam is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-25-2009, 06:24 AM   #2 (permalink)
Millions of them.
 
Torque's Avatar
 
Join Date: Dec 2003
Location: USA
Car: e36 w/ a m42
Posts: 14,878
Photos:
Torque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond repute
The two knobs under the center vent ... turn the left one to hot.
__________________
Torque is offline   Reply With Quote
Old 11-25-2009, 01:03 PM   #3 (permalink)
Neutral Member
 
Join Date: Nov 2009
Car:
Posts: 54
Photos:
92cleanbeam is on a distinguished road
hi

Okay I don't think I stated my problem clearly enough. But, with both knobs turned all the way to hot and the heater on defrost it works fine it also works fine with vents at the feet. But when I turn the vent knob to the middle vents, you know the ones that blast in your face, The air all the sudden turns cold. The heat works fine except when on one certain vent, then it turns cold.
92cleanbeam is offline   Reply With Quote
Old 11-25-2009, 01:07 PM   #4 (permalink)
Millions of them.
 
Torque's Avatar
 
Join Date: Dec 2003
Location: USA
Car: e36 w/ a m42
Posts: 14,878
Photos:
Torque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond repute
Hm that's a bummer. Probably one of the flaps/motors stuck ... I had the same thing with my e34. Went the whole of last winter only getting warm air to my feet.
__________________
Torque is offline   Reply With Quote
Old 11-25-2009, 02:17 PM   #5 (permalink)
Neutral Member
 
Join Date: Nov 2009
Car:
Posts: 54
Photos:
92cleanbeam is on a distinguished road
kinda what i was thinking

Thanks for the reply. I see your on almost every post I looked at so far. You must be pretty experienced in these cars. I have only had mine for 3 months. I bought it for $2900. It only has 103k miles on it and its a 92 325is. It runs great but seems to lose its power at higher RPMs. It seems maybe its ready for a new chain. I noticed also that a lifter or something sticks when it starts cold. Really cold. One more thing, my heater smells like coolant when it is on, but not when a/c is on. The whole entire coolant system has just been replaced. Is there something easy to fix this? I know air freshners don't work. Thanks for all the help
92cleanbeam is offline   Reply With Quote
Old 11-25-2009, 03:23 PM   #6 (permalink)
Millions of them.
 
Torque's Avatar
 
Join Date: Dec 2003
Location: USA
Car: e36 w/ a m42
Posts: 14,878
Photos:
Torque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond repute
Quote:
Originally Posted by 92cleanbeam View Post
Thanks for the reply. I see your on almost every post I looked at so far. You must be pretty experienced in these cars. I have only had mine for 3 months. I bought it for $2900. It only has 103k miles on it and its a 92 325is. It runs great but seems to lose its power at higher RPMs. It seems maybe its ready for a new chain. I noticed also that a lifter or something sticks when it starts cold. Really cold. One more thing, my heater smells like coolant when it is on, but not when a/c is on. The whole entire coolant system has just been replaced. Is there something easy to fix this? I know air freshners don't work. Thanks for all the help
Probably a dripping heater core; honestly unless it's really bad and also leaking all over the place, I'd leave it ... pretty much the whole lower part of the dash has to come out; but that said, once you have that out, it should be no problem finding why you don't have heat to certain vents.

As for the chain: they are lifetime and don't need to be replaced; probably a tensioner rattling.

btw, sounds like a great deal ... good price, a little bit of work and you got a great car.
__________________
Torque is offline   Reply With Quote
Old 11-25-2009, 03:36 PM   #7 (permalink)
Neutral Member
 
Join Date: Nov 2009
Car:
Posts: 54
Photos:
92cleanbeam is on a distinguished road
great shape

Yeah the car is in great shape considering its age. It has a faded hood because the owner left the wax on in the blistering sun. Beyond that it has a great running motor that doesn't miss a beat. The only thing is the ticking that comes from motor at strartup which eventually goes away after a few seconds. Also, I was hoping you wouldn't say heater core. I bet thats why he sold it. I wonder if it wasn't replaced correctly. Is there any way for the core to leak by faulty installation? The reason I ask is because the whole entire coolant system was replaced and he said it had no issues overheating. I didn't question the guy as he really really really took care of this car down to every minor detail. I still have the tool kit and spare that have never been touched. The interior is in pretty good shape but the plastic odds and ends fall of from time to time. Its like a puzzle sometimes. I guess a heater core will give me something to do on it. I have torn out many dashes and have removed many dashes so I am kind of skeptical. What about some kind of sealant? Or would it still have an odor unless torn apart and cleaned up? Again, Thanks for the replies.
92cleanbeam is offline   Reply With Quote
Old 11-26-2009, 11:43 AM   #8 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 6
Photos:
nelson.jones07 is on a distinguished road
Wow great look and style, its really very impressive and stylist. Seems a very high performance car.
__________________
Nelson Jones
BMW Parts Wheels
BMW Headlights
BMW Accessories
nelson.jones07 is offline   Reply With Quote
Old 11-26-2009, 02:03 PM   #9 (permalink)
Neutral Member
 
Join Date: Nov 2009
Car:
Posts: 54
Photos:
92cleanbeam is on a distinguished road
nice car

Yeah Torque that car looks really nice. I like the lowering you have going on. Could you please provide details on your lowering. I have been wanting to lower mine but it runs so smooth I haven't messed with it. However, I think the car looks ten times better. Mine is a 2 door though so it may look a little different. I like the four doors better myself. I have always been a fan of lowered 4 doors.
92cleanbeam is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
87 325es Heater A/C fan only blows on speed 4 terriibleted65 3-Series (E21, E30) 7 11-29-2009 03:16 PM
1995 E36 328i Touring : Heater blows cold MM16 3-Series (E36) 7 11-01-2008 01:47 PM
Heat blows cold then hot ???? slate530i 5-Series (E12,E28, E34, E39, E60) 4 04-18-2007 09:17 AM
Blows When Cold robby c 5-Series (E12,E28, E34, E39, E60) 1 09-29-2004 03:00 AM
Heater only blows hot when driving? Scarface 3-Series (E36) 5 11-26-2003 06:17 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:17 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.