Has Anyone Fixed That Dash Instrument Gremlin? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-13-2009, 12:09 AM   #1 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 4
Photos:
fenlux is on a distinguished road
Has Anyone Fixed That Dash Instrument Gremlin?

Hi Guys,

I'm a newbie here and have been searching yours and other forums for the problem I have with my dash instruments.

The problem where the gauges flicker and die has been mentioned in a few threads here but no one has actually said that they have fixed or found the problem.

It was mentioned in one thread that the instrument panel needed to be replaced, has anyone done this and fixed the problem?

I have replaced the battery and checked the plugs in the back of the instrument panel for those who are going to say it is that easy.

Any help with this problem would be much appreciated.

Cheers and great forum.
fenlux is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-13-2009, 11:28 AM   #2 (permalink)
Neutral Member
 
martyyyn's Avatar
 
Join Date: Jan 2009
Location: Skopje, Macedonia
Car: E36 325Turbo Diesel
Posts: 66
Photos:
martyyyn is on a distinguished road
Hi,

Have you checked your boot/trunk cables, not sure if its relevent to the cluster cutting out but there are known to cause all sorts of electrical gremlins, other that that maybe its a bad earth connection.


http://www.bimmerwerkz.com/forum/3-s...ing-55136.html

Cheers Martin
__________________
martyyyn is offline   Reply With Quote
Old 02-13-2009, 12:46 PM   #3 (permalink)
n00b
 
Join Date: Jan 2009
Car:
Posts: 16
Photos:
lrobertwood is on a distinguished road
i had same problem on my 325i (1993) ended up changing my cluster today took me ten mins to do only two srews and three plugs in the back came out with steering wheel at highest point no problem
lrobertwood is offline   Reply With Quote
Old 02-13-2009, 03:22 PM   #4 (permalink)
Neutral Member
 
martyyyn's Avatar
 
Join Date: Jan 2009
Location: Skopje, Macedonia
Car: E36 325Turbo Diesel
Posts: 66
Photos:
martyyyn is on a distinguished road
Quote:
Originally Posted by lrobertwood View Post
i had same problem on my 325i (1993) ended up changing my cluster today took me ten mins to do only two srews and three plugs in the back came out with steering wheel at highest point no problem
Did it solve your problems Robert ?

Cheers Martin
__________________
martyyyn is offline   Reply With Quote
Old 02-13-2009, 05:54 PM   #5 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 4
Photos:
fenlux is on a distinguished road
Thanks for the replies,

Yes have checked and fixed boot wire loom, also waiting for a boot lock actuator to arrive because someone had fitted a dodgy aftermarket boot actuator which is causing the doors to unlock after I lock them.

Has that fixed the problem Robert?

Cheers, Simon.
fenlux is offline   Reply With Quote
Old 02-14-2009, 03:11 AM   #6 (permalink)
Neutral Member
 
martyyyn's Avatar
 
Join Date: Jan 2009
Location: Skopje, Macedonia
Car: E36 325Turbo Diesel
Posts: 66
Photos:
martyyyn is on a distinguished road
Quote:
Originally Posted by fenlux View Post
Thanks for the replies,

Yes have checked and fixed boot wire loom, also waiting for a boot lock actuator to arrive because someone had fitted a dodgy aftermarket boot actuator which is causing the doors to unlock after I lock them.

Has that fixed the problem Robert?

Cheers, Simon.
Sorry got the name wrong...lol it was after 12pm friday night....lol

Cheers Martin
__________________
martyyyn is offline   Reply With Quote
Old 02-14-2009, 04:41 AM   #7 (permalink)
n00b
 
Join Date: Jan 2009
Car:
Posts: 16
Photos:
lrobertwood is on a distinguished road
Quote:
Originally Posted by lrobertwood View Post
i had same problem on my 325i (1993) ended up changing my cluster today took me ten mins to do only two srews and three plugs in the back came out with steering wheel at highest point no problem
yes everything now working great
lrobertwood is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reunited with my 540! A/C Fixed! Trunk fixed! Eric S. 5-Series (E12,E28, E34, E39, E60) 3 08-04-2006 12:02 PM
Bmw E30 Instrument Dash Background tomsbmw325is 3-Series (E21, E30) 2 05-04-2005 11:31 AM
Electrical Gremlin Platinum52 3-Series (E46, E90) 2 09-02-2004 10:22 PM
EEP-2 dash / instrument cluster message (fuel, tem SkysTheLimit 3-Series (E36) 0 05-23-2004 03:19 PM
Do I have a Gremlin? DANINFOSECDOD 3-Series (E46, E90) 5 10-12-2003 09:16 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:10 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.