Fuel Injection Problem - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-27-2004, 01:21 PM   #1 (permalink)
Neutral Member
 
Join Date: Apr 2004
Location: United Kingdom, London
Car:
Posts: 82
Photos:
zlac109 is an unknown quantity at this point
Hi
I have a 320i SE E36 and a few days ago i noticed that when idlin and when keeping the acceleration at a constant the fuel injection is unstable and also the MPG idicator goes up and down continiously.
I have reset all the electronics of the car, i have replaces the idle vale, but it's not working.

Also, when idling for a lond time and in heavy trafic the engine ovreheats. Ito doesn't go to the red zone, but it goes to the tird line it has never done that before.
I am considering replacing the ECU.
Any ideas anyone?

Thanks
zlac109 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-27-2004, 01:55 PM   #2 (permalink)
What? No Autobahn?
 
jrhaile's Avatar
 
Join Date: Jan 2004
Location: Spokane, Wa
Car: 2001 M5
Posts: 3,525
Photos:
jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile
Send a message via ICQ to jrhaile Send a message via AIM to jrhaile Send a message via MSN to jrhaile
o2 sensor...
__________________
jrhaile is offline   Reply With Quote
Old 04-27-2004, 02:06 PM   #3 (permalink)
Neutral Member
 
Join Date: Apr 2004
Location: United Kingdom, London
Car:
Posts: 82
Photos:
zlac109 is an unknown quantity at this point
Forgot to mention that.
I tried that too, but it didn't solve much.

Also, sometimes, very rarely, it stays stable for about 20 seconds, so given that i was thinking it might be an electrical issue
zlac109 is offline   Reply With Quote
Old 04-27-2004, 02:47 PM   #4 (permalink)
You Can Has A Custom Title!!
 
DesmoBob's Avatar
 
Join Date: Dec 2002
Location: Hawaii
Car:
Posts: 2,238
Photos:
DesmoBob is an unknown quantity at this point
re: idle
http://www.bmw-forums.com/forum/inde...howtopic=10977

re: overheats in traffic
you say it has never done that before, so has just started occurring?
did you just do a coolant flush? if so, it may need bleeding.

check fan clutch. if fan clutch is out then there will not be enough air movement in traffic.
__________________
DesmoBob is offline   Reply With Quote
Old 04-27-2004, 03:21 PM   #5 (permalink)
Neutral Member
 
Join Date: Apr 2004
Location: United Kingdom, London
Car:
Posts: 82
Photos:
zlac109 is an unknown quantity at this point
Checked the fan and it's fine. The coolant is good too, spot on the level mark.
zlac109 is offline   Reply With Quote
Old 04-27-2004, 05:23 PM   #6 (permalink)
Neutral Member
 
Join Date: Apr 2004
Location: Bradford, ON, Canada
Car: 97 328is, 93 318is
Posts: 92
Photos:
thinair is on a distinguished road
Send a message via ICQ to thinair Send a message via MSN to thinair
check the vacuum lines, makes sure they're all properly connected.
__________________
Nelson Papel
1997 Madeira Violet 328is - Carbonio Intake, Racing Dynamics exhaust, fan delete, ASC delete, M50 intake manifold, M3 Cams, Eurospeed/AA software, 3.38LSD, M3 f&r brakes + MC, Bilstein PSS, Eibach swaybars, BBS RK 17x8" wheels, Toyo T1R (235/40R17) tires, Racing Dynamics K55 kit, full euro lighting, 4300k HID lows, etc..........
<a href='http://www3.sympatico.ca/thinairbikes/bmw.htm' target='_blank'>Click here for more info on my car</a>
thinair is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Injection Problem? bmw325es 3-Series (E36) 3 01-26-2005 11:05 PM
Yet Another Fuel Pump Problem Smooth Criminal 3-Series (E21, E30) 11 09-30-2004 02:30 PM
Fuel Pump electronical Problem {NTM} 3-Series (E21, E30) 0 07-28-2004 08:08 AM
Cold Start Problem (fuel Pressure Drop) BEX 3-Series (E36) 6 05-16-2004 07:35 PM
320i in-tank fuel pump? nightsurfride 3-Series (E21, E30) 1 01-28-2004 10:45 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:09 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.