few questions, need help please! - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-03-2010, 02:04 PM
n00b
 
Join Date: Mar 2009
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
brinkstar is on a distinguished road
(Thread Starter)
few questions, need help please!

hey,

So heres a few problems, any answers or ideas to any of these will be awesome. I personally don’t think they are that big of deal just want to get a better idea.

#1. When I turn the steering wheel, I hear an elastic band (kind of like a rubber band stretching) is this just part of the wheel, it only does it on 50% of my turns (sounds like a pulling noise of a rubber band) it does it more in winter, but still does it once in a great while (maybe 5 times a month) in summer, no matter how warm the car is, inside and outside, car seems to still make this noise.

#2. Yesterday I left my dome light on (whew me for forgetting) jumped my car, drove it for 15mins (maybe 1-2miles) good 15mins with the car on though, parked my car, turned it off, back on, started up great. Before I even had it jumped, nothing worked, alarm system noise when I unlock was extremely faint, no lights, u get the pic.

Now today, I go to start the car, all electronics work, the alarm is loud as it always is, the lights all turn on, full power. but the car is still rolling over, not starting, I’m like 85% positive I just didn’t leave the car run long enough to gain enough power. Is this sound correct or could there be any other problems I’m not seeing?

#3. My check coolant level message has been coming up for the past month. I’ve checked it plenty of times, it’s at the perfect level, the coolant is new as of march 2009. The car runs perfect. doesn’t make any unusual noises. The message though will come on every time I start the car (just started in about November when we started to get snow/cold weather) if I park the car, turn it off, run into a gas station, run back out, start the car, the message wont pop up, guessing because the car is hot. it doesn’t over heat, sits right at the perfect mark on my dash. The other thing is also when I hit that "check" button on my dash, it says Check Cleared, All ok (or w/e it usually says) so it’s like... ok u say my coolant needs to be checked but now it’s ok 15 seconds later?

I’m just asking this so I know when I bring it in maybe I’ll be able to save some money and have some of these not fixed. (id love for them all to be fixed but clearly moneys an issue and I can only afford to get the coolant issue fixed, and an oil change)

If the battery issue is huge and I’m wrong about my guess then that needs to be fixed of course too, but any feedback that may save me some money for the time being and just basically get me to work for the next few months would be helpful.

Thank you everyone!


1998 BMW 3-series 328i Automatic. Great condition, per mechanic before i bought it, he did a full 1 hour run down and he said nothing looked replaced. everything looked great and there is not a single problem with the car. i have not driven this car like the way its suppose to, i go the speed limit, dont excelerate fast. so im treatnig it the way the car should be.

Last edited by brinkstar; 02-03-2010 at 02:08 PM.
brinkstar is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-03-2010, 03:49 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,700
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Have you checked the power steering fluid level?

BMW

Sig by zeaq
witeshark is offline  
#3 (permalink) Old 02-04-2010, 05:48 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
#1 As W/S has suggested

#2 Charge the battery overnight, if it still plays up I would suspect a new battery required....battery life 3-7 years, date should be on battery.

#3 coolant level sensor = replace or check connection.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
new, and so many questions t530i New Members Check In 6 07-17-2008 08:24 PM
2 questions ???? chrismcl05 3-Series (E36) 9 09-25-2006 05:55 PM
Two Questions dvmotorsports 3-Series (E36) 6 05-17-2005 10:30 PM
A few questions on 95-99 M3 no_bimmer M-Series (M1, M3, M5, M6) 16 06-22-2004 05:17 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome