Engine pinging is drivin me nuts! - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-21-2004, 09:22 PM   #1 (permalink)
n00b
 
Join Date: Jun 2004
Car:
Posts: 2
Photos:
DCrew is an unknown quantity at this point
The pinging from my '93 325i has gotten so bad it's starting to sound like a 240D. No chip, Amoco Gold, 64K miles. Moderate acceleration in any gear, even pulling away from a stop. I understand this isn't uncommon with these motors...what is the cure? Thanks everyone from a NEW member...

Dave
DCrew is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-21-2004, 10:07 PM   #2 (permalink)
n00b
 
dport's Avatar
 
Join Date: Jun 2004
Location: Lenexa, Ks
Car:
Posts: 29
Photos:
dport is an unknown quantity at this point
I believe the cars have a knock sensor to prevent that. You might get that checked out. Is Amoco gold 87 or 89 octane? It is not unusual for older cars to want more octane. Is your tune up current?
__________________
<img src='http://img.photobucket.com/albums/v417/dport135/newsig.jpg' border='0' alt='user posted image' />
'95 318i Brembo Sport Rotors, B &amp; G Springs, Tokico Shocks/Struts
dport is offline   Reply With Quote
Old 06-21-2004, 10:37 PM   #3 (permalink)
ex owner/admin
 
Furious's Avatar
 
Join Date: Nov 2002
Location: Toronto-Canada
Car: turbo e36 325/s50 and e46 330xi
Posts: 10,839
Photos:
Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious
Send a message via AIM to Furious
yeah sounds like the knock sensor is out or something, that or the gas is not up to par. i run 91-94 octane and with a chip to boot, no pinging for me.

lastly try some fuel treatment, and see if it helps.

(i like using the one from lucas)
__________________
Furious is offline   Reply With Quote
Old 06-22-2004, 12:06 PM   #4 (permalink)
n00b
 
Join Date: Jun 2004
Car:
Posts: 2
Photos:
DCrew is an unknown quantity at this point
Amoco Gold is 92 octane. I had an inspection II done about three months ago, so the plugs, etc are all new.

I'm told that if the knock sensors are bad it will leave a fault code on the OBD, and will also make the engine light come on. Neither has happened. If there's an expert on knock sensors please tell me if this is correct and if they could be the problem. They're darned expensive to change without being sure.

Thanks again,
Dave
DCrew is offline   Reply With Quote
Old 06-22-2004, 01:45 PM   #5 (permalink)
5th Gear Member
 
Silver4evr's Avatar
 
Join Date: Dec 2003
Location: Los Angeles
Car:
Posts: 1,800
Photos:
Silver4evr is an unknown quantity at this point
Are you losing aceleration?
What does the dealer say?
Have the tech go with you on a test ride.
They should be able to figure it out. That's their job. If they can't, find another mechanic.
__________________
2004 E60 530is, Delivered 12/12/03, TiSilver/LGrey, PP, SP,PS, PDC, ACC, FRS, Step, Xenons, clear bra, body colored rear inserts. (Retired, 1983 henna red 320is)

2004 Corvette Z06 Commemorative Edition
Silver4evr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help...92 318I Gas Engine Sounds Like a Diesel ? DougJP 3-Series (E36) 13 04-10-2006 11:56 PM
Bad Engine Idle And Fault Not Found.. Paraklas 3-Series (E21, E30) 10 06-16-2005 09:25 PM
BMW P83 Engine triggrhaapi Bimmer Talk/Motorsports Talk 0 07-21-2003 02:03 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:35 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.