Engine has no power! - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-28-2004, 01:38 AM
n00b
 
Join Date: Jun 2004
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hugo is an unknown quantity at this point
(Thread Starter)
Talking

Hi this is my first time on this forum, and i need some help from you guys! Not long ago i purchased 1995 BMW 320i and already i have a problem with it. Car has no power at the start. I put it into first gear, let the clutch go, press the gas pedal and NOTHING! It accelerate very slowly and when it comes to 30 km/h (4000-5000 rpm) i can feel SOME power coming back but not all of it. I just want to mention that the fuel economy is still ok (8-9 L per 100 km), and that the clutch is still OK. If anyone knows what the problem could be please let me know!

Thanx!
hugo is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-28-2004, 12:35 PM
4th Gear Member
 
BlantonG13's Avatar
 
Join Date: Dec 2003
Location: Florence, NJ
Posts: 812
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BlantonG13 is an unknown quantity at this point
Send a message via AIM to BlantonG13
you aren't supposed to put water in the gas tank...jk...


is it possible you are missing the gear? what you thought was first, maybe you keep missing and putting it in 3rd? I know it sounds really dumb, but it happens. How long have you been driving stick?

Also, does your car Rev up in neutral quick or is that slow as well? Its possible that your throttle body may be messed up or you could have a messed up fuel delivery system...

1996 318i
5 Speed Manual

Alpine CDA-7895 Head Unit
12" Alpine Type-R, sealed box
Pioneer 400w amp for $20 at a yard sale (to replace my fried MRV-1507)
Infinity Kappa 4" 2-way speakers(rear)
Infinity Kappa 5.25" component speakers(front)
Debaffled airbox, K&N filter
Tracked Mud on carpets
Shampooed and cleaned carpets
BlantonG13 is offline  
#3 (permalink) Old 06-28-2004, 01:21 PM
You Can Has A Custom Title!!
 
thekid's Avatar
 
Join Date: Jan 2004
Location: Jackson MS
Posts: 3,445
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute
there is a lot that it could be. You prolly need to break down and take it to a mechanic. But also remember the 320i is slower than the 318i. That I6 doesn't make enough power for the added weight of the car. But I do still think that something is wrong.
thekid is offline  
#4 (permalink) Old 06-28-2004, 02:05 PM
n00b
 
Join Date: Jun 2004
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hugo is an unknown quantity at this point
(Thread Starter)
I just check it with the computer and Oxigen sensor is gone. So i'm gonna put new one in and see how it goes!

Thank you once again!
hugo is offline  
#5 (permalink) Old 06-29-2004, 12:30 AM
4th Gear Member
 
BlantonG13's Avatar
 
Join Date: Dec 2003
Location: Florence, NJ
Posts: 812
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BlantonG13 is an unknown quantity at this point
Send a message via AIM to BlantonG13
Wow, it was just missing the Oxygen sensor all together??? Smack the person that you bought it from. Well, now you will get the Driving Experience you had been hoping for! Goodluck and enjoy!

1996 318i
5 Speed Manual

Alpine CDA-7895 Head Unit
12" Alpine Type-R, sealed box
Pioneer 400w amp for $20 at a yard sale (to replace my fried MRV-1507)
Infinity Kappa 4" 2-way speakers(rear)
Infinity Kappa 5.25" component speakers(front)
Debaffled airbox, K&N filter
Tracked Mud on carpets
Shampooed and cleaned carpets
BlantonG13 is offline  
#6 (permalink) Old 06-29-2004, 02:59 AM
350z
 
Join Date: Nov 2003
Posts: 4,932
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bigred318 is an unknown quantity at this point
Send a message via MSN to bigred318 Send a message via Yahoo to bigred318
Quote:
Originally posted by BlantonG13@Jun 29 2004, 12:10 AM
Wow, it was just missing the Oxygen sensor all together??? Smack the person that you bought it from. Well, now you will get the Driving Experience you had been hoping for! Goodluck and enjoy!
umm im not sure if he meant it is gone like not there or just not working, becuase wouldnt the car not work if it wasnt there? im not sure, i was going to say that or maybe put some fuel injector cleaner in there and see what happens still might be a good idea!!! also missing repeatdly and going to 3rd would have been sooo funny hahahaha ghead ghead

David
bigred318 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help...92 318I Gas Engine Sounds Like a Diesel ? DougJP 3-Series (E36) 13 04-11-2006 12:56 AM
Bad Engine Idle And Fault Not Found.. Paraklas 3-Series (E21, E30) 10 06-16-2005 10:25 PM
BMW P83 Engine triggrhaapi Bimmer Talk/Motorsports Talk 0 07-21-2003 03:03 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome