E36 325I acceleration performance issues!!! - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-24-2009, 03:33 PM
n00b
 
Join Date: Jun 2009
Location: Tennessee
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
flheat23 is on a distinguished road
(Thread Starter)
Unhappy E36 325I acceleration performance issues!!!

I just purchased a 92 325i. Car has 198k on it. The problem I'm having is the acceleration(Med-Heavy) is bogging the engine down. I was reading the threads and just unscrewed the MAF and took it for a run and it pulled a whole lot better, especially in 1 & 2. But in 3 and 4 at 2200-2500 I can feel the bog through the gas pedal as if it's choking itself, and you can forget 5th unless I'm on the highway. It will get up and go, just sluggish. It seems I'm constantly downshifting more or pulling higher RPM's before the next gear to have the right power for that gear. I opened the hood and removed the dirty airfilter housing and kept the MAF unplugged and noticed when reved hard, a very very small pop in the exhaust plus a slight rich mixture smell. So, I know my MAF sensor is shot, but i'm stuck on what to do next??? At least I can pull out smoothly in 1st and 2nd with the MAF disconnected. Any help would be greatly appreciated.

P.S I'm sure there are alot of Bimmer owners who have this problem and need a solid fix for it. Thanks flheat23
flheat23 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-25-2009, 04:33 PM
n00b
 
Join Date: Jun 2009
Location: Tennessee
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
flheat23 is on a distinguished road
(Thread Starter)
I messed around with the car today and I noticed that when I disconnected the MAF sensor unit from the intake box and placed my hand against it, the car didn't die. So it was sucking air from somewhere. So, I tightened the C-clamp on the intake hose from the throttle body and it sucked much better, then died like it should, just not quick enouph. I re-connected the MAF plug and there was a much bigger difference than like it was before. I also noticed there was a big gash in the intake hose from dryrot that I hadn't noticed. I replaced the hose and acceleration is still bogging down, but much better. I then placed a vacuum gage to the crank case breather return tube and I oly got 3-5 psi which is garbage. I guess I have to get a mechanic stethoscope and start listening for leaks and replacing hoses. That's what I think is causing the hesitation, miss, rich mixture, and small backfire from exhaust. We'll see. It's funny, I have no check engine light or rpm fluctuation.

If anyone has any better suggestions, please feel free to put your input. Thanks guys/and gals!!
flheat23 is offline  
#3 (permalink) Old 06-26-2009, 05:14 AM
n00b
 
Join Date: Feb 2009
Location: Dublin, Ireland
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Shanew1983 is on a distinguished road
Crank shaft positioning sensor all the way mate

Id do that next
Shanew1983 is offline  
#4 (permalink) Old 06-26-2009, 08:41 AM
n00b
 
Join Date: Jun 2009
Location: Tennessee
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
flheat23 is on a distinguished road
(Thread Starter)
I will check the crank position sensor as well. Thanks!
flheat23 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting issues on my e36... Yazz325Ci 3-Series (E36) 2 04-05-2009 07:08 PM
e36 ews issues benji78 3-Series (E36) 0 05-06-2008 03:47 PM
Need help with an E36, acceleration. beaner10 3-Series (E36) 11 03-22-2008 04:19 AM
Tms Performance Chip, E36 325i Obd1, 402 Dme nascam Classifieds Sell & Buy 3 12-02-2004 07:53 AM
climate issues with 325i 93 cap77 3-Series (E36) 3 09-09-2004 09:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome