e36 320 Engine intermitant problem got worse - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-07-2009, 08:39 AM
n00b
 
Join Date: Mar 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
maverick1426 is on a distinguished road
(Thread Starter)
e36 320 Engine intermitant problem got worse

My intermitant engine problem just got worse. Engine use to start to misfire and run rough when heater guage reach just over the blue mark and conk out, but was fine after restart and would be for the rest of the day, but same would happen next day.... Now can't get engine to run above 2000 with out losing power and misfires/popping... Any idea's
maverick1426 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-07-2009, 10:36 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Could be the coil.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#3 (permalink) Old 03-08-2009, 07:53 AM
1st Gear Member
 
vincentmb615's Avatar
 
Join Date: Sep 2008
Location: cape
Posts: 204
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
vincentmb615 is on a distinguished road
Send a message via AIM to vincentmb615
yeah you have a bad coil maybe a couple do the plugs when looking at the old ones you cant tell what one hasnt been firing

[94 325i two toned
vincentmb615 is offline  
#4 (permalink) Old 03-08-2009, 11:40 AM
Neutral Member
 
basrite's Avatar
 
Join Date: Feb 2009
Location: Brisbane
Posts: 81
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
basrite is on a distinguished road
Maverick,

Yeah my 320 doesn't like above the blue bar.. get huge flat spots and hesitation until it hits operating temperature.

I put back the factory air box and installed a K&N panel filter.. most of the issues have gone.. only a slight hesitation now (compared to what it was). Some days it will be a pig and just flat spot huge time tho. (bye bye to the pod filter).

I've got a feeling its the MAF that is playing up.. but I cant find any references as to whether the computer has a open/closed loop mode and whether it uses the MAF while cold to make sure that is the culprit.

Eg: Hop onto highway at 80kmh... put foot down nothing.. 5 seconds later it accelerates (but not as hard as when warmed up).

Hopefully we can team together to fix this issue!

J.

Yes... i'm a total car nut! Why else would I upgrade my mower to rev to twice its standard rpm!
basrite is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
3k+ Rev problem on E36, M44 Engine StumpsterDHR 3-Series (E36) 13 03-05-2009 04:09 PM
1997 e36 325tds Engine Problem diesel power New Members Check In 2 06-26-2008 10:38 PM
92 325 intermitant starting problem frankinbarnes 3-Series (E36) 7 04-23-2008 06:06 AM
BMW E46 (320) Saloon problem Bmkinili 3-Series (E46, E90) 3 07-10-2004 11:49 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome