E36 1998 3.18i random misfire, lose power check engine light - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-21-2008, 01:32 AM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
E36 1998 3.18i random misfire, lose power check engine light

Hi everybody,
This is my first post; I read a lot of good advice in this site so I hope I will get some suggestions because I really need help. The problem persists for over 2 years now and I am sick of trying. I bought my car little over two years ago it had the check engine light on but I thought I bought it cheap and have it fixed somehow. After two years and lots of $$ I still have the light on and the problem is there. Here is what happens: The car runs normal most of the time randomly it starts misfiring and loses power I try to pinpoint when this happens but I really cannot sometime it happens when the car is cold sometimes when it is hot and under load. The codes I saw so far are usually multiple misfire followed by some of the specific cylinders but not the same ones all the time. In these two years I have several parts changed with no result I had car run with no problem weeks and then the problem reoccurs. Here is a list and date of the parts changed just to fix this problem:
1) 22-07-2006 Fuel filter and spark plugs changed
2) 28-12-2006 Checked air valves, replaced air valve and hose
3) 13-01-2007 Crank position sensor replaced
4) 21-02-2007 Ignition wires and mass air sensor (used part) replaced, the coil pack swapped and tested did not resolve the problem so old one was left on the car. After mass air sensor replaced the problem disappeared for a long time (5-6 months)
5) When the problem re occurred I cleaned the Mass Air sensor and this temporarily fixed the problem (or it was a coincidence) so I decided to buy a new sensor I put it in 15-05-2008 and after resetting the CEL drive the car for a while and the light came on again with the same problems. I found the breather hose going to valve cover was lose and tighten it the car drive fine for a day I cleared the codes but today it start misfiring again no CEL yet but I am sure it will come on if I drive a long distance.

So here is my never ending problem, the car drives very nice most of the time but fails occasionally. Never died on me or had problem starting. I would appreciate any suggestions or advice a good mechanic in Pasadena, CA. I took the car to 3 dealers and a privet shop most of the parts replaced in this shop, I like them but I am sick of trying parts. The dealers were useless I think they do not need any more business in this area .

Thanks for all the help.
cson is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-21-2008, 01:44 AM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
what is the Check engine light Code it is throwing???? Also have you checked the o2 sensor?

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#3 (permalink) Old 05-21-2008, 01:57 AM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
Thanks for quick response I was not expecting a replay this fast. I can not remeber all but will write them down this time after the reset. There was 6 of them this morning. Multiple misfiring and two of the cylinders can't remember which ones. Hot film Mass air sensor, this might be due to my fault I took the wires of the Mass Air sensor during idel. There was an other sensor fault but I can't remember which. The mechanic cleared them so fast I could not catch all of them. I am thinking to buy a reader and read them myself.

Thanks
cson is offline  
#4 (permalink) Old 05-21-2008, 02:01 AM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
The O2 sensors, there was not a fault code about them but the car has 130000 miles so That is my next quess, but I thought they should trow a code if they are bad. The gas mileage is not too bad I go 300 - 350 miles till the light came on.
cson is offline  
#5 (permalink) Old 05-21-2008, 02:09 AM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
One more thing I remembered, one of the delers said the problem is the catalytic converter. However these guys had the car all day and I called them at the end of the day and they said they couldn't had time to check the car I said i am coming toget it and when I went there they said oh we checked it and it is going to cost you 1500-2000 to change the cat. I said no and took it to the privite shop and he said there is no code about the cat. So i don't know which one to trust anymore.
cson is offline  
#6 (permalink) Old 05-21-2008, 12:36 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
Quote:
Originally Posted by cson View Post
One more thing I remembered, one of the delers said the problem is the catalytic converter. However these guys had the car all day and I called them at the end of the day and they said they couldn't had time to check the car I said i am coming toget it and when I went there they said oh we checked it and it is going to cost you 1500-2000 to change the cat. I said no and took it to the privite shop and he said there is no code about the cat. So i don't know which one to trust anymore.
I DONT beleve it is your cat... get the codes ran an get back to me!

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#7 (permalink) Old 05-21-2008, 12:53 PM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
Thanks i did not think so either,
dealer usually picks the most expensive part to start testing. The CEL did not come again after the reset and the hose tightining. I will post the codes once I get the light back on. I drived nice this morning with no problem.
cson is offline  
#8 (permalink) Old 05-21-2008, 01:38 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
ok! the codes usually are stored... next time in comes on get the codes read and post them on here it will help alot!

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#9 (permalink) Old 05-21-2008, 02:07 PM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
I thought when you erase them with the tool they well been erased. Do you think they are still stored some how? Wellif I drive more then 30-40 miles on highway I am sure they will come back. If not and if the problem don't show up again well that is fine with me too, but I am sure it is not been fixed.
cson is offline  
#10 (permalink) Old 05-21-2008, 02:15 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
no if you clear them with a scanner they go away... Good luck!

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#11 (permalink) Old 05-21-2008, 10:01 PM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
Well I think it was a scanner, I can not get any codes, I will wait till they come back. I realized the air mass meter boot and the other plastic hose that attached to the engine (I need the name or part number for this one) are craced. They do not look like they leak air but it is something cheap to replace. I also want to change the air filter housing it is broken and I don't think it is air tight. Do you think a cold air intake will work for this car, if yes which one, if not what is the part number for the original housing. Thanks.
cson is offline  
#12 (permalink) Old 05-21-2008, 10:15 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,699
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Cracks in the air to engine parts caused my E30 to idle very rough. It causes the air coming in to be erratic.

BMW

Sig by zeaq
witeshark is offline  
#13 (permalink) Old 05-22-2008, 12:15 AM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
I saw several posts related to these hoses, I need the part number for the one that is attached to the engine not to the mass air sensor on my car. Do anybody know how can I find it. I hope this is the reason but I am not that sure.
cson is offline  
#14 (permalink) Old 05-22-2008, 11:56 AM
n00b
 
Join Date: May 2008
Location: Jamaica
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
giarc is on a distinguished road
Send a message via MSN to giarc Send a message via Yahoo to giarc
OK try getting some injector or carb cleaner and spray it at various points on the hoses and even the area around the throttle body and note any changes in the throttling and there you'll have your leak.
giarc is offline  
#15 (permalink) Old 05-23-2008, 04:36 PM
n00b
 
Join Date: May 2008
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cson is on a distinguished road
(Thread Starter)
I will try it this weekend thanks for the advice. After I tighten the hose the car runs much nicer and only had very minor hickups so I thnk most of the leak was from this hose. We will see I need to drive it a little longer as I had weeks without an incident.
cson is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
92 e36 fault codes? check engine light seven 3-Series (E36) 1 11-15-2006 03:50 PM
E36 Check Engine Light Goes On After atm2000 3-Series (E36) 6 03-28-2005 06:50 PM
Check Light And Check Engine Light 325is1994 3-Series (E36) 9 01-12-2005 01:36 PM
Check Engine Light & Air Bar Light blackstallion 3-Series (E36) 1 11-11-2004 11:53 AM
loud engine noise and check engine light steviebhoy 3-Series (E36) 4 06-04-2004 06:59 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome