dead cluster - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-15-2004, 01:51 PM   #1 (permalink)
n00b
 
Join Date: Apr 2004
Car:
Posts: 2
Photos:
jhun is an unknown quantity at this point
I recently brought a 94 325 I was on my way home the other night when my instrument cluster died, the temp, fuel, and tach, died the speedo still works but is not accurate as the computer seems to be more accurate any idea where to begin to look for the problem, could it be a short somewhere else.
jhun is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2004, 01:55 PM   #2 (permalink)
You Can Has A Custom Title!!
 
Join Date: Jan 2004
Location: Eugene Oregon
Car: 2008 128i
Posts: 2,718
Photos:
007ben is an unknown quantity at this point
Send a message via AIM to 007ben Send a message via Yahoo to 007ben
did you check fuses?
__________________
2008 128i Jetblack
007ben is offline   Reply With Quote
Old 04-15-2004, 02:00 PM   #3 (permalink)
n00b
 
Join Date: Apr 2004
Car:
Posts: 2
Photos:
jhun is an unknown quantity at this point
yes there all good, another problem i'm having is that when i push the temp button on the computer it reads -35degrees does anyone think the problem is related
jhun is offline   Reply With Quote
Old 04-15-2004, 02:17 PM   #4 (permalink)
You Can Has A Custom Title!!
 
Join Date: Jan 2004
Location: Eugene Oregon
Car: 2008 128i
Posts: 2,718
Photos:
007ben is an unknown quantity at this point
Send a message via AIM to 007ben Send a message via Yahoo to 007ben
the temp being that low is most likely the temp sensor missing.

the cluster may just be dead... does it ever do anything other than the speedo?
__________________
2008 128i Jetblack
007ben is offline   Reply With Quote
Old 04-15-2004, 03:11 PM   #5 (permalink)
ex owner/admin
 
Furious's Avatar
 
Join Date: Nov 2002
Location: Toronto-Canada
Car: turbo e36 325/s50 and e46 330xi
Posts: 10,839
Photos:
Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious
Send a message via AIM to Furious
very common, mines been on and off for about a year. you need to change the cluster itself. could be a wire, but chances lay that its the cluster.
__________________
Furious is offline   Reply With Quote
Old 04-18-2004, 12:18 PM   #6 (permalink)
1st Gear Member
 
kamikazinyc's Avatar
 
Join Date: Nov 2003
Car:
Posts: 242
Photos:
kamikazinyc is an unknown quantity at this point
I just changed mine cluster got 2 diff face plate but I like mine old one better so I swaped the plate will post some pix later every thing else speed fule temp works but the RPM is 1000 off I think(slow).
__________________
DREMEL is South Africa Engineer's best friend
<span style='color:blue'>HID all the way </span>
kamikazinyc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
M5 Cluster in a 540i, will it work? ///Matt 5-Series (E12,E28, E34, E39, E60) 5 10-13-2005 10:26 AM
Instrument Cluster Wiring spinkb 3-Series (E21, E30) 6 03-06-2005 08:39 AM
Instrument cluster removal shaman97 3-Series (E21, E30) 5 07-01-2004 03:13 PM
new instrument cluster. hodges 3-Series (E36) 7 05-30-2003 07:49 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:23 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.