dead cluster - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-15-2004, 02:51 PM
n00b
 
Join Date: Apr 2004
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jhun is an unknown quantity at this point
(Thread Starter)
I recently brought a 94 325 I was on my way home the other night when my instrument cluster died, the temp, fuel, and tach, died the speedo still works but is not accurate as the computer seems to be more accurate any idea where to begin to look for the problem, could it be a short somewhere else.
jhun is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-15-2004, 02:55 PM
You Can Has A Custom Title!!
 
Join Date: Jan 2004
Location: Eugene Oregon
Posts: 2,718
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
007ben is an unknown quantity at this point
Send a message via AIM to 007ben Send a message via Yahoo to 007ben
did you check fuses?

2008 128i Jetblack
007ben is offline  
#3 (permalink) Old 04-15-2004, 03:00 PM
n00b
 
Join Date: Apr 2004
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jhun is an unknown quantity at this point
(Thread Starter)
yes there all good, another problem i'm having is that when i push the temp button on the computer it reads -35degrees does anyone think the problem is related
jhun is offline  
#4 (permalink) Old 04-15-2004, 03:17 PM
You Can Has A Custom Title!!
 
Join Date: Jan 2004
Location: Eugene Oregon
Posts: 2,718
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
007ben is an unknown quantity at this point
Send a message via AIM to 007ben Send a message via Yahoo to 007ben
the temp being that low is most likely the temp sensor missing.

the cluster may just be dead... does it ever do anything other than the speedo?

2008 128i Jetblack
007ben is offline  
#5 (permalink) Old 04-15-2004, 04:11 PM
ex owner/admin
 
Furious's Avatar
 
Join Date: Nov 2002
Location: Toronto-Canada
Posts: 10,839
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious
Send a message via AIM to Furious
very common, mines been on and off for about a year. you need to change the cluster itself. could be a wire, but chances lay that its the cluster.

Furious is offline  
#6 (permalink) Old 04-18-2004, 01:18 PM
1st Gear Member
 
kamikazinyc's Avatar
 
Join Date: Nov 2003
Posts: 242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kamikazinyc is an unknown quantity at this point
I just changed mine cluster got 2 diff face plate but I like mine old one better so I swaped the plate will post some pix later every thing else speed fule temp works but the RPM is 1000 off I think(slow).

DREMEL is South Africa Engineer's best friend
<span style='color:blue'>HID all the way </span>
kamikazinyc is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
M5 Cluster in a 540i, will it work? ///Matt 5-Series (E12,E28, E34, E39, E60) 5 10-13-2005 11:26 AM
Instrument Cluster Wiring spinkb 3-Series (E21, E30) 6 03-06-2005 09:39 AM
Instrument cluster removal shaman97 3-Series (E21, E30) 5 07-01-2004 04:13 PM
new instrument cluster. hodges 3-Series (E36) 7 05-30-2003 08:49 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome