dash issues 92 325is - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-07-2009, 04:33 PM   #1 (permalink)
1st Gear Member
 
hunter325i's Avatar
 
Join Date: Jan 2007
Location: southern california
Car: 1993 325is
Posts: 150
Photos:
hunter325i is on a distinguished road
dash issues 92 325is

yesterday i noticed while i was driving to work that the only meter on my dash that was working was my speedometer. All of the lights work on my dash, but all the needles are all the way down to the left. also my oil lights are all out of wack. they stay lit while im driving but they flicker while i drive. i checked all the fuses relating to the dash, but all is good there. now i know BMW is infamous for linking multiple fuses to multiple things, but what??? if anybody has any ideas i would greatly appreciate it

thanks
__________________
hunter325i is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-07-2009, 10:23 PM   #2 (permalink)
n00b
 
Join Date: Sep 2008
Car:
Posts: 23
Photos:
felixr78 is on a distinguished road
Quote:
Originally Posted by hunter325i View Post
yesterday i noticed while i was driving to work that the only meter on my dash that was working was my speedometer. All of the lights work on my dash, but all the needles are all the way down to the left. also my oil lights are all out of wack. they stay lit while im driving but they flicker while i drive. i checked all the fuses relating to the dash, but all is good there. now i know BMW is infamous for linking multiple fuses to multiple things, but what??? if anybody has any ideas i would greatly appreciate it

thanks
I'm having the same problem my temperature gauge it works whenever it wants to. It goes all the way to the hot side when the car is On and if i turned off and then On again it goes to the cold side. I feel you pain my friend hopefully someone will help us.Good Luck!!!
felixr78 is offline   Reply With Quote
Old 02-08-2009, 03:59 AM   #3 (permalink)
n00b
 
540red's Avatar
 
Join Date: Oct 2008
Location: Christchurch. New Zealand
Car: E34 540. Lexus Altezza. RX7
Posts: 32
Photos:
540red is on a distinguished road
Electrics

I look forward to the solution for your question. Currently, my 325 has everything out except the speedo so there must be an answer. Cheers. Kelvin Hunter
540red is offline   Reply With Quote
Old 02-08-2009, 10:53 AM   #4 (permalink)
1st Gear Member
 
hunter325i's Avatar
 
Join Date: Jan 2007
Location: southern california
Car: 1993 325is
Posts: 150
Photos:
hunter325i is on a distinguished road
well at least im not the only one haha but yes anybody with an answer would be good because its not really fun trying to measure out my gas amount by mileage haha
__________________
hunter325i is offline   Reply With Quote
Old 02-08-2009, 02:24 PM   #5 (permalink)
n00b
 
Join Date: Nov 2008
Location: belfast
Car: 98 bmw 318is e36
Posts: 15
Photos:
head12345 is on a distinguished road
have you tried taking your dial cluster out and checking that your connection hasnt come lose.or replacing the fuses instead of just checking them as when my headlight blow the fuse looked ok but when i replaced it just to see if it made a difference it worked.
head12345 is offline   Reply With Quote
Old 02-08-2009, 10:39 PM   #6 (permalink)
1st Gear Member
 
hunter325i's Avatar
 
Join Date: Jan 2007
Location: southern california
Car: 1993 325is
Posts: 150
Photos:
hunter325i is on a distinguished road
Quote:
Originally Posted by head12345 View Post
have you tried taking your dial cluster out and checking that your connection hasnt come lose.or replacing the fuses instead of just checking them as when my headlight blow the fuse looked ok but when i replaced it just to see if it made a difference it worked.
ill have to swap them out to see if that help....thanks
__________________
hunter325i is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1988 325is idle issues! HELP! 325isBMW1988 3-Series (E21, E30) 19 09-19-2008 04:35 PM
A/c Issues PR bimmer 3-Series (E46, E90) 1 02-27-2008 02:29 AM
PLEASE HELP serious climate control issues 1994 325is!!!!!!!! kevinl34 3-Series (E36) 0 05-06-2007 08:29 PM
Wtb 1985 1988 325is Dash midniter Classifieds Sell & Buy 1 10-29-2004 02:00 AM
More AC issues wulley1 3-Series (E36) 13 05-28-2004 06:31 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:13 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.