Cluster Problems - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-27-2005, 05:08 PM   #1 (permalink)
n00b
 
Join Date: Jan 2005
Car:
Posts: 11
Photos:
spoolindynamics is an unknown quantity at this point
a guys my cluster is weird... first the MPG stick disapears after i start the car... and my MPH seems to be sticky cuz it wont move fer shit... i thought it was the fuses so i changed them but still nothin new... any idea...??? used
__________________
C:\Documents and Settings\Cabanban Family\My Documents\My Pictures\Car
spoolindynamics is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-28-2005, 03:18 AM   #2 (permalink)
Neutral Member
 
Join Date: Aug 2004
Car:
Posts: 91
Photos:
Clint_M is an unknown quantity at this point
the tachometer will always dissapear when you start the car, as its resting position is out of sigh up behind the edge of the lip.

As for the MPH not moving, is it not moving AT ALL? or does it move sometimes and other times it sticks?

If its not moving at ALL, it could be:

busted needle/needle springs
There might be a speedometer sender gauge (i belive there is one in the inline 6's)
Electrical fault somewhere, although from reading my manual the speedo,rev counter, fuel meter and tachometer are on the same circuit so if it was electrical, they would all fail at the same time if there was a dodgey wire/break in the circuit, like on my bloody car!

At my 1st guess on the speedo, id say the springs underneath the needle may have been messed around with.
Clint_M is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Cluster Problems Majin 3-Series (E21, E30) 0 06-14-2005 03:16 PM
instrument cluster problems okczy21 3-Series (E36) 2 09-01-2004 07:05 PM
gauge cluster problems daxsandman 3-Series (E21, E30) 0 07-29-2004 05:48 PM
Cluster problems al10594 3-Series (E36) 2 06-10-2004 01:16 PM
Gauge Cluster Problems spoonman 3-Series (E46, E90) 1 12-31-2003 11:22 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:35 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.