Climate control/blower electrical connection problem? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-30-2007, 12:59 AM   #1 (permalink)
n00b
 
Join Date: Oct 2004
Car:
Posts: 23
Photos:
gfowler is an unknown quantity at this point
Climate control/blower electrical connection problem?

Recently, the power on my '96 328i climate control unit (fan/blower and all it's lights & functions) cuts on and off, seemingly an electrical connection problem. When it's on, all functions work fine. Then the whole thing will simply cut off (about half the time), and suddenly "pop" back on the other half. A couple of years ago I had a new blower installed along with new resistor, so those should (normally) still be good. Is there a chance this problem could be due to anything related to the fuse box or a bad relay? That would be the easy thing for me, outside of that I'm afraid I'd have to pay a BMW mechanic to find where the problem lies. What things could I check?
Thanks!
gfowler is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-30-2007, 03:50 PM   #2 (permalink)
1st Gear Member
 
paco1076's Avatar
 
Join Date: Jan 2006
Location: Frederick, MD
Car: 1997 BMW M3
Posts: 130
Photos:
paco1076 is on a distinguished road
Send a message via AIM to paco1076
I had a similar issue and had a burnt fuse connector in my fuse/relay box under the hood. There should be a thread on here about it with pictures...
__________________
1997 E36 M3 - running stocker style right now...
paco1076 is offline   Reply With Quote
Old 03-30-2007, 03:51 PM   #3 (permalink)
1st Gear Member
 
paco1076's Avatar
 
Join Date: Jan 2006
Location: Frederick, MD
Car: 1997 BMW M3
Posts: 130
Photos:
paco1076 is on a distinguished road
Send a message via AIM to paco1076
http://www.bimmerwerkz.com/forum/3-s...ter-50800.html

Try that link...
__________________
1997 E36 M3 - running stocker style right now...
paco1076 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desperately Need Your Help: BMW325i "Service Engine Soon" light problem CNMB250 3-Series (E46, E90) 4 12-19-2007 06:26 AM
Climate control fan problem botswana 3-Series (E46, E90) 2 01-08-2006 09:09 PM
Need The Experts-mysterious Electrical Problem??? JonnyM3 3-Series (E36) 6 12-06-2004 07:04 PM
Electrical Problem? akrauss 3-Series (E46, E90) 14 08-11-2003 03:43 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:54 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.