Check Engine Light - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-06-2004, 05:25 PM   #1 (permalink)
n00b
 
Join Date: Jul 2004
Car:
Posts: 2
Photos:
tomszafranski is an unknown quantity at this point
First time here folks. My 1992 325i starts running rough when warmed up. It runs ok until it gets warm then the check eng light comes on and often turns off only to return again. When it comes on I know it's going to run poorly. At it's worst, it'll cut off when I come to a stop. I bought it when it had 92,000 and it now has 145,000. I have not put a new O2 sensor in it yet. I'm taking it in tomorrow could use your input.

Thanks,

Tom
tomszafranski is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-06-2004, 05:28 PM   #2 (permalink)
You Can Has A Custom Title!!
 
Kevin325i's Avatar
 
Join Date: Mar 2004
Location: Madison, WI
Car:
Posts: 2,613
Photos:
Kevin325i is an unknown quantity at this point
Send a message via AIM to Kevin325i
Read out the codes with the pedal method. Turn ignition to position one then press the gas to the floor 5 times in 3 seconds, the CE will blink out the codes for you.

Kevin
__________________
Kevin (President TBEA)

"WAAAAAAARRRRRIORS, come out to plaaaaay."
Kevin325i is offline   Reply With Quote
Old 07-06-2004, 05:29 PM   #3 (permalink)
What? No Autobahn?
 
jrhaile's Avatar
 
Join Date: Jan 2004
Location: Spokane, Wa
Car: 2001 M5
Posts: 3,525
Photos:
jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile jrhaile
Send a message via ICQ to jrhaile Send a message via AIM to jrhaile Send a message via MSN to jrhaile


o2 sensor would be a good start... then check your idle control valve also referred to as idle speed control. might need to be cleaned or replaced...then you could have a cat going out but usually you smell something... also could be using wrong kind of oil...
__________________
jrhaile is offline   Reply With Quote
Old 07-06-2004, 05:55 PM   #4 (permalink)
n00b
 
Join Date: Jul 2004
Car:
Posts: 2
Photos:
tomszafranski is an unknown quantity at this point
I tried to get a read out by turning key to on pos and hit throttle 5 times to no avail. I tried twice. I didn't mention that when this started two days ago there was a strong sulfuric odor. I don't get that as long as I don't "get on it". I need to drive it about 6 miles to the shop. Will I incur any damage doing this?

Tom
tomszafranski is offline   Reply With Quote
Old 07-06-2004, 05:56 PM   #5 (permalink)
You Can Has A Custom Title!!
 
Kevin325i's Avatar
 
Join Date: Mar 2004
Location: Madison, WI
Car:
Posts: 2,613
Photos:
Kevin325i is an unknown quantity at this point
Send a message via AIM to Kevin325i
Sounds like a bad cat and it took the O2 sensor with it.

Kevin
__________________
Kevin (President TBEA)

"WAAAAAAARRRRRIORS, come out to plaaaaay."
Kevin325i is offline   Reply With Quote
Old 07-06-2004, 05:58 PM   #6 (permalink)
WOT in Reverse
 
jllphan's Avatar
 
Join Date: Jan 2004
Location: Cashville, TN
Car:
Posts: 3,441
Photos:
jllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond repute
Send a message via AIM to jllphan
No, you'll be ok. I'm no expert, but it does sound like the O2 sensor could be the problem. Just wonder why it failed. Never been changed and worn out, bad cat, cheap gas?
__________________
jllphan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light aheath 3-Series (E36) 1 04-27-2005 06:27 PM
Check Engine Light On, But Only When I Start Car BMW-ATI 3-Series (E36) 5 04-15-2005 09:40 PM
Check Engine Light & Air Bar Light blackstallion 3-Series (E36) 1 11-11-2004 11:53 AM
Red check engine light came on today YNGRVP 3-Series (E36) 9 05-28-2004 09:36 PM
Check Engine Light came on today camnipotent 3-Series (E36) 22 05-17-2004 06:23 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:04 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.