check engine issues 1221 code - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-31-2007, 06:50 PM
Neutral Member
 
Join Date: Nov 2006
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
seven is on a distinguished road
(Thread Starter)
check engine issues 1221 code

I have a problem with the o2 sensor. I had the check engine light come on 1221 code. o2 sensor no problem changed the sensor and the light went out. now it will come back on and go off sometimes quickly sometimes it takes a couple days. I notice no running problems. runs idles and the fuel mileage is the same. has anybody had this problem before? If so how did you fix it? Thanks for all your help in the past
seven is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-31-2007, 09:41 PM
Neutral Member
 
Join Date: Nov 2006
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
seven is on a distinguished road
(Thread Starter)
Forgot to mention the car is a 1993 325 is 5 speed. o2 sensor was replaced with a Bosch unit the car also has a Dinan cold air intake any help would be appreciated
seven is offline  
#3 (permalink) Old 10-03-2007, 09:57 AM
n00b
 
Join Date: Sep 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
spicer is on a distinguished road
was that the pre or post cat sensor?
spicer is offline  
#4 (permalink) Old 10-12-2007, 11:24 PM
Neutral Member
 
Join Date: Apr 2007
Location: Bergen, NY
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Marknhl is on a distinguished road
Send a message via AIM to Marknhl
I love BMW's but I think some of their sensors aren't the greatest. I replaced my O2 sensor with an $81 Bosch sensor a couple of months ago and I had the sensor turn on and off the other day. I was PISSED when I saw it come on and tested it manually finding out it was the O2 sensor again. The next day it was gone however, and I was happy again - ha. Hasn't turned on since. My onboard computer likes to tell me i'm low coolant all the time - common E36 problem from what I read here - it also likes to tell me there is a fault in the brake light system - haven't found one, lights work fine. My license plate light decided to turn off the other night as well. I figured out how to take it apart, did so, put it back together, and when I got to the auto parts store it was working fine. Go figure. Personally, I wouldn't even worry about it unless it happens excessively, and even then if the car is running fine and you can't find any issues..... unless anyone else has some thoughts....
Marknhl is offline  
#5 (permalink) Old 10-20-2007, 09:57 AM
Neutral Member
 
Join Date: Nov 2006
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
seven is on a distinguished road
(Thread Starter)
No running issues at all. my car always tell me the coolant is low and a license plate light failure. must be a common problem. I have decided not to worry about it I have pulled enough hair out
seven is offline  
#6 (permalink) Old 10-20-2007, 09:58 AM
Neutral Member
 
Join Date: Nov 2006
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
seven is on a distinguished road
(Thread Starter)
found the fix to the check engine light!!! a small piece of black tape on the dash and the light dissappears
seven is offline  
#7 (permalink) Old 10-20-2007, 10:25 AM
Neutral Member
 
Texbeamer's Avatar
 
Join Date: Oct 2007
Location: Texas
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Texbeamer is on a distinguished road
tape

Quote:
Originally Posted by seven
found the fix to the check engine light!!! a small piece of black tape on the dash and the light dissappears
Texbeamer is offline  
#8 (permalink) Old 10-28-2007, 07:35 PM
1st Gear Member
 
Join Date: Oct 2007
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
whosyadadie01 is on a distinguished road
lmfao i wish.. ive got a check engine light and when scanned it says o2 sensor voltage for the sensors i just replaced .. any idea if its cuz i used a universal o2 sensor and not a oem cuz it is missin on the cyl's they are connected to
whosyadadie01 is offline  
#9 (permalink) Old 10-29-2007, 09:16 AM
4th Gear Member
 
bimmerguy82's Avatar
 
Join Date: Mar 2005
Location: City of Rain, PNW
Posts: 884
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute bimmerguy82 has a reputation beyond repute
Send a message via MSN to bimmerguy82
Quote:
Originally Posted by seven
found the fix to the check engine light!!! a small piece of black tape on the dash and the light dissappears
Until something else more serious happens then you won't know until it's too late.

BMWcrazy
___________
-Joshua



|AA stage 1 software| UUC light flywheel and clutch| UUC EVO 3 ssk | K&N Intake | Ebay Headers |

BMWCCA member#407674

Founding member of the hit 145 mph in my almost stock 325i BMW club.
bimmerguy82 is offline  
#10 (permalink) Old 10-29-2007, 05:56 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
Quote:
Originally Posted by Texbeamer
+1

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#11 (permalink) Old 03-26-2008, 10:32 AM
n00b
 
Join Date: Mar 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jrw7714 is on a distinguished road
Reset the check engine light?

Anybody know how to reset the check engine light?
jrw7714 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help plz: Throwing Codes 251/253. Have full explanation, just need insight: pelotudo 3-Series (E36) 3 07-01-2006 04:50 PM
Check Engine Light aheath 3-Series (E36) 1 04-27-2005 06:27 PM
check engine maru 3-Series (E21, E30) 0 08-23-2004 07:55 PM
Warning! Cashier's Check Fraud L337E46 Classifieds Sell & Buy 2 03-06-2004 03:04 PM
service questions thamindzzeye 3-Series (E36) 4 04-30-2003 02:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome