Calling all fuel trim experts!! - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-20-2010, 12:53 AM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kazamali is on a distinguished road
(Thread Starter)
Calling all fuel trim experts!!

Hey guys,

I've been chasing a fuel trim issue for quite some time and need some expert help. I'm including a lot of data, so hopefully it will accelerate and narrow the areas of investigation.

The facts:

1999 E36 M3, 96k miles, Supercharged via AA Twin-screw (9lb psi), stock exhaust

-O2, MAF, Fuel filter and regulator replaced 1 year ago
-Spark plugs and fuel injectors replaced a few weeks ago
-Car throws 1188/1189 codes (fuel trim) consistently after a few "trips"
-Plugging in an OBDII data logger shows positive fuel trim(10% - %20+) all the way from idle, hard acceleration and cruising speed.
-Car has had supercharger for 4 years now and initially had trim issues when first installed(vacuum leak), but has run fine since for 2 solid years without issue
-Car is showing larger positive trim at cruising speed, not at idle (the latter usually indicates a vacuum leak as vacuum is larger at idle)
-Car shows no physical signs of issues (i.e. no limping, hesitation on acceleration, nor rough idle)

I just need some direction on where to go next since these codes are preventing a successful smog check (resetting the ECU doesn't work because the "monitors" in the ECU will reset). This is really looking like a vacuum leak issue (which, at this point, is going to require a smoke test because I've been over every hose and seal a million times), but I wanted to make sure if this is possibly pointing to a fuel pump failing or another MAF issue.

I'm hyperlinking graphs of a 5 mile trip that show values of short term fuel trim for both banks at different RPM/Throttle Position plot points AND MAF volume reports at the same plot points. (note that idle is at around 800 RPM and 15% Throttle angle and cruising speed is 3200 RPM and %30 Throttle Angle) On top of that, I also have a link that shows the same trip, but in a line graph showing the same values in a different way. Note that I've reset the adaptations to start off fresh and that's why the Long Term Fuel Trims are small (they WILL grow to %12 percent if I drive long enough).

I need someone to take a look and see if there's a definite smoking gun here so I don't blindly go and check a bunch of other things unnecessarily.

I'm trying to be as thorough here for you guys as much as possible, but let me know if I've missed anything.


Table of STFT and MAF readings

Graph of data (for the same trip)

Thanks!

Kazam
kazamali is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-22-2010, 01:25 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
My guess is vacuum leak i would Smoke the induction system...

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#3 (permalink) Old 08-17-2010, 06:45 PM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kazamali is on a distinguished road
(Thread Starter)
Solved!

So, sorry for the laaate update on this, but between vacations and mail-ordering supplies, it's taken a while. All in all, the resolution was:

**Active Autowerke's MAF Calibrator box**

Yep, that was it. The longer story:

I took everyone's feedback and had a smoke test and fuel pressure test done. I did find very minute issues with my fuel pump (it wasn't holding pressure as it should after the engine was shut off), but operating pressure was fine, nonetheless. Smoke test came out just fine too. (I had a guy in San Jose do both tests for less than a C-note). He smoked the SC and my valve cover. No issues.

So I took this data, plus the OBD log/fuel trim data and called Active Autowerke(Florida) where I bought my SC. Turns out the calibrator box they sent me to replace my failed one 1.5 years ago wasn't doing it's job properly. It was essentially underrreporting airflow and subsequently causing the O2's to up (waaaay up) the mix in response to a lean one. Since I wasn't due for smog at that time, I ignored the randome MIL's.

The SC kit I have was orginally using a 5-series MAF to accomodate the larger air flow and a "calibrator" box had to be used between it and the ECU to make it all work(voltage outputs are different). Active's subsequent, UPDATED, replacement for my failed one was apparently bogus, but they had a solution THIS TIME to use a Porsche MAF without the calibrator. Fine by me, because that would be one less part to fail in the future. I just needed to get my ECU reflashed to work with the new MAF's outputs. Long story short, I'm on the Porsche MAF, updated ECU, LTFT's came down to 0.8% and 1.6% and I passed CA smog today, legally. Woot!

So in short, here's what I learned: Before doing ANY type of crazy modifications to your engine/emissions, buy an OBDII logger and take baseline measurements on EVERYTHING. Take a repeatable short trip so that you can compare numbers before and after your change (that's how I knew, after the fact unfortunately, the old calibrator was misreporting the airflow). The only reason why I even got thru to Active so fast was that I was able to (along with smoke/fuel test results) clearly explain what was going on. Most folks tell them "My Engine light is on"(help with this is waay limited). They immediately knew what it was and BAM, I had a fix within a few days. My only gripe is that they didn't proactively tell me this after they sent a bogus calibrator(but, had I used an OBDII logger, I would have caught this on my own a long time ago). Whatever. For all you tweakers out there, just invest $150 in some scanning equipment and you'll be golden. Trust me.

I hope to share the 300% of great things I learned with the rest of you in your future posts.

Thanks for ALL of your help.....it *really* did accelerate the process (even tho it took ME months...haha).

Sorry for the long post, but this was a big win for me.

-Kazam
kazamali is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Calling All Bimmer Experts!! Rekless56 3-Series (E36) 6 04-04-2009 05:40 PM
'01 540i fuel trim problems RockyBalboa-UK 5-Series (E12,E28, E34, E39, E60) 7 12-17-2008 11:09 AM
Calling All Experts rakeshp 5-Series (E12,E28, E34, E39, E60) 4 07-28-2005 11:57 PM
Fuel Trim Malfunction daves7x20 1,6,7,8 - Series and Mini Cooper 4 01-14-2005 04:10 PM
Fuel Trim Malfunction - 1998 740i gm3mtm 1,6,7,8 - Series and Mini Cooper 1 08-13-2004 12:53 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome