on board computer - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-22-2004, 08:15 AM   #1 (permalink)
Neutral Member
 
Stunnd65's Avatar
 
Join Date: Jun 2004
Location: Southeast PA
Car:
Posts: 57
Photos:
Stunnd65 is an unknown quantity at this point
bought my first bimmer last week.... a cashmere beige (gold) 93 325i with 115k miles....love to drive it....the on board computer has been giving me messages about the brake light circuit, the coolant level and the license plate bulb, all of which are working fine....am I going to get hammered to fix this problem? after seeing the messages other than the brake light circuit one, I'm not so sure that it's just a brake switch problem like others in this forum have experienced....I just got rid of an 89 Benz because I could have bought 2 cars for what it was costing me and now I'm a little paranoid about anything going wrong
Stunnd65 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-22-2004, 09:11 AM   #2 (permalink)
You Can Has A Custom Title!!
 
Join Date: Jan 2004
Location: Eugene Oregon
Car: 2008 128i
Posts: 2,718
Photos:
007ben is an unknown quantity at this point
Send a message via AIM to 007ben Send a message via Yahoo to 007ben
so your coolant is not low?
replace the sensor...

you sure the brake lights are lighting? mine does that to me 2 times now. when it does no brake lights, thus a problem with the switch.

and both licence plate lights are working? if so check for other shorts involving the licence plate lights.
__________________
2008 128i Jetblack
007ben is offline   Reply With Quote
Old 06-22-2004, 09:57 AM   #3 (permalink)
1st Gear Member
 
Join Date: Mar 2004
Car:
Posts: 119
Photos:
leibniz is an unknown quantity at this point
what 007ben said about both license plate lights working. If one is burnt, you'll see the message on the OBC.

I also had a problem with "brake light failure" and license plate light failure messages, and it was a problem until the bulbs were replaced with OEMs.

I also had a problem in my '97 328i that might be relevant to your situation: the lights wiring harness that runs onto the trunk assembly, although not appearing to bend or bind, contained wires that were bent and brittle. The dealership "patched it" for me and said it would be about $600 CDN to replace the wiring harness. Labour mostly, I assume.

So it all works great for now, but I see more $$$ on the horizon.
leibniz is offline   Reply With Quote
Old 06-22-2004, 10:17 AM   #4 (permalink)
WOT in Reverse
 
jllphan's Avatar
 
Join Date: Jan 2004
Location: Cashville, TN
Car:
Posts: 3,441
Photos:
jllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond repute
Send a message via AIM to jllphan
First off to the forums!

These cars aren't super cheap to own, but they are far less expensive than many other German cars.

leibniz and I share the same experience, I had the brake light circuit warning on my OBC, and merely checked and replaced any bulbs that weren't spec bulbs=problem fixed.

As for coolant low, if the warning is on, the sensor probably works fine. I would check the level when the engine is COLD, not after you see the OBC message. It is probably a little low, just remember to fill with BMW coolant mixed 50/50 with water. This is very important as one of the few problem areas of these cars is the cooling system. The BMW coolant is phospate-free and is highly recomended to use nothing else.

I would offer the same advice for the license plate as stated above for brake light
__________________
jllphan is offline   Reply With Quote
Old 06-22-2004, 11:36 AM   #5 (permalink)
Neutral Member
 
Stunnd65's Avatar
 
Join Date: Jun 2004
Location: Southeast PA
Car:
Posts: 57
Photos:
Stunnd65 is an unknown quantity at this point
First, thanks for the replies. I am actually at the dealership now and registered for this forum while waiting in the customer lounge. It's been a long morning but at least the coffee is good and they have a high-speed internet connection. They said that the brake light bulbs looked black inside of them even though they were still coming on so they're replacing them. They didn't say anything about the coolant or the plate bulb. I have checked the coolant when the engine was cold and the level is actually about an inch above the line. Could that be the problem? Also, should I drain the system and put in the BMW coolant you mentioned? Lastly, I almost got through the inspection for less than $500US but the rear shocks are shot apparently. Oh well, at least I'm driving a bimmer!
__________________
Cashmere Beige Metallic '93 325i
Stunnd65 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
On Board computer dmonk 3-Series (E36) 9 08-29-2010 09:03 PM
On Board Computer dvmotorsports 3-Series (E36) 8 06-29-2005 03:25 PM
97 328i On Board Computer Issues richietherocket 3-Series (E36) 2 02-27-2005 09:06 AM
On Board Computer Swap? 1993_325i_5 speed 3-Series (E36) 2 01-21-2005 11:48 PM
On Board Computer? matt325is 3-Series (E36) 1 09-21-2004 08:40 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.