Anyone Had This Problem? - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-08-2005, 11:13 PM
Neutral Member
 
Join Date: Jan 2005
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bkcraun is an unknown quantity at this point
(Thread Starter)
1992 E36 325i, check engine light comes on, idle starts surging. I changed the ICV and nothing changed. I changed the O2 sensor and the check engine light and the idle surge went away! Problem solved........except. I have now done this "fix" on 3 separate occasions over the last 6 months. Each time it solves the problem, but each time the problem eventually comes back. No codes other than something isn't reading the O2 sensor. What is it?
bkcraun is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-09-2005, 03:01 AM
Been here a while.
 
97alpineM3's Avatar
 
Join Date: May 2004
Location: Virginia
Posts: 5,375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all
Send a message via AIM to 97alpineM3 Send a message via MSN to 97alpineM3
What code exactly are you talking about?... If your not reading your O2 sensor.. there are ways to check the electrical validity of the O2 sensor... which makes sure its sending back the right signals... (checking the O2 sensor it self) If your not getting the signals back to the ecu... the only thing I can think of is you have a problem with the connection line between the O2 sensor and your computer system.

I was start small.. and work up... since replacing the O2 sensor fixes this problem... try keeping the O2 sensor.. and changing the wiring harness... you can get one online or at the dealer. See if that fixes her...

Good Luck... and I hope this either helps or points you in the right direction.

Lers


1997 E36 M3 1990 E30 325i
97alpineM3 is offline  
#3 (permalink) Old 06-09-2005, 03:01 AM
Been here a while.
 
97alpineM3's Avatar
 
Join Date: May 2004
Location: Virginia
Posts: 5,375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all
Send a message via AIM to 97alpineM3 Send a message via MSN to 97alpineM3
What code exactly are you talking about?... If your not reading your O2 sensor.. there are ways to check the electrical validity of the O2 sensor... which makes sure its sending back the right signals... (checking the O2 sensor it self) If your not getting the signals back to the ecu... the only thing I can think of is you have a problem with the connection line between the O2 sensor and your computer system.

I was start small.. and work up... since replacing the O2 sensor fixes this problem... try keeping the O2 sensor.. and changing the wiring harness... you can get one online or at the dealer. See if that fixes her...

Good Luck... and I hope this either helps or points you in the right direction.

Les


1997 E36 M3 1990 E30 325i
97alpineM3 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic Idle / Misfire / Cutting out makdolby 3-Series (E36) 12 02-05-2012 08:57 AM
528i Alarm Problem Xero 5-Series (E12,E28, E34, E39, E60) 5 01-03-2011 02:16 PM
Smg Problem On 330i johanfunsale 3-Series (E46, E90) 0 02-28-2005 08:33 AM
Alpine 9835 Fm Tuner Problem ultraviolet353 Audio and Electronics 7 09-23-2004 12:09 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome