All electrics went dead -- that's D-E-A-D while driving down the highway - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-11-2009, 07:30 AM   #1 (permalink)
n00b
 
Join Date: Dec 2008
Location: Hot Springs, Arkansas
Car: 95 318is -- love the car
Posts: 15
Photos:
talisman318is is on a distinguished road
All electrics went dead -- that's D-E-A-D while driving down the highway

That's right. And while it is at the mechanic's right now, does anyone have a good read on the possibilities that explain why -- while I'm just driving down the highway -- the guages and all instrumentation would drop away, the car had a few surges of ignition firing, but only for a quarter mile or so -- and then all dead. Coasted off an exit and into a parking space at a convenience mart. Wouldn't even crank over. ?????????

Thoughts?
talisman318is is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-11-2009, 08:31 AM   #2 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
It may be a main, very central fusible link. If the hazard lights are disabled, that would suggest just that.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 06-11-2009, 10:51 AM   #3 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Had this happen...............I found out that the alternator had died and the the car lived off the battery until it did exactly the same as yours, at 1st I thought the batt had given up as it was old, so I just changed that, 2 days later same thing........had the Alt checked and it was fine on test until a mechanic came over and said rev it to 2000rpm and sure enough the output from the Alt cut out.

Changed the Alt, has been fine for 2 years and I never got any warning light on the dash that it wasnt charging.

So it maybe be your Alt.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 06-12-2009, 12:14 AM   #4 (permalink)
n00b
 
Join Date: Dec 2008
Location: Hot Springs, Arkansas
Car: 95 318is -- love the car
Posts: 15
Photos:
talisman318is is on a distinguished road
Alternator was the problem.

Yep, alternator went out. Few hundred dollars later I'm good to go. Thanks for the input.
talisman318is is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No electrics but car starts fester001 5-Series (E12,E28, E34, E39, E60) 2 05-06-2009 11:22 PM
dead battery and dead key.. cant get in trunk to jump car richmond3h 3-Series (E36) 4 03-29-2009 08:35 PM
Door/electrics Problem 320CDI 3-Series (E46, E90) 0 01-04-2005 04:32 PM
Problem with 98 523 electrics buck101 5-Series (E12,E28, E34, E39, E60) 1 10-16-2003 09:01 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:56 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.