95 318is idle problem when starting - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-04-2007, 09:14 AM   #1 (permalink)
n00b
 
Join Date: Feb 2005
Car:
Posts: 9
Photos:
Mario Milewski is an unknown quantity at this point
95 318is idle problem when starting

Hi,

I have a 95 318is, 5spd and sometimes when I start the car the idle goes up then it goes down , this continues for few seconds and then idle becomes stable (in some cases the rpms go so much down that the car almost stalls). The problem occurs more often during hot weather or when the engine is warm. I have no problem with the idle once the engine runs, i.e. when I stop at the lights the idle is stable. I have checked the engine codes but nothing shows up. Any help would be greatly appreciated.

Thank You,

Mario
Mario Milewski is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-04-2007, 09:25 AM   #2 (permalink)
Science Roolz!
 
Join Date: Aug 2004
Location: Indianapolis, Indiana
Car: 2011 Mazda2, 1990 Miata
Posts: 7,043
Photos:
SHAHAB323IS is a name known to allSHAHAB323IS is a name known to allSHAHAB323IS is a name known to allSHAHAB323IS is a name known to allSHAHAB323IS is a name known to allSHAHAB323IS is a name known to all
Send a message via AIM to SHAHAB323IS
try this

Idle Control Valve Write up; ICV clean DIY - Bimmerforums - The Ultimate BMW Forum
__________________
2011 Mazda2
1990 Mazda Miata
SHAHAB323IS is offline   Reply With Quote
Old 06-14-2007, 09:15 AM   #3 (permalink)
n00b
 
Join Date: Feb 2005
Car:
Posts: 9
Photos:
Mario Milewski is an unknown quantity at this point
idle still eratic at startup, o2 replaced

Thanks for the advice, I have cleaned the idle control valve and replaced the o2 sensor but problem still persists. I have noticed that when o2 sensor is disconnected it helps a lot. I have also checked the EVAP canister but it looks good, no cracks or anything. Could this erratic idle at startup be possibly caused by faulty knock sensor? From what I know replacing the knock sensor on M42 engine is a major job. I was looking on the internet for some write up on how to replace knock sensor but I did not find much.

Thank you for any help on this.

Mario
Mario Milewski is offline   Reply With Quote
Old 08-01-2007, 03:31 PM   #4 (permalink)
n00b
 
Join Date: Aug 2007
Car:
Posts: 3
Photos:
yumtum is on a distinguished road
i had similar problems on my 318is saloon m44 16v engine and i had the camshaft positioning sensor replaced. only use genuine sensor after market will not last as the heat will get to it
yumtum is offline   Reply With Quote
Old 08-03-2007, 09:14 AM   #5 (permalink)
n00b
 
Join Date: Apr 2007
Car:
Posts: 7
Photos:
jhawth1 is on a distinguished road
Wow I pop on this forum once and a while and it seems everytime I find exactly what I am looking for.

This is a great forum and as a new owner of a e36 I am happy to have found it.

Thanks to all who post this great info
jhawth1 is offline   Reply With Quote
Old 08-04-2007, 01:40 PM   #6 (permalink)
quality
 
Delmarco's Avatar
 
Join Date: Aug 2004
Location: NYC
Car: 2001 330i & 2011 550i
Posts: 7,254
Photos:
Delmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond reputeDelmarco has a reputation beyond repute
Garage
I had that problem. After cleaning the Idle Control valve and you still have rough idling. It means you have to replace the Idle Control pulley (not sure if that is the name). On the 318 M42 (my car) engine it looks different than the newer M44.
1995 318s had either 42 or 44 so check what you have first at RealOEM.com Online BMW Parts Catalog
then you can replace the pulley. I also recommend replacing the pulley belts at the same time since you will have to remove them as well. You will save in labor $$$ down the line.

A new 318i pulley goes anywhere from $30s and up. Belts are about the same.
__________________
Delmarco is offline   Reply With Quote
Old 04-17-2012, 05:33 PM   #7 (permalink)
Neutral Member
 
ncktuley1's Avatar
 
Join Date: Feb 2011
Location: Woodburn, oregon
Car: 92 318is
Posts: 68
Photos:
ncktuley1 is on a distinguished road
Garage
why would the pulley matter? and im having the same problem, i replaced the icv and o2 sensor. No cracks in the vacuum lines. but the crankshaft sensor looked to be dented just a little bit. would that effect it that much?
__________________
Quote:
Originally Posted by black318i View Post
Unicorn taint, I hear it's impossible to find though.
ncktuley1 is offline   Reply With Quote
Old 04-17-2012, 10:09 PM   #8 (permalink)
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Car: 1998 E36 328i
Posts: 2,210
Photos:
Lord Vader is on a distinguished road
All your intake lines are okay? What about the line under the manifold? If outcomes loose or cracks it causes idle issues.
__________________

ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desperately Need Your Help: BMW325i "Service Engine Soon" light problem CNMB250 3-Series (E46, E90) 4 12-19-2007 06:26 AM
Idle Problem Rich328 3-Series (E36) 7 09-04-2005 03:46 PM
98 328i Starting Problem moe19x 3-Series (E36) 7 11-04-2004 07:55 AM
Window Problem E36 318is Digital318is 3-Series (E36) 5 09-22-2004 09:28 AM
'88 528e Starting Problem Solved! jopa 5-Series (E12,E28, E34, E39, E60) 2 07-07-2004 09:24 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:36 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.