328i help..not as fast as used to be... - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-11-2004, 09:34 PM
n00b
 
Join Date: Jun 2004
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dr_dirtg is an unknown quantity at this point
(Thread Starter)
Hey, I'm new here.

What is there that I could change/replace in the car that would re-gain lost power from my 328i?
Excluding spark plugs/ spark plug wires. or air filter. I changed oil on it very frequently.
Is there common problems with these engines loosing power?

Here is my story...

About 2 years ago, I got a 98 328i 4 door had about 70miles on the odometer, the car had the fastest response and incredible acceleration. It is Automatic. I was smoking civics, jettas, Corrados, and 250hp lexus ls400's... yes its AUTOmatic.
Top speed I reached with it was 255km/hr. (160mph) oh, and I reached this on a stretch of approximately 3/4 of a mile (1km) or so.
I never got 1/4 mile time or any time for it.

I then Got a Corrado Vr6, and I had it since.
The 328 went on to my non-mechanically inclined younger brother.
He Fucked it up Somehow.
Now the car has 110,000miles on it... The car does not accelerate as fast anymore.
A goddamn civic Sir's nose is a few feet ahead of the 328 until we get to about 100km/hr then I start leading away... (i used to smoke the exact same sir Off the line by 4 or 5 car lengths, he did not mod it at all since).
The 328i was doing 11L/100km before and now it still does the same.

(The response messed up- it's response isn't as quick... before - I woudl from standing in the spot Floor it and the car woudl Shoot like a rocket, now it still shoots but slowly, and it doens't have a Constant pick up like it used to.)

Something with the acceleration messed up - I dont know what, it doesn't burn oil or anything, its still moderately quick, but the SIR is about 3 car lengths ahead and a 98 2.0L Jetta is 2 car lengths faster from about 0-60 km.
Oh and top speed is about 230km/hr now. and it takes a Lot longer to Get there and it REALLY PISSES ME OFF!
Anyone have any info on what it could be? Any Similar Stories???
Help I want this car to regain its power and rape those ShitVICs again
Oh I do have Engine Check Light that is litten up , But It was litten up Ever since I had the car.

THANKS, Appreciate it.
dr_dirtg is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-12-2004, 05:34 PM
n00b
 
Join Date: May 2004
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jwhitby is an unknown quantity at this point
Turn the key to the on position (not start) for exactly 10 seconds. Turn the key to the off position for 10 seconds. Start the car. This resets some ofthe settings for adaptive driving response (or something like that). Should last for a while.
jwhitby is offline  
#3 (permalink) Old 06-12-2004, 05:57 PM
You Can Has A Custom Title!!
 
thekid's Avatar
 
Join Date: Jan 2004
Location: Jackson MS
Posts: 3,445
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute
does the car have an occasional idle problem? Check all of your vacum hoses. I have a vacum leak and it sucks. The acceleration I had is all gone, the car is slow as balls. I could barely keep up with a V6 camry the other day that was being driven by a 40 year old woman.
thekid is offline  
#4 (permalink) Old 06-12-2004, 05:59 PM
2nd Gear Member
 
Join Date: May 2004
Location: East Texas..USA...
Posts: 451
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DeefNDorf is an unknown quantity at this point
Send a message via AIM to DeefNDorf Send a message via MSN to DeefNDorf
Hmm...DUDE!...Fix the leak....

Hmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm...
DeefNDorf is offline  
#5 (permalink) Old 06-12-2004, 07:34 PM
n00b
 
Join Date: Jun 2004
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dr_dirtg is an unknown quantity at this point
(Thread Starter)
Quote:
Originally posted by thekid@Jun 12 2004, 05:37 PM
does the car have an occasional idle problem? Check all of your vacum hoses. I have a vacum leak and it sucks. The acceleration I had is all gone, the car is slow as balls. I could barely keep up with a V6 camry the other day that was being driven by a 40 year old woman.
hmm, I'm gonna try that 10second thing when i get the car back here tommorow.

Camry eh - Shit I better fix this thing fast , I'm anti Jap Crap cars. I can't have this happening to me. hehe
dr_dirtg is offline  
#6 (permalink) Old 06-12-2004, 07:44 PM
n00b
 
Join Date: Jun 2004
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dr_dirtg is an unknown quantity at this point
(Thread Starter)
Quote:
Originally posted by thekid@Jun 12 2004, 05:37 PM
does the car have an occasional idle problem? Check all of your vacum hoses. I have a vacum leak and it sucks. The acceleration I had is all gone, the car is slow as balls. I could barely keep up with a V6 camry the other day that was being driven by a 40 year old woman.
As for the vacumm leaks... I checked all the small vacumm hosing a while ago when I tried to fix the problem... and they were all good... no rips /cuts or anything...
I thikn I will just Replace them anyway...
but I doubt it will help.

Any other suggestions???
dr_dirtg is offline  
#7 (permalink) Old 06-12-2004, 09:53 PM
You Can Has A Custom Title!!
 
thekid's Avatar
 
Join Date: Jan 2004
Location: Jackson MS
Posts: 3,445
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute
Quote:
Originally posted by DeefNDorf@Jun 12 2004, 05:39 PM
Hmm...DUDE!...Fix the leak....
I'm trying but the UPS guy has fucked me royal. He was supposed to deliever the hose on thursday, didn't show. Friday, no show. I'm about to go to the stealership and get a hose.
thekid is offline  
#8 (permalink) Old 06-12-2004, 09:54 PM
You Can Has A Custom Title!!
 
thekid's Avatar
 
Join Date: Jan 2004
Location: Jackson MS
Posts: 3,445
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute thekid has a reputation beyond repute
also, if the code thing turns up nothing get a compression test done.
thekid is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Decision: 325i Vs 328i ynotony 3-Series (E36) 10 05-26-2005 10:16 AM
E36 Vs E46 328i raid 3-Series (E36) 7 03-13-2005 08:18 PM
328i Vs 328i W/ Sport Package Darkmage 3-Series (E36) 9 10-11-2004 01:11 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome