1994 BMW 325 Electrical Problem - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

» Auto Insurance

» Featured Product
» Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-23-2009, 07:01 AM   #1 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 11
Photos:
Jimw is on a distinguished road
1994 BMW 325 Electrical Problem

Greetings:
I have a 1994 325 with an electric. prob. Intermittently, the speedo/tach/fuel/temp gauge will drop to zero while driving. Usually after -20- seconds they will come back on again...everything else in the display module remains working. The schematic shows a BRN/ORG ground wire common to these -4- modules they picks up vehicle gnd under trim panel on passenger side. I have located and cleaned/checked this connection. Have also cleaned/replaced the vehicle gnd strap (near front rght whl). Have removed the speedo cluster and even taken apart the plug going into back of ubit to make sure the gnd wire is connected and seated properly. Problem still exists...I wil run a seperate gnd to replace this wire, but suspect that the gnd problem may be inside the cluster. Has anyone seen this problem and come up with a fix? Can a BMW dealer work on the cluster?Want to maintain mileage accuracy.
Thanks!
Jimw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2009, 07:47 AM   #2 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
All BMW will go for is a new cluster if they are still in production,check the fuses for corrosion and tightness.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 02-23-2009, 03:01 PM   #3 (permalink)
1st Gear Member
 
vincentmb615's Avatar
 
Join Date: Sep 2008
Location: cape
Car: 94 325i two toned full body kit
Posts: 204
Photos:
vincentmb615 is on a distinguished road
Send a message via AIM to vincentmb615
marti is right on point also check for the relay it may have a short in a pin or something
__________________
[94 325i two toned
vincentmb615 is offline   Reply With Quote
Old 02-23-2009, 05:55 PM   #4 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 11
Photos:
Jimw is on a distinguished road
Quote:
Originally Posted by Jimw View Post
Greetings:
I have a 1994 325 with an electric. prob. Intermittently, the speedo/tach/fuel/temp gauge will drop to zero while driving. Usually after -20- seconds they will come back on again...everything else in the display module remains working. The schematic shows a BRN/ORG ground wire common to these -4- modules they picks up vehicle gnd under trim panel on passenger side. I have located and cleaned/checked this connection. Have also cleaned/replaced the vehicle gnd strap (near front rght whl). Have removed the speedo cluster and even taken apart the plug going into back of ubit to make sure the gnd wire is connected and seated properly. Problem still exists...I wil run a seperate gnd to replace this wire, but suspect that the gnd problem may be inside the cluster. Has anyone seen this problem and come up with a fix? Can a BMW dealer work on the cluster?Want to maintain mileage accuracy.
Thanks!
Thanks!, will all fuses supplying power to the cluster.

Jim
Jimw is offline   Reply With Quote
Old 02-23-2009, 07:57 PM   #5 (permalink)
Ich bin der Modifikator
 
johnnyBgood's Avatar
 
Join Date: Sep 2007
Location: Bayonne, NJ
Car: 97'E36 2.8 w/Optional Sport Package
Posts: 3,325
Photos:
johnnyBgood is a jewel in the roughjohnnyBgood is a jewel in the roughjohnnyBgood is a jewel in the rough
Garage
Quote:
Originally Posted by Jimw View Post
Thanks!, will all fuses supplying power to the cluster.

Jim
According to the Bentley Service Manual, 94' e36 fuse positions.....there are 4, fuse #23-5A , #27-5A, #31-5A, & #46-15A.....also could be a loose connection on the harness in the back of the cluster.

johnny,
__________________
______________________________________
_______________________97 E36|Conforti Software|M50 Manifold|AFE|Borla|H&R| Bilstein |Eibach|Rockford|3.15 LSD
____________________________________________http://www.cardomain.com/ride/3129109
johnnyBgood is offline   Reply With Quote
Old 02-23-2009, 08:14 PM   #6 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 11
Photos:
Jimw is on a distinguished road
Thanks for your help!

Jim
Jimw is offline   Reply With Quote
Old 02-23-2009, 08:14 PM   #7 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 4
Photos:
fenlux is on a distinguished road
I have just had the same problem with my 320, ended up changing my instrument cluster and all is now good. I am also waiting for a interface to turn up to try and change the odometer reading back to original.
fenlux is offline   Reply With Quote
Old 03-08-2009, 01:07 PM   #8 (permalink)
n00b
 
Join Date: Mar 2009
Car:
Posts: 2
Photos:
PFON is on a distinguished road
I had the same problem on 1994 318is. I just finished installing a used gauge cluster purchased on the internet....like 30 minutes ago. Totally fixed the problem and I am jazzed. However....the mileage is wrong and whoever sent me the gauge apparently had an automatic and mine is a 5 speed so the transmission light is on. I am now attempting to locate the correct plug in the back of my old gauge that stores the mileage and service info.
PFON is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 bmw 325.. CF hood wanted L.I. StreetRacer For Sale 0 12-17-2008 03:15 PM
1994 BMW 325 IS 5-Speed - $5900 OBO - Seattle Area LtcOliverNorth Cars For Sale 1 10-03-2006 12:06 AM
1994 325 Is - Questions Black1994325is 3-Series (E36) 3 12-27-2004 03:13 PM
Parts For 1994 325 gymcoach Classifieds Sell & Buy 0 11-12-2004 09:42 AM
Bmw 325 Iac Problem With The Roof ThunderSS 3-Series (E36) 1 10-08-2004 02:29 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:54 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.