Yes another Speedo problem - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-24-2003, 06:15 PM
n00b
 
Join Date: Sep 2003
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Aussie_323i is an unknown quantity at this point
(Thread Starter)
Thumbs up

I own an '84 323i and my speedo is driving me absolutely crazy. I first started having problems about a year ago, were my speedo would sometimes work and then all of sudden just stop working and drop to zero and then maybe 10 min later would start working again or sometimes not start working till the next day.

I decided to pull the speedo out and have it tested by a VDO agent and they showed me it working fine. I then went on to test the continuity of the wires running from the sensor in the diff all the way to the pins on the instrument panel circuit board and they are all fine. Then thinking it must be the sensor it self, I replaced it with a new one but to no avail. The next step was to replace the Instrument panel circuit board but that did nothing either. The service indicator board has also recently been replaced and the batteries seem fine. So I need some help! ghead

* on the instrument panel circuit board there are 5 pins which connect to the speedo, can anyone tell what each of these pins are for (voltage, pulse signal etc)?

*Also is it possible to wire up the speedo by running wires to sensor in the diff and to the battery?
Any help would be greatly appreciated as you can see this is getting quite costly for me, Thanks
Aussie_323i is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-24-2003, 06:25 PM
Retired administrator
 
triggrhaapi's Avatar
 
Join Date: Dec 2002
Location: Los Angeles
Posts: 5,996
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute triggrhaapi has a reputation beyond repute
Send a message via AIM to triggrhaapi
lemme see what I can find out


Addicted to Speed Since 1997
Founding member of the GreenDragon Poo Flingers Club
Founder and Double Member of the 150mph club

Read about my Frankenmotor Project and see how an M50 becomes an S50!!!

No, don't worry. It's cool. I'm taking it back for us.
triggrhaapi is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Smg Problem On 330i johanfunsale 3-Series (E46, E90) 0 02-28-2005 07:33 AM
Problem With Speedo On 1991 E34 535i ben_t 5-Series (E12,E28, E34, E39, E60) 0 12-29-2004 01:51 AM
Speedo Problem Foley 3-Series (E21, E30) 1 12-06-2004 08:15 AM
160 top out speedo is it a problem buuhh99 3-Series (E36) 39 08-18-2004 12:30 PM
Speedo Problem pogiboy9 3-Series (E21, E30) 1 03-30-2004 07:21 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome