Tachometer Not Working, Help?? - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-30-2004, 12:32 AM
n00b
 
Aznhiga's Avatar
 
Join Date: Oct 2004
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Aznhiga is an unknown quantity at this point
(Thread Starter)
My 325es tachometer stopped working along with the mpg. The water temperature gauge sometimes stops working too. Help would be nice, because I would liek to know when to shift soemtimes.thanx.
Aznhiga is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-30-2004, 02:40 PM
You Can Has A Custom Title!!
 
Join Date: Dec 2002
Location: Houston
Posts: 2,053
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MrM3 is an unknown quantity at this point
Send a message via AIM to MrM3
Welcome Aznhiga,

Pretty much the entire e30 cluster is prone to failure at some point. it could be the tach itself that stopped working, it could be a malfunction in the SI Board (possibly heat related), it could be wiring related if some one messed around under the dash installing an alarm or something, or it may just be the SI batteries. There have also been cases where the batteries have leaked onto the SI board after overheating from the car sitting in the sun for a long period of time.

I would just buy a used good condition complete cluster with low mileage and swap the speedometer/odometer with your current one so your mileage will still be accurate. Also, when looking for a cluster make sure you find one that's the same brand as the original (VDO or Motometer).
MrM3 is offline  
#3 (permalink) Old 10-30-2004, 09:01 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,698
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Check the fuses, that's what it was when mine failed

BMW

Sig by zeaq
witeshark is offline  
#4 (permalink) Old 10-30-2004, 10:19 PM
5th Gear Member
 
BimmerKris's Avatar
 
Join Date: Jan 2004
Posts: 1,306
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BimmerKris is an unknown quantity at this point
try changing the batterys

<img src='http://bmwforums.penguinstudios.com/BimmerKris/salesig%20copy.jpg' border='0' alt='user posted image' />
<a href='http://www.acantha.ca' target='_blank'>www.acantha.ca</a> 100% thrash your face off metal
BimmerKris is offline  
#5 (permalink) Old 10-30-2004, 10:28 PM
3rd Gear Member
 
bavariankid06's Avatar
 
Join Date: Aug 2004
Location: South Carolina-Home of the BMW Community
Posts: 697
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bavariankid06 is an unknown quantity at this point
Send a message via AIM to bavariankid06 Send a message via MSN to bavariankid06
yea, change the SI batteries...i hav that same problem and it is one the the 10...things i'm getting done this week. my speedo, water temp, and mpg didn't work...it was kinda funny, the speedo would bounce up and down and most of the time it would be like 10-15 mph off

<img src='http://img.photobucket.com/albums/v305/crisby325i/Forum%20Sigs/BMWFSig.jpg' border='0' alt='user posted image' />

Mods:
Ireland Engineering Stage 3 springs
Bilstien Shocks/Struts
MB Motoring Rev 16x7 w/ Fuzion ZRi 205/45/16 tires
&lt;&gt;&lt;&gt;&lt;&gt;&lt;&gt;&lt;&gt;&lt;&gt;&l t;&gt;&lt;&gt;&lt;&gt;&lt;&gt;&lt;&gt;
<span style='font-size:8pt;line-height:100%'><span style='color:blue'><span style='font-family:Times'>Member of the 100,000 Miles Club</span>
<span style='colorurple'><span style='font-family:Times'>Member of the 3 Pedal Club</span></span>
<span style='color:red'><span style='font-family:Times'>Member of the &quot;I'm 17 and Own a Bimmer&quot; Club</span></span></span>
<span style='color:gray'><span style='font-family:Times'>Member of the 15 Yr Old Club</span></span></span>


Links:
<a href='http://www.cardomain.com/id/tigerzrule06' target='_blank'>On Cardomain's Top 5 E30 List!!</a>
<a href='http://www.photobucket.com/albums/v305/crisby325i' target='_blank'>.:My Photo Album:.</a>
<span style='color:red'><a href='http://www.seboc.com/' target='_blank'>S.E.B.O.C. - Southeastern BMW Owners' Club</a></span>
<span style='font-size:14pt;line-height:100%'><a href='http://www.petitiononline.com/STOPCB/petition.html' target='_blank'>11564th signer of the &quot;Stop Chris Bangle Petition&quot;</a></span>
bavariankid06 is offline  
#6 (permalink) Old 11-01-2004, 08:52 PM
n00b
 
Simon S's Avatar
 
Join Date: Oct 2004
Location: Madison, WI
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Simon S is an unknown quantity at this point
Simon S is offline  
#7 (permalink) Old 11-02-2004, 01:04 AM
1st Gear Member
 
theratdude64's Avatar
 
Join Date: Oct 2004
Location: SLC Utah
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
theratdude64 is an unknown quantity at this point
Send a message via AIM to theratdude64 Send a message via MSN to theratdude64
does the intermittant speedometer and SI batteries apply to intermittant gas guage too? Also will the guides for the E30 be somewhat close to an E21?

<img src='http://s89706284.onlinehome.us/bmwsig.jpg' border='0' alt='user posted image' />
82 320i 1.8 liter Automatic
86 Camaro 5 Speed

member of the wonders WTF is up with everyone being a member of sigs
member of the beasty engine club
member of the manual tranny club
member of the Utah Sucks Club
member of the V8 OWNS JOO Club
theratdude64 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Spedometer & Odometer Intermittently quit working osestrada 3-Series (E36) 2 10-13-2005 12:17 PM
Radio Not Working? HoFF 3-Series (E21, E30) 4 06-26-2005 04:47 PM
Speedometer not working M5power 5-Series (E12,E28, E34, E39, E60) 9 03-29-2005 08:58 PM
2003 540i, Sound Not working.. youngceo Audio and Electronics 4 06-03-2004 05:20 PM
reverse lights suddenly stoped working mstar 3-Series (E36) 5 05-28-2004 06:16 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome