tacho dies. - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-13-2006, 10:57 PM   #1 (permalink)
n00b
 
Join Date: Dec 2005
Car:
Posts: 10
Photos:
drcrougeux is on a distinguished road
tacho dies.

ALLO.

I HAVE AN 1988 325 IC CONV.
TACH SEEMS TO WORK ONLY WHEN IT FEELS LIKE IT...
How is it connected ? all other instruments work.
The SI Board batteries were checked & are ok.
Loose cable ? Is it elec or mech ?

Someone has got to know this.
It's seems to be a common issue.

conrad
drcrougeux is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-14-2006, 09:47 AM   #2 (permalink)
2nd Gear Member
 
JoeMadoo's Avatar
 
Join Date: Dec 2005
Location: Victorville, CA
Car:
Posts: 396
Photos:
JoeMadoo is on a distinguished road
Send a message via AIM to JoeMadoo Send a message via MSN to JoeMadoo Send a message via Yahoo to JoeMadoo
Your radio dosent shut off when your tash dies does it? That was my problem and it turned out to me a loose fuse, number 19 i think.
__________________
86 Alpine White 335is M30 Swap <br>My Car Domain
ASE L1 Smog Certified

JoeMadoo is offline   Reply With Quote
Old 06-14-2006, 10:22 PM   #3 (permalink)
2nd Gear Member
 
Join Date: Jan 2005
Car:
Posts: 367
Photos:
egk2 is an unknown quantity at this point
Quote:
Originally Posted by drcrougeux
ALLO.

I HAVE AN 1988 325 IC CONV.
TACH SEEMS TO WORK ONLY WHEN IT FEELS LIKE IT...
How is it connected ? all other instruments work.
The SI Board batteries were checked & are ok.
Loose cable ? Is it elec or mech ?

Someone has got to know this.
It's seems to be a common issue.

conrad
There are two grounding nuts on the back of the cluster, they tend to loosen
up over time, check yours and tighten if needed.
__________________
2.8L M20 Stroker
egk2 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel, Temp and Tacho all died Benaud 3-Series (E21, E30) 6 04-04-2006 05:33 PM
Need Help Engine Dies After Starting VIEN46 3-Series (E36) 15 12-24-2004 10:54 AM
starts then dies....very rough low idle help!! pagz 5-Series (E12,E28, E34, E39, E60) 5 07-09-2004 02:04 PM
my damn battery dies at random times? tyro2001 3-Series (E21, E30) 8 06-17-2004 07:31 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:47 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.