slow acceleration help - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-14-2004, 06:51 PM   #1 (permalink)
n00b
 
Join Date: May 2004
Car:
Posts: 31
Photos:
jaykool169 is an unknown quantity at this point
Thumbs up

hi everyone. i have a 1987 325is bmw. ive had it for like a year now. its been running good up till like this past winter and up to now. it starts up fine but its got like no acceleration at all so i did this to it. i changed the cap, rotor, mass airflow meter. timing belt, fuel filter, plugs, wires, coil, and thats about it. at it still runs terrible. now im looking to change the main computer but i dont know bc its alot of money. can someone plz tell me what else it might be.
Attached Thumbnails
slow acceleration help-car5.jpg  
jaykool169 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-14-2004, 07:23 PM   #2 (permalink)
5th Gear Member
 
Join Date: May 2004
Car: 00 Prelude, 95 525i, 85 635CSi
Posts: 1,414
Photos:
d3ity will become famous soon enoughd3ity will become famous soon enough
I'm assuming you have replaced the air filter. If you havent, GO BUY ONE! you also might want to dump some fuel injector cleaner and other stuff through your engine. The computer shouldnt have much to do with your acceleration. If you put anything aftermarket on it (specifically the ignition wires/coils) you may want to switch back to OEM.

More specific information would be helpful, What RPM's / gear does it slow in, you could need a new clutch if its a manual, or possibly some transmission components.

Replace the air filter...if you havent, PRONTO. That'll suck your horsepower dry.
__________________
<iframe src="http://gamercard.xbox.com/TiddlyPlatypus.card" scrolling="no" frameBorder="0" height="140" width="204">Put your gamertag here too.</iframe>
d3ity is offline   Reply With Quote
Old 05-14-2004, 08:31 PM   #3 (permalink)
4th Gear Member
 
Bmw1990's Avatar
 
Join Date: Dec 2003
Location: St. Joseph Michigan
Car:
Posts: 967
Photos:
Bmw1990 can only hope to improve
Send a message via AIM to Bmw1990
Make sure you check the intake bellows, those can crack pretty easily. My was bad and when the engine was running i would pry mine aaprt and the car would die. When you accelerate the engine shifts around so it could be pullin the intake bellows apart. Just my .02 cents
__________________
<img src='http://img127.imageshack.us/img127/4284/bmwlogo2new17jy.jpg' border='0' alt='user posted image' />
Black 4 door 1990 325i
15&quot;x7.5 Ronal LS-wrapped in 205/50-15 Bridgestone Potenza G009
Bmw1990 is offline   Reply With Quote
Old 05-15-2004, 11:42 AM   #4 (permalink)
n00b
 
Join Date: May 2004
Car:
Posts: 31
Photos:
jaykool169 is an unknown quantity at this point
well i have ran alot of cleaners into my car like the injectors and corbon cleaner. the air filter is brand new. i just have one clue what it is. like the car had terrible acceleration all the time in every gear. and even if not in gear the rpms go up very slow. help plz
Attached Thumbnails
slow acceleration help-my_car.jpg  
jaykool169 is offline   Reply With Quote
Old 05-15-2004, 04:54 PM   #5 (permalink)
4th Gear Member
 
Bmw1990's Avatar
 
Join Date: Dec 2003
Location: St. Joseph Michigan
Car:
Posts: 967
Photos:
Bmw1990 can only hope to improve
Send a message via AIM to Bmw1990
Your Catalytic Converter could be bad. I hope it isnt that becasue it will cost u some $$$$$$$ to replace
__________________
<img src='http://img127.imageshack.us/img127/4284/bmwlogo2new17jy.jpg' border='0' alt='user posted image' />
Black 4 door 1990 325i
15&quot;x7.5 Ronal LS-wrapped in 205/50-15 Bridgestone Potenza G009
Bmw1990 is offline   Reply With Quote
Old 05-15-2004, 04:55 PM   #6 (permalink)
n00b
 
Join Date: May 2004
Car:
Posts: 31
Photos:
jaykool169 is an unknown quantity at this point
can i be the o2 senser. but im not sure if it is bc i took it out and ran my car and it still ran lke shit. or would it work if i was to buy a new one. and do they like reset the computer if you do
jaykool169 is offline   Reply With Quote
Old 05-15-2004, 05:04 PM   #7 (permalink)
4th Gear Member
 
Bmw1990's Avatar
 
Join Date: Dec 2003
Location: St. Joseph Michigan
Car:
Posts: 967
Photos:
Bmw1990 can only hope to improve
Send a message via AIM to Bmw1990
Yea if u took out the oxygen sensor and it ran like crap it should have. All the Oxygen sensor does is reads teh amount of oxygen in the system and it adjusts the fuel ratios accordingly. You can try buying a new Oxygen sensor, it might help, I just got one and it helped the car idle better. I think they are like 70 dollars. Did Check the Intake bellows yet?
__________________
<img src='http://img127.imageshack.us/img127/4284/bmwlogo2new17jy.jpg' border='0' alt='user posted image' />
Black 4 door 1990 325i
15&quot;x7.5 Ronal LS-wrapped in 205/50-15 Bridgestone Potenza G009
Bmw1990 is offline   Reply With Quote
Old 05-15-2004, 05:08 PM   #8 (permalink)
4th Gear Member
 
Bmw1990's Avatar
 
Join Date: Dec 2003
Location: St. Joseph Michigan
Car:
Posts: 967
Photos:
Bmw1990 can only hope to improve
Send a message via AIM to Bmw1990
No it doesn't reset the computer
__________________
<img src='http://img127.imageshack.us/img127/4284/bmwlogo2new17jy.jpg' border='0' alt='user posted image' />
Black 4 door 1990 325i
15&quot;x7.5 Ronal LS-wrapped in 205/50-15 Bridgestone Potenza G009
Bmw1990 is offline   Reply With Quote
Old 05-16-2004, 12:05 AM   #9 (permalink)
n00b
 
Join Date: May 2004
Car:
Posts: 31
Photos:
jaykool169 is an unknown quantity at this point
ok thanx but i know its not that cat bc i took it off and drove and there was no differance in power at all. it seems like the in proper fuel air ratio is going on but im not sure
jaykool169 is offline   Reply With Quote
Old 05-16-2004, 07:51 AM   #10 (permalink)
You Can Has A Custom Title!!
 
CiscoKid's Avatar
 
Join Date: Apr 2004
Location: South Jersey, USA
Car:
Posts: 2,195
Photos:
CiscoKid is an unknown quantity at this point
Send a message via AIM to CiscoKid
how loud was that?
__________________
CiscoKid is offline   Reply With Quote
Old 05-16-2004, 09:17 AM   #11 (permalink)
5th Gear Member
 
Join Date: May 2004
Car: 00 Prelude, 95 525i, 85 635CSi
Posts: 1,414
Photos:
d3ity will become famous soon enoughd3ity will become famous soon enough
Not as loud as my 635 withOUT an exhaust.


It just sorta dropped off, rusted mount.

Took it down to teh shop and had it rewelded/replaced.

LOUD AS HELL.
__________________
<iframe src="http://gamercard.xbox.com/TiddlyPlatypus.card" scrolling="no" frameBorder="0" height="140" width="204">Put your gamertag here too.</iframe>
d3ity is offline   Reply With Quote
Old 05-16-2004, 06:16 PM   #12 (permalink)
n00b
 
Join Date: May 2004
Car:
Posts: 31
Photos:
jaykool169 is an unknown quantity at this point
so does anyone know what else it might be thats wrong with my car plz
i need help big time im stuck on it and dont know what else to try
jaykool169 is offline   Reply With Quote
Old 05-16-2004, 07:46 PM   #13 (permalink)
5th Gear Member
 
Join Date: May 2004
Car: 00 Prelude, 95 525i, 85 635CSi
Posts: 1,414
Photos:
d3ity will become famous soon enoughd3ity will become famous soon enough
jaykool, what have you tried and what were the results?
__________________
<iframe src="http://gamercard.xbox.com/TiddlyPlatypus.card" scrolling="no" frameBorder="0" height="140" width="204">Put your gamertag here too.</iframe>
d3ity is offline   Reply With Quote
Old 05-17-2004, 01:59 PM   #14 (permalink)
n00b
 
Join Date: May 2004
Car:
Posts: 31
Photos:
jaykool169 is an unknown quantity at this point
changed the cap, rotor,spark plugs, wires, mass airflow meter, timing belt, fuel filter, plugs, wires, coil,some sencer that cheaks the teath on the fly wheel, cheaked the valves to see if they got lose, and thats all that i can think off. plz help
Attached Thumbnails
slow acceleration help-car5.jpg  
jaykool169 is offline   Reply With Quote
Old 05-17-2004, 08:58 PM   #15 (permalink)
5th Gear Member
 
Join Date: May 2004
Car: 00 Prelude, 95 525i, 85 635CSi
Posts: 1,414
Photos:
d3ity will become famous soon enoughd3ity will become famous soon enough
Replace the air filter and your o2 sensor.
__________________
<iframe src="http://gamercard.xbox.com/TiddlyPlatypus.card" scrolling="no" frameBorder="0" height="140" width="204">Put your gamertag here too.</iframe>
d3ity is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery On Recharging... Slow Turnover whitey_E30 3-Series (E21, E30) 1 02-28-2005 07:20 PM
Automatic Slow Off The Line In D, But Not 1st jkh2828 3-Series (E36) 16 01-11-2005 12:57 PM
'92 525iT poor acceleration wilkie3 5-Series (E12,E28, E34, E39, E60) 8 08-03-2004 09:38 PM
Acceleration problem for 328i ??? mstar 3-Series (E36) 10 05-19-2004 10:27 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:21 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.