SI Board - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-15-2008, 04:39 PM
Dig
n00b
 
Join Date: Sep 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dig is on a distinguished road
(Thread Starter)
SI Board

I have a 1988 325I, and I just replaced the SI board because the tach,temp, and mpg gauge were not functioning. The new board solved two out of three issues. The mpg gauge is working, but not correctly. At idle the gauge goes all the way to the right and the only time it shows the most mpg is when you let off the accelerator at highway speeds. The gauge is mostly in the zero to five mpg position. Does anyone know what the problem may be.
Dig is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-15-2008, 06:25 PM
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Posts: 629
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dvmotorsports is on a distinguished road
Quote:
Originally Posted by Dig View Post
I have a 1988 325I, and I just replaced the SI board because the tach,temp, and mpg gauge were not functioning. The new board solved two out of three issues. The mpg gauge is working, but not correctly. At idle the gauge goes all the way to the right and the only time it shows the most mpg is when you let off the accelerator at highway speeds. The gauge is mostly in the zero to five mpg position. Does anyone know what the problem may be.
I don't know exactly how they function, but i believe the older ones work on vacuum. I could be wrong though. But to be honest, they aren't accurate if that is what you are concerned about. But if you do want it working and you can confirm that is does operate on vacuum, start with the line going to the gauge. My 87 VW GTi had a vacuum line running right to the back of the gauge. Haven't had my E30 cluster apart, so i don't know if it's the same. Not much help, sorry.

BMW Technician
dvmotorsports is offline  
#3 (permalink) Old 03-16-2008, 10:59 AM
Dig
n00b
 
Join Date: Sep 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dig is on a distinguished road
(Thread Starter)
Thank you, but I don't recall a vacuum hose or connection for one on the back of the cluster.
Dig is offline  
#4 (permalink) Old 03-17-2008, 04:00 PM
Crazy Fabricatin' Admin
 
gotKRAUT's Avatar
 
Join Date: Feb 2004
Location: Elk Grove, CA
Posts: 9,355
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute gotKRAUT has a reputation beyond repute
Send a message via AIM to gotKRAUT Send a message via MSN to gotKRAUT Send a message via Yahoo to gotKRAUT
actually the BMW one is very accurate, it works via ambient temperature, fuel flow rates and throttle position

Completely different than the crude VW system

did you replace the battery to the board? if its got a new board and still off then the batteries are bad or the actual instrument itself...have you swapped injectors or engines?

Kyle Sutherland

1995 BMW 540i/6:
The Calypso Beast Vid 0-70ish
1987 BMW 325es: Face & Butt Lifted/M50tu Swapped*Sold*
1985 VW Scirocco: Too many mods, money pit*Sold*
E34 Plate Filler Wanted!
gotKRAUT is offline  
#5 (permalink) Old 03-17-2008, 04:45 PM
Dig
n00b
 
Join Date: Sep 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dig is on a distinguished road
(Thread Starter)
Kyle, thanks for the reply. I put in a remanufactured board and I actually checked the batteries before I put the board in. They were almost completely charged. Do they recharge when the engine is running or whenever they're connected to a 12 volt battery? The board was rebuilt in September of 2007. There has not been any work done to the engine, it has less than 65,000 on it. The MPG gauge is basically doing the opposite of what it's supposed to do except when I'm at highway speed and take my foot of the gas. It's really weird.
Dig is offline  
#6 (permalink) Old 03-18-2008, 12:56 AM
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Posts: 629
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dvmotorsports is on a distinguished road
Quote:
Originally Posted by gotKRAUT View Post
actually the BMW one is very accurate, it works via ambient temperature, fuel flow rates and throttle position
on the old ones? i thought that setup was only on newer cars.

BMW Technician
dvmotorsports is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
S I BOARD HELP! chuckie1 3-Series (E21, E30) 11 11-13-2005 08:09 PM
Si Board yamaha405 3-Series (E21, E30) 1 02-27-2005 09:15 AM
Si Board calves2997 3-Series (E21, E30) 2 01-12-2004 11:27 AM
SI-Board chrisz2000 Bimmer Talk/Motorsports Talk 1 11-21-2003 02:53 AM
New to the board, need some help. Cat Biscuits Bimmer Talk/Motorsports Talk 7 09-12-2003 03:24 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome