random stalling... - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-07-2009, 12:56 PM   #1 (permalink)
n00b
 
Join Date: Jul 2006
Car:
Posts: 27
Photos:
91 325ix is on a distinguished road
random stalling...

hey guys, I own a 1991 325ix with almost 230,000 miles and this is my problem.

I've spent hours searching this forum for a fix to the problem still haven't found it, a lot of people with the same problem but no specific fix. My car started stalling out a couple of weeks ago. I was just cruising when the engine stalled. Waited for a couple of minutes and it started again, I drove for about 30 seconds when stalled again, it did that four times till I got home. The next morning same problem, me and my father checked the engine for something loose or disconnected, nothing wrong. Checked the fuel pump, working just fine. Then we switched the fuel pump relay with the one next to it which is similar. The car ran just fine for a week or so. When it started stalling again it would not cut off completely it would just bog off and with a downshift it would run fine again. Yesterday it stalled twice and had to crank it a few times before it started again. Thinking it has something to do with the relays I unplugged the fuel pump relay and the one next to it, let the car sit for a couple of minutes and plugged them back in. It started just fine and got home without problem. Today happened the same thing and repeated the same process and got home with the engine just hesitating one time but it did not stalled.

After reading a couple of threads about this problem I went to check for loose vacuum hoses or loose plugs, nothing wrong. The only thing that I haven't checked yet is the fuel filter.

BTW. The timing belt was changed a couple of months ago, the mechanic told me to take the car back in a couple of months to readjust the valves, could this be another symptom that's causing this problem??

thanks in advance
91 325ix is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2009, 01:43 PM   #2 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
I don't think valves out of adjustment could cause stalling. How old is the fuel pump?
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 07-07-2009, 02:45 PM   #3 (permalink)
n00b
 
Join Date: Jul 2006
Car:
Posts: 27
Photos:
91 325ix is on a distinguished road
not even two months old, the old one went bad because of the old fuel left in the tank went bad and damaged it. The car was at the shop for a long time, so that happened.

Last edited by 91 325ix; 07-07-2009 at 02:54 PM.
91 325ix is offline   Reply With Quote
Old 07-07-2009, 07:37 PM   #4 (permalink)
2nd Gear Member
 
Join Date: Oct 2008
Car:
Posts: 493
Photos:
silversled can only hope to improve
yeah, the fuel filter sounds like a possiblity, especially if the engine stalls more frequently with higher speed longer runs than just short around town runs...could be a clogged fuel filter...good luck cliff
silversled is offline   Reply With Quote
Old 07-07-2009, 07:39 PM   #5 (permalink)
2nd Gear Member
 
Join Date: Oct 2008
Car:
Posts: 493
Photos:
silversled can only hope to improve
and no, valves won't cause that....absolutely not out of adjusted valves...sounds like your on the right track with the fuel thing....
silversled is offline   Reply With Quote
Old 07-08-2009, 04:13 PM   #6 (permalink)
n00b
 
Join Date: Jul 2006
Car:
Posts: 27
Photos:
91 325ix is on a distinguished road
as soon as I can I'll change the fuel filter, and post again...
thanks
91 325ix is offline   Reply With Quote
Old 07-23-2009, 07:16 PM   #7 (permalink)
n00b
 
Join Date: Jul 2006
Car:
Posts: 27
Photos:
91 325ix is on a distinguished road
Finally changed the fuel filter but the problem continues. Last week the ran car fine with the old filter still in, on the weekend I installed the new one and it kept working well till today. It happened like this, I was about to enter the highway and when I was going to step on the gas I felt the stall coming, the thing that the car does is that it keeps running till you step on the gas. When I press on the gas it makes like a choking sound if I take the foot of the gas it keeps running until momentum is lost and stalls. Then it starts like nothing happened, sometimes it takes like a minute to start again but most of the times it starts right away. Could this be related to the air intake system, maybe the throttle gets stuck or something I'm really running out of ideas. Btw. the air filter is like three months old.

Anything that you guys might think it is??

thanks
91 325ix is offline   Reply With Quote
Old 10-23-2009, 05:34 PM   #8 (permalink)
n00b
 
Join Date: Oct 2009
Car:
Posts: 11
Photos:
seppy is on a distinguished road
Quote:
Originally Posted by 91 325ix View Post
Finally changed the fuel filter but the problem continues. Last week the ran car fine with the old filter still in, on the weekend I installed the new one and it kept working well till today. It happened like this, I was about to enter the highway and when I was going to step on the gas I felt the stall coming, the thing that the car does is that it keeps running till you step on the gas. When I press on the gas it makes like a choking sound if I take the foot of the gas it keeps running until momentum is lost and stalls. Then it starts like nothing happened, sometimes it takes like a minute to start again but most of the times it starts right away. Could this be related to the air intake system, maybe the throttle gets stuck or something I'm really running out of ideas. Btw. the air filter is like three months old.

Anything that you guys might think it is??

thanks
hi,
i have the exact same problem on a 93 325i. did you find out what it is thats causing this. thanks
seppy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random Stalling and dies; it won't start sjw2152 3-Series (E36) 9 05-02-2008 05:30 PM
Stalling bagelboy91 3-Series (E21, E30) 6 04-26-2007 10:28 AM
Help...Stalling NewBMWowner 3-Series (E36) 10 09-01-2004 11:25 AM
stalling tonsalvado Bimmerwerkz.com Site Help 1 07-24-2004 04:21 PM
STALLING!!!!!!! BlackEye 5-Series (E12,E28, E34, E39, E60) 1 08-24-2003 08:41 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:55 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.