Problem with signal indicator light - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-31-2004, 03:13 PM   #1 (permalink)
Neutral Member
 
Join Date: Jul 2004
Location: Vancouver, BC
Car:
Posts: 68
Photos:
ye12 is an unknown quantity at this point
I have an 89 325i and at random, the left turn signal indicator on the dash stops working. Is there a easy fix for this?
ye12 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-31-2004, 05:45 PM   #2 (permalink)
n00b
 
Join Date: Oct 2003
Location: Calgary, Canada
Car:
Posts: 33
Photos:
All wheels rolling is an unknown quantity at this point
Does it work and then it'll start clicking fast like a light is out or does it blink and then not blink? There's a big difference.

Preston
All wheels rolling is offline   Reply With Quote
Old 09-02-2004, 03:04 PM   #3 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Wow, how strange! I have an 89 and that very same problem. The signal works though B)
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 09-02-2004, 09:38 PM   #4 (permalink)
Neutral Member
 
Join Date: Jul 2004
Location: Vancouver, BC
Car:
Posts: 68
Photos:
ye12 is an unknown quantity at this point
Quote:
Originally posted by All wheels rolling@Aug 31 2004, 06:25 PM
Does it work and then it'll start clicking fast like a light is out or does it blink and then not blink? There's a big difference.

Preston
No, the blinker works normally and the front and rear lights blink fine. The dash indicator doesn't always work. It appears to be a loose connection or maybe the filament on the bulb is ready to break. Before I start taking apart the dash, I though I would ask if anyone else had fixed this problem.
ye12 is offline   Reply With Quote
Old 09-02-2004, 11:34 PM   #5 (permalink)
5th Gear Member
 
BMWJNKY's Avatar
 
Join Date: Oct 2003
Location: Elk Grove, CA
Car: '89 E30 w/M50
Posts: 1,175
Photos:
BMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond reputeBMWJNKY has a reputation beyond repute
Send a message via AIM to BMWJNKY Send a message via Yahoo to BMWJNKY
To get the cluster out of an E30 isn't that hard. 30min tops with basic hand tools and a haynes/bently manual.
__________________
My M50 Powered E30 Page

BMWJNKY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic Idle / Misfire / Cutting out makdolby 3-Series (E36) 12 02-05-2012 07:57 AM
Turn Signal Problem, stuck on, not blinking. jek1955 3-Series (E36) 2 10-27-2005 06:48 AM
Smg Problem On 330i johanfunsale 3-Series (E46, E90) 0 02-28-2005 07:33 AM
Wierd Turn Signal Problem theratdude64 3-Series (E21, E30) 13 10-24-2004 11:16 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:23 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.