Perplexing Idle behaviour (325e auto) :conf - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-25-2009, 12:10 PM
n00b
 
shin_arkhangel's Avatar
 
Join Date: May 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
shin_arkhangel is on a distinguished road
(Thread Starter)
Perplexing Idle behaviour (325e auto) :conf

Hi everyone, I'd like to thank the forum members for helping me out for the past two problems I've had.

This one is sort of related, and I've tried to look around and study up but I still don't have a narrow list of possible problems to choose from.

Long post ahead.

-------------------------------------------------------------------------

Now tending to the problem of a fluctuating idle and it seems to be a fairly common problem with lots of possible fixes around. Thing is, the car doesn't consistently give me an erratic idle.

At last servicing/repair which is about 6 months ago, the mechanic said that he had tuned the O2 sensor as best as he can and changed the spark plugs. Previously, the car was apparently running lean. After servicing, the idle would run stable at 1000rpm (only learned recently that a normal RPM is around 750). Another thing he noted was "stuck injectors" which he didn't change (and how he knew they were stuck, I don't know)

He also recommended that I use 98 Octane unleaded petrol instead of 91 Octane. I now use 98 in almost every tank as I did feel increased power and better fuel efficiency. (This car is in Australia, where the petrol types are 91, 95 and 98)

After 4 months, the engine was showing infrequent signs of an erratic idle, though this was not always the case when I drove.

--------------------------------------------------------------------------

Now, more than 6 months later and after changing the battery, erratic idle revs are a frequent occurrence (goes from 1000 to 1400, drops and repeats cycle). This happens only after the engine is sufficiently warmed up/ hot (temp gauge needle is approx vertical straight/middle)

So I decide that I ought to try cleaning the ICV, which I do with a can of carb cleaner. Cleaner removes a fair amount of black sediment. Reinstall ICV...

And the idle rev drops dramatically to 500rpm and stays there, dropping slightly when the car is in Drive. No hesitation when I press the accelerator though.

I drive the car for a good 30 minutes (warming the car up) and bring it to a park and the idle rev is still hovering around 500-550rpm.

I come back 3 hours later and start the car (engine is cold). the idle rev is now close to 1000rpm and not fluctuating. Later on, about 15 minutes into a drive, I put the car into neutral and the rev fluctuates like it did before (engine warm). Another 15 minutes later, in front of my driveway and in Park, I rev the engine to 3000rpm and the idle now stabilizes at 1000 rpm (engine warm).



Will drive the car around again tomorrow and see what happens. Also, the fuel efficiency of the car is also deteriorating. I used to be able to do 28.24mpg (8.33l/100km) in the car but last mileage I got was 23.3mpg and it looks like it's getting worse.

-------------------------------------------------------------------------

Once this tank of fuel runs out, I'll probably go and run fuel injector cleaner to see if that improves performance in any way.

In the meantime though, does anyone have a clue as to why the engine idles like that and so inconsistently?
shin_arkhangel is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-25-2009, 06:27 PM
1st Gear Member
 
325isBMW1988's Avatar
 
Join Date: Aug 2008
Location: New England
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBMW1988 is on a distinguished road
Send a message via AIM to 325isBMW1988
my car is doing the same thing.....im replacing the fuel pump to see if that fixes my problem, thats just about the only part for that problem that i havent replaced yet....tricky E30's

let me know if you figure your problem out! ill do the same!

Last edited by 325isBMW1988; 03-25-2009 at 06:27 PM. Reason: Add
325isBMW1988 is offline  
#3 (permalink) Old 03-25-2009, 07:20 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
there is one thing you stated that motivates me to comment....tuned the O2 sensor? you cannot tune an O2 sensor.....
silversled is offline  
#4 (permalink) Old 03-25-2009, 09:05 PM
n00b
 
shin_arkhangel's Avatar
 
Join Date: May 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
shin_arkhangel is on a distinguished road
(Thread Starter)
Hmm, Is an O2 sensor = Airflow Meter? I've been speaking to at least 2 people and am getting the impression that the two are interchangeable. So either one of the two (or both) are confusing me... Hmm
shin_arkhangel is offline  
#5 (permalink) Old 03-25-2009, 09:40 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
no, the air flow meter is totally different than the O2 sensor; pricewise locationwise and replacementwise....however, ironically, they are very closely related, they talk alot through the grapevine....
silversled is offline  
#6 (permalink) Old 03-26-2009, 10:34 AM
1st Gear Member
 
325isBMW1988's Avatar
 
Join Date: Aug 2008
Location: New England
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBMW1988 is on a distinguished road
Send a message via AIM to 325isBMW1988
ive replaced both my AFM and my O2 sensor and the problem still occurs!
325isBMW1988 is offline  
#7 (permalink) Old 03-26-2009, 11:51 AM
n00b
 
shin_arkhangel's Avatar
 
Join Date: May 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
shin_arkhangel is on a distinguished road
(Thread Starter)
Well I drove my car around today and erratic revving is *almost* absent. Most of the time, the idle rev is what it used to be before going nuts. When the rev does get nutty, I forcibly throttle the engine past 2000rpm and the erratic revving stops once I let go.

Eh, I'm not expert at this, the only thing I did was clean the ICV. Next stop, injector cleaners. By the way, is your engine temp gauge working?
shin_arkhangel is offline  
#8 (permalink) Old 03-26-2009, 07:28 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
I would suggest checking the throttle linkage...could be binding/gummed up....
silversled is offline  
#9 (permalink) Old 04-07-2009, 01:39 AM
n00b
 
Join Date: Apr 2008
Location: Washington
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Joe318 is on a distinguished road
sounds like it could very well be a vacume leak my 92 e30 did the same thing then i replaced all the hoses and never did it again.
Joe318 is offline  
#10 (permalink) Old 04-07-2009, 10:05 AM
1st Gear Member
 
325isBMW1988's Avatar
 
Join Date: Aug 2008
Location: New England
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBMW1988 is on a distinguished road
Send a message via AIM to 325isBMW1988
my car is fixed!!!! come to find out my fuel pump was halfway on the grommet! :0 Bought a used one for 80 bucks and she runs like a new BMW (kinda lol) and shes running 34 mpg right now with all the sensors i replaced! thanks for all the help everyone!
325isBMW1988 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
85 325e Start/Idle Issues benjamintracy 3-Series (E21, E30) 0 01-13-2009 07:04 AM
Erratic idle 523i Auto E39 DuncanThomas 5-Series (E12,E28, E34, E39, E60) 4 06-19-2008 11:08 AM
325e IDLE PROBLEMS pinnaclebass 3-Series (E21, E30) 6 06-02-2008 02:57 AM
86 325e engine swap to 91i idle problem lemonhead 3-Series (E21, E30) 10 02-21-2006 06:05 PM
BMW 318i 1996 strange behaviour >?< hmm benny 3-Series (E36) 6 06-19-2004 06:46 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome