Odometer not reading - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-12-2008, 09:59 AM   #1 (permalink)
Neutral Member
 
Join Date: May 2008
Location: dallas
Car: 85 325e 90 525I '96 328i
Posts: 91
Photos:
pinnaclebass is on a distinguished road
Send a message via AIM to pinnaclebass Send a message via Yahoo to pinnaclebass
Odometer not reading

so the Odometer on the 1985 325e has stopped reading, the trip meter has stopped rolling. is it the board inside the dash?? or some external hook up or wiring.
pinnaclebass is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2008, 10:47 AM   #2 (permalink)
3rd Gear Member
 
Nick_318is's Avatar
 
Join Date: Dec 2007
Location: Detroit, MI
Car: 1991 318is, 2005 Subaru Legacy GT
Posts: 570
Photos:
Nick_318is is on a distinguished road
Garage
Send a message via AIM to Nick_318is
I know the hook up comes off of the rear Diff for the speed, you might want to check that it is connected, if it is, chances are that it is something else.
__________________

Quote:
Originally Posted by yammahamma View Post
If I wanted to date you, I would have bought you dinner first.
Nick_318is is offline   Reply With Quote
Old 07-12-2008, 03:06 PM   #3 (permalink)
Neutral Member
 
Join Date: May 2008
Location: dallas
Car: 85 325e 90 525I '96 328i
Posts: 91
Photos:
pinnaclebass is on a distinguished road
Send a message via AIM to pinnaclebass Send a message via Yahoo to pinnaclebass
well everything is reading except miles arent scrolling through. for main gauge or the trip monitor. so im wondering what it is.
pinnaclebass is offline   Reply With Quote
Old 07-12-2008, 05:46 PM   #4 (permalink)
3rd Gear Member
 
Nick_318is's Avatar
 
Join Date: Dec 2007
Location: Detroit, MI
Car: 1991 318is, 2005 Subaru Legacy GT
Posts: 570
Photos:
Nick_318is is on a distinguished road
Garage
Send a message via AIM to Nick_318is
Might be the SI board's batteries? Notice anything else strange going on with your gauges? Otherwise I have seen cases where people have reported that an actual gear in the cluster goes bad, so you might have to pull the gauge cluster out as your next step.
__________________

Quote:
Originally Posted by yammahamma View Post
If I wanted to date you, I would have bought you dinner first.
Nick_318is is offline   Reply With Quote
Old 07-13-2008, 06:12 PM   #5 (permalink)
Neutral Member
 
Join Date: May 2008
Location: dallas
Car: 85 325e 90 525I '96 328i
Posts: 91
Photos:
pinnaclebass is on a distinguished road
Send a message via AIM to pinnaclebass Send a message via Yahoo to pinnaclebass
ya actually the temperature gauge is reading a 1/4 off. it works it just reads low. and the service indicator light cant be reset.

but yes biggest thing the mileage wont read.
can that be the batteries to the board?
pinnaclebass is offline   Reply With Quote
Old 07-14-2008, 07:52 PM   #6 (permalink)
3rd Gear Member
 
Nick_318is's Avatar
 
Join Date: Dec 2007
Location: Detroit, MI
Car: 1991 318is, 2005 Subaru Legacy GT
Posts: 570
Photos:
Nick_318is is on a distinguished road
Garage
Send a message via AIM to Nick_318is
It might be but i'm really not sure I think you have to pull the cluster to do the batteries, but I have never done it, so i'm not 100% sure. While you have the cluster out take a look.
__________________

Quote:
Originally Posted by yammahamma View Post
If I wanted to date you, I would have bought you dinner first.
Nick_318is is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tachometer reading is off! bimmerguy82 3-Series (E36) 5 12-29-2006 10:11 PM
Outside temp reading jon1282 5-Series (E12,E28, E34, E39, E60) 9 11-07-2006 02:52 AM
Outside Temp Reading jah5927 5-Series (E12,E28, E34, E39, E60) 8 08-29-2005 09:14 PM
Temperature Reading afrochapin 5-Series (E12,E28, E34, E39, E60) 2 04-12-2005 05:26 PM
Temperature Reading Thief 3-Series (E46, E90) 1 11-29-2004 02:16 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:28 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.