No spark after reversed polarity battery fried ignition coil and smoked alternator - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-25-2008, 04:35 PM
n00b
 
Join Date: May 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rotocrazy is on a distinguished road
(Thread Starter)
No spark after reversed polarity battery fried ignition coil and smoked alternator

1986 325es sitting for 1 year. changed fluid. started ok with jumpers. charged battery then could not start. battery was reversed polarity so it smoked my alternator and ignition coil. replaced ignition coil and battery. Now I have no spark.

What could the reverse polarity battery posibly done and how can i fix?
rotocrazy is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-26-2008, 12:51 AM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
check your fuses.... could have fried your ecu.....

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#3 (permalink) Old 05-26-2008, 06:25 PM
n00b
 
Join Date: May 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rotocrazy is on a distinguished road
(Thread Starter)
Thank you. just replaced fuses and checked the ignition coil ok. it cranks strong, still wont start.

Note. alternator previously glowed red and smoked, Now battery light is always on when ignition is on.

1-does the alternator needs to be operative to start?
2-any ideas?
rotocrazy is offline  
#4 (permalink) Old 05-26-2008, 09:22 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
Replace the alternator... It MOST LIKEY has a major short in it.... Also check your main relay

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
High Perfomance Ignition Coil dannyb 3-Series (E36) 1 06-18-2007 01:27 PM
Ignition Coil problem blackride 3-Series (E46, E90) 4 10-21-2006 01:43 AM
Pertronix electronic ignition COIL shield 3-Series (E21, E30) 9 09-07-2004 06:37 PM
Ignition Coil Problem Ethylene Oxide 3-Series (E46, E90) 1 08-16-2004 06:04 PM
90 525i - bad ignition coil? thebaldguy 5-Series (E12,E28, E34, E39, E60) 1 04-26-2004 03:38 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome