New Member Tech Question - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-20-2010, 11:33 AM   #1 (permalink)
n00b
 
Join Date: May 2010
Location: British Columbia Canada
Car: 1982 BMW 320i
Posts: 6
Photos:
Island Highway is on a distinguished road
New Member Tech Question

Hi,

I don't want to bother anyone so please let me know if this isn't the right place to post this question. I have a 1982 320i which I recently bought. Its been running great for the last 2 months or so, but suddenly it hates starting (it eventually starts though) and when I run at higher RPM's it starts bucking and hesitating. I've never owned a BMW before so I can't isolate the issue to anything I already know about cars. I'm hoping its a simple thing and I can get back to driving it with confidence again. Any feedback on this would be deeply appreciated.

Thanks.
Island Highway is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-26-2010, 03:15 AM   #2 (permalink)
1st Gear Member
 
Join Date: Jul 2009
Car:
Posts: 137
Photos:
tim96 is on a distinguished road
A dodgey fuel pump is possible. Is the pump noisy at all?
tim96 is offline   Reply With Quote
Old 05-26-2010, 06:37 AM   #3 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
Welcome to the Werkz.

Is it possible you picked up some dirty fuel that may have blocked your fuel filter, or that may have contained water?
brettski is offline   Reply With Quote
Old 05-26-2010, 07:22 AM   #4 (permalink)
You Can Has A Custom Title!!
 
german-speed-demon's Avatar
 
Join Date: Feb 2005
Car:
Posts: 8,829
Photos:
german-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant futuregerman-speed-demon has a brilliant future
fuel pump, fuel fiilter, if your car is FI, (which i think it is, )check the the o2 sensor. also Throttle position sensor, idle control valve, cold start valve.

any of these would be a likely culprit.
__________________
R.I.P fast 6


Two wheels or Four, I'm happy as long as the throttle is pinned.
german-speed-demon is offline   Reply With Quote
Old 05-26-2010, 02:51 PM   #5 (permalink)
n00b
 
Join Date: May 2010
Location: British Columbia Canada
Car: 1982 BMW 320i
Posts: 6
Photos:
Island Highway is on a distinguished road
It was the fuel filter which it took me about the same amount of time to find as the handle to open the door from the inside (I feel pretty dumb haha). I've since replaced the filter and now the car is running very smoothly again. I'm grateful that it wasn't more serious. Thanks to all of you for your suggestions, you are very helpful and I really appreciate it!
Island Highway is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tech Question Shudogg 3-Series (E36) 0 03-03-2005 02:31 PM
Tech question 1faste30 3-Series (E36) 1 08-23-2004 10:08 AM
Tech Question gotKRAUT 3-Series (E21, E30) 11 08-09-2004 09:01 PM
Question for the TECH Braymond 3-Series (E46, E90) 5 02-27-2004 06:02 PM
tech question thekid 3-Series (E36) 0 02-27-2004 03:21 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:16 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.