Just bought 86 325E - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-11-2008, 08:21 AM   #1 (permalink)
n00b
 
Join Date: Dec 2008
Car:
Posts: 3
Photos:
damquick1 is on a distinguished road
Just bought 86 325E

So I bought this 86 325E, couldn't refuse the $400.00 price. The car is in fairly great shape, clean body, sunroof (nees to be adjusted but does not leak) no rot, interior complete but need some freshening, four new tires, new clutch, new battery, tie rod ends and ball joints. Runs good but I keep getting idiot lights on the overhead display showing coolant, oil and liscense plate lamp. Problem is the light is working & I just changed the oil & filter and did a motor flush, and the coolant seems to be full. I want to pull the t-stat, and then flush the cooling system, is there a way to flush the sealed cooling system? I can't seem to find a radiator petcock, I assume there is one? Has anyone done a flush on their E30 325 that can help me out here?
Is there a reset for the overhead other than pushing the "Check" light?

Also need to pick up a few pieces of trim, both interior and exterior, seems like most can be found on E-Bay, but I'm searching for the exterior drip rail trim for a 325E coupe, any ideas?

As soon as I get caught up I'll post some pics.


Thanks in advance for your help,
DQ
damquick1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-11-2008, 10:50 AM   #2 (permalink)
n00b
 
Join Date: Dec 2008
Location: upstate ny
Car: 1989 325i sedan love it!
Posts: 29
Photos:
89bmuh is on a distinguished road
what is showing up on the overlight sensors?
89bmuh is offline   Reply With Quote
Old 12-11-2008, 10:52 AM   #3 (permalink)
n00b
 
Join Date: Dec 2008
Location: upstate ny
Car: 1989 325i sedan love it!
Posts: 29
Photos:
89bmuh is on a distinguished road
Like the oil change light it wont reset until you either buy the tool or get it done at a shop. i know a friend that coild do it himself though.
89bmuh is offline   Reply With Quote
Old 12-11-2008, 12:51 PM   #4 (permalink)
n00b
 
Join Date: Dec 2008
Car:
Posts: 3
Photos:
damquick1 is on a distinguished road
Quote:
Originally Posted by 89bmuh View Post
what is showing up on the overlight sensors?
oil, coolant, and liscense light
damquick1 is offline   Reply With Quote
Old 12-11-2008, 07:37 PM   #5 (permalink)
n00b
 
Join Date: Dec 2008
Location: upstate ny
Car: 1989 325i sedan love it!
Posts: 29
Photos:
89bmuh is on a distinguished road
hmm....the oil you have to get reset from the plug on the engine at a shop that has one or buy a reset switch from bavarian autosports. the other to im not sure about though the sensors must be bad.
89bmuh is offline   Reply With Quote
Old 12-12-2008, 05:29 AM   #6 (permalink)
n00b
 
Join Date: Dec 2008
Car:
Posts: 3
Photos:
damquick1 is on a distinguished road
I think I'm going to replace the coolant temp sensor on the t-stat housing, I'll jump it first to see if it is faulty and then OHM it out, I read in another forum that is probably the issue as the temp gauge moves very very slow then jumps up to 1/3. Also noticed that the tach is sticking at 2K rpm's, I guess I'll be pulling the cluster to replace the NICAD batteries that are behind it. Has anyone else done this? It looks pretty easy but I want to make sure I don't screw it up.
damquick1 is offline   Reply With Quote
Old 12-12-2008, 04:40 PM   #7 (permalink)
n00b
 
Join Date: Apr 2004
Car:
Posts: 31
Photos:
solanog is an unknown quantity at this point
It may be that the sensors are not working, or something as simple as like they might be unplugged or dirty contacts. This lights (near the rearview mirror) would only light if levels are not O.K. or bulbs need to be replaced or are burnt. They have nothing to do with mileage, there is an oil light on the dash but that needs to be reset and there is a way to do that with just a simple wire, look for how to reset the SIL.
solanog is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just bought a 1984 325e DonnyDarko 3-Series (E21, E30) 10 06-05-2008 11:15 PM
New to BMWs, bought an '85 325e. StoneyBlouse 3-Series (E21, E30) 20 10-22-2006 05:27 PM
Anyone Looking For A 84 325e? emericadna7 3-Series (E21, E30) 0 05-09-2005 02:49 PM
Just bought a 1984 325e joshh 3-Series (E21, E30) 5 08-06-2004 12:41 PM
'85 325e needs help!! pig325e 3-Series (E21, E30) 3 07-02-2004 01:16 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:29 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.