Help - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-01-2011, 12:52 PM   #1 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 11
Photos:
beamerman325 is on a distinguished road
Help

i have a 1987 bmw 325i covertible it won't start engine rotates but there is no spark i put a new timing belt,ecu,pulse sensor(crankshaft position sensor),cap and rotor it will start once in a while and run good for like 1 hour then it cuts right out now no spark and won't start plus when u turn the key on the check engine light don't come on and when and if it does thats when it will start also can't hear fuel pumps unless car starts or i jump the realay do u hear them when u click the key on? any help would be appriciated thanks alot
beamerman325 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-02-2011, 12:02 AM   #2 (permalink)
n00b
 
Join Date: Jul 2011
Location: Long Beach, CA
Car: 1984 BMW 318i
Posts: 49
Photos:
CaptDale is on a distinguished road
Your post is really hard to read and fully understand. Anyways, have you tried new spark plugs? I check those right after the battery and the distributor. Not too sure about what you mean with hearing the fuel pump.
CaptDale is offline   Reply With Quote
Old 08-04-2011, 03:29 PM   #3 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 11
Photos:
beamerman325 is on a distinguished road
thank i'll try new plugs but im not getting spark at the coil either and i,ve tried a new coil and still no spark what do i check on the battery and distributor?
beamerman325 is offline   Reply With Quote
Old 08-04-2011, 05:30 PM   #4 (permalink)
n00b
 
Join Date: Jul 2011
Location: Long Beach, CA
Car: 1984 BMW 318i
Posts: 49
Photos:
CaptDale is on a distinguished road
Well make sure the battery is charged enough and that the battery terminals are clean and the battery cables are tightened to the terminal and clean. Then make sure the distributor is clean (wd40 spray inside if moisture inside) and that the rotor is not broken, after that it is either a wiring problem or you might have to take it to the shop.
CaptDale is offline   Reply With Quote
Old 08-06-2011, 09:24 AM   #5 (permalink)
Captain... Savvy ?
 
Jack Dabsy's Avatar
 
Join Date: Apr 2011
Location: Barnsley UK
Car: BMW E38 728i 1996 Met Black
Posts: 2,194
Photos:
Jack Dabsy will become famous soon enough
Garage
Also check inside the distributor cap for "tracking" or physical cracks...
Pull out a spark plug and reconnect it to its lead, turn the motor over (with the plug body touching the engine to ground/earth it) and look for a spark and notice its colour (should be a lovely blue !!
No Spark = electrical
Spark = fuelling or timing
__________________

Eso es todo!
Please press the "REP" button if you are happy with your response/answer...

Please JOIN, or just have a look... Its Totally FREE...
BMW Part Market

BMW Online Manuals (TIS)

New Member ?
Jack Dabsy is offline   Reply With Quote
Old 08-08-2011, 09:13 AM   #6 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 11
Photos:
beamerman325 is on a distinguished road
i tryed all that i have no spark and the cap and rotor are brand new thank you for the help
beamerman325 is offline   Reply With Quote
Old 08-08-2011, 09:32 AM   #7 (permalink)
1st Gear Member
 
Penngwyne's Avatar
 
Join Date: Nov 2010
Location: Naracoorte, South Australia
Car: E34 525i 1989/03
Posts: 106
Photos:
Penngwyne is on a distinguished road
Possibly a loose connection somewhere
Make yourself a test lamp and see if you actually have power at the coil
Look for loose fuses and relays and connectors.Give connectors a wriggle and see what happens.
Not familiar with the 3 series but just had an intermittent fault with my daily drive (which I hope has been fixed) due to a loose connector at the ECU causing spark problems.
__________________
My daily is a Mitsubishi HSGR (but I wouldn't mind an e34 525i)
Penngwyne is offline   Reply With Quote
Old 08-08-2011, 10:12 PM   #8 (permalink)
n00b
 
Join Date: May 2010
Car:
Posts: 11
Photos:
beamerman325 is on a distinguished road
the three relays on the driver side strut tower does anyone know what the one closest to the front of the car is for? or called cause i think thats what is causing the problem but i don't know what it controls so i can't get a new one it is the only five prong relay in the car
beamerman325 is offline   Reply With Quote
Old 09-04-2011, 04:01 PM   #9 (permalink)
n00b
 
Join Date: May 2009
Car: 1992 325i Convertable E30
Posts: 1
Photos:
psy4s is on a distinguished road
Quote:
Originally Posted by beamerman325 View Post
i have a 1987 bmw 325i covertible it won't start engine rotates but there is no spark i put a new timing belt,ecu,pulse sensor(crankshaft position sensor),cap and rotor it will start once in a while and run good for like 1 hour then it cuts right out now no spark and won't start plus when u turn the key on the check engine light don't come on and when and if it does thats when it will start also can't hear fuel pumps unless car starts or i jump the realay do u hear them when u click the key on? any help would be appriciated thanks alot
I had this same problem. I replaced the fuel pump and boom everything is fine.
psy4s is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:04 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.