heater/ac blower issue - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-31-2007, 07:18 AM
n00b
 
Join Date: Aug 2007
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rmousir is on a distinguished road
(Thread Starter)
heater/ac blower issue

Hi all,

I am new here.

I have a older 325is and some things are starting to go on it.. Most recently is the heater/ac fan switch.. This morning I got in the car and the only level that would come on was #4 or highest. None of the other fan switch levels worked. I never noticed this before so I expect that it is new. I also wanted to add that I know that I need to do some fixing on the speedo as it works when it wants to. What do you folks suggest?

Thanks very much in advance for your time, suggestions, and comments.

Richard.
rmousir is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-31-2007, 10:28 AM
5th Gear Member
 
BMWJNKY's Avatar
 
Join Date: Oct 2003
Location: Elk Grove, CA
Posts: 1,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute
Send a message via AIM to BMWJNKY Send a message via Yahoo to BMWJNKY
Sounds like the blower motor resistor has gone bad. For fan speeds 1-3 the current runs through a different resistance level to control how fast the fan turns but on 4 there is no resistance so it bypasses the resistor. This is why your fan only works on 4.

Best thing to do with the speedo is pull the cluster, and make sure all the connectors are clean. If everything looks good it may just need a new speedo.
BMWJNKY is offline  
#3 (permalink) Old 08-31-2007, 12:37 PM
n00b
 
Join Date: Aug 2007
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rmousir is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by BMWJNKY
Sounds like the blower motor resistor has gone bad. For fan speeds 1-3 the current runs through a different resistance level to control how fast the fan turns but on 4 there is no resistance so it bypasses the resistor. This is why your fan only works on 4.

Best thing to do with the speedo is pull the cluster, and make sure all the connectors are clean. If everything looks good it may just need a new speedo.
Great info! Thanks very much.. I plan on digging into the car this week.. Any idea on where I can get a resister on the cheap? I priced out a new one and it came in just under $100. I don't see that happening.. I also read that I could clean it up first and then put it back to see if it works before replacing it.

I will do the same for the speedo.
rmousir is offline  
#4 (permalink) Old 08-31-2007, 02:46 PM
5th Gear Member
 
BMWJNKY's Avatar
 
Join Date: Oct 2003
Location: Elk Grove, CA
Posts: 1,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute
Send a message via AIM to BMWJNKY Send a message via Yahoo to BMWJNKY
I highly doubt cleaning the resistor will work, usually the burn and short out and there is nothing that can be done to fix them.

$100 better be the installed price because list on the part is $35.75 and $24.26 depending on what one is in the car and labor to install it is about 45min.
BMWJNKY is offline  
#5 (permalink) Old 08-31-2007, 03:43 PM
n00b
 
Join Date: Aug 2007
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rmousir is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by BMWJNKY
I highly doubt cleaning the resistor will work, usually the burn and short out and there is nothing that can be done to fix them.

$100 better be the installed price because list on the part is $35.75 and $24.26 depending on what one is in the car and labor to install it is about 45min.
Is this something I can get at autozone or do I need a special BMW part place?
rmousir is offline  
#6 (permalink) Old 09-04-2007, 12:36 PM
5th Gear Member
 
BMWJNKY's Avatar
 
Join Date: Oct 2003
Location: Elk Grove, CA
Posts: 1,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute BMWJNKY has a reputation beyond repute
Send a message via AIM to BMWJNKY Send a message via Yahoo to BMWJNKY
You will probably have to get it at a place that deals with BMW parts.
BMWJNKY is offline  
#7 (permalink) Old 09-07-2007, 04:15 PM
Neutral Member
 
Handsome Rob's Avatar
 
Join Date: Apr 2005
Location: Springville, Ut
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Handsome Rob is an unknown quantity at this point
Send a message via AIM to Handsome Rob Send a message via MSN to Handsome Rob
Go here. They have the best prices iv seen. I have the same problem with my climate control

BMW Parts Catalog - BMW 3-series 84-05 - E30 3-series 84-92 - A/C, Heat, Climate Control

1986 BMW 325E - Alpine White
2001 Audi A4 - Santorin Blue
Handsome Rob is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Blower Motor Chirp Fixed jnash 3-Series (E46, E90) 2 07-07-2009 09:41 AM
2000 323I blower not working - HELP Shawnna 3-Series (E46, E90) 2 01-19-2006 06:16 AM
Blower Only Works on Setting 4 rfthomas 3-Series (E36) 9 01-17-2006 09:17 PM
01, 330ci Blower For The Heater/ac Stopped Working Ajayup 3-Series (E46, E90) 4 12-23-2004 06:37 PM
Weird cabin blower issue kestrel325is 3-Series (E36) 3 07-22-2004 04:51 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome