Gas Treatment - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-13-2005, 07:54 PM   #1 (permalink)
n00b
 
Join Date: Dec 2004
Car:
Posts: 33
Photos:
BMWDriver86 is an unknown quantity at this point
So I added in STP gas treatment and the car has been starting every time and when it was really cold it still started up pretty easily, mabey one or 2 tries when it was freezing. Does this mean I should add that STP gas treatment every time I fill up the car or just that once? Get back on that subject please.
BMWDriver86 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-13-2005, 08:44 PM   #2 (permalink)
2nd Gear Member
 
Join Date: Sep 2004
Car:
Posts: 382
Photos:
Casey3561 is an unknown quantity at this point
No, just once in a while. Gas treatments tend to also serve as octane boosters- most contain ample portions of alcohol as a water remover. Running it too much simply isn't a good thing for the motor.
__________________
Proud member of the 100,000 mile club
Proud member of the I Hate SUVs club
Casey3561 is offline   Reply With Quote
Old 02-15-2005, 09:50 PM   #3 (permalink)
n00b
 
Join Date: Dec 2004
Car:
Posts: 33
Photos:
BMWDriver86 is an unknown quantity at this point
like, the car needs it to actually start I think, I got starting problems when its cold and I poured that stuff in on a full tank and untill the tank ran out it started every time instantly no matter what temperature till it ran out, then I put in half a tank and it didnt start the next day. So I went and poured in some more of that and in about 3 mins it started. what do you think? get back to me on that.
BMWDriver86 is offline   Reply With Quote
Old 02-16-2005, 03:41 PM   #4 (permalink)
3rd Gear Member
 
Join Date: Dec 2004
Location: jacksonville beach
Car:
Posts: 577
Photos:
e30fanm3 is an unknown quantity at this point
Send a message via AIM to e30fanm3 Send a message via Yahoo to e30fanm3
you could need a fuel filter or fuel pressure regulator
e30fanm3 is offline   Reply With Quote
Old 02-16-2005, 07:17 PM   #5 (permalink)
n00b
 
Join Date: Dec 2004
Car:
Posts: 33
Photos:
BMWDriver86 is an unknown quantity at this point
so what is making it work with that gas treatment? doesnt make sense. Let me know.
BMWDriver86 is offline   Reply With Quote
Old 02-17-2005, 04:26 PM   #6 (permalink)
3rd Gear Member
 
Join Date: Dec 2004
Location: jacksonville beach
Car:
Posts: 577
Photos:
e30fanm3 is an unknown quantity at this point
Send a message via AIM to e30fanm3 Send a message via Yahoo to e30fanm3
the reason i say maybe a fuel filter is cause the additive is a higher octane so maybe the engine doesnt need as much to run as it would with just gas so if the filter is a little clogged it may still be getting enough of the additive to run. same thing with the fuel pressure regulator, but thats just a guess i could be way off, i would have to have the car here to correctly diagnose
e30fanm3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow to start - gas smell irish 3-Series (E21, E30) 2 11-01-2005 02:42 PM
Erratic Gas Guage misterervin 3-Series (E21, E30) 5 09-22-2005 08:20 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:44 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.