Fast Blinking Right Hand Turn Signal - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-18-2005, 03:07 PM
n00b
 
Join Date: Dec 2004
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWDriver86 is an unknown quantity at this point
(Thread Starter)
I was driving my bmw today and I noticed that the right hand turn signal blinks really fast on the turn signal, but the left works normally, I looked at the the tail light and it was blinkin fast. Any ideas on what this might be? Get back to me please.
BMWDriver86 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-18-2005, 03:12 PM
3rd Gear Member
 
Kowalski's Avatar
 
Join Date: Jan 2005
Location: Canada, British Columbia, White rock
Posts: 752
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Kowalski is an unknown quantity at this point
Send a message via MSN to Kowalski
did you just buy it? cause the guy berfore you could'v got a heavy duty blinker put in, they have different speeds, and he just might have gotten you one of them, or replace your relays other hten that i have no idea.

M42 Custom ground cams for sale PM me
264* roatation and 388 lift
Kowalski is offline  
#3 (permalink) Old 01-18-2005, 03:13 PM
3rd Gear Member
 
Kowalski's Avatar
 
Join Date: Jan 2005
Location: Canada, British Columbia, White rock
Posts: 752
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Kowalski is an unknown quantity at this point
Send a message via MSN to Kowalski
mine also does that some times too, not sure why but im going to replace the relay cause im pretty sure it never has been replaced. it does it some times and then it stops some times im nto really sure what the deal is.

M42 Custom ground cams for sale PM me
264* roatation and 388 lift
Kowalski is offline  
#4 (permalink) Old 01-18-2005, 04:45 PM
Neutral Member
 
BMW@JMU's Avatar
 
Join Date: Jan 2005
Posts: 77
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMW@JMU is an unknown quantity at this point
Try checking the front turn signal also. Chances are that bulb is out or not completing the circuit. If it is the front one, try giving the lense a bump with your hand...that may do the trick.

-1985 325e - 5000 RPM's of Fury
BMW@JMU is offline  
#5 (permalink) Old 01-18-2005, 08:51 PM
n00b
 
Join Date: Dec 2004
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWDriver86 is an unknown quantity at this point
(Thread Starter)
yea I did that and it worked, my only other problem is starting the car when its cold, it was just in the shop for no spark and fuel, they traced the problem to the power distribution box and repaired electrical open at power distribution box. When I got it out it was doing fine and I just got it out of the shop on the 11th of january. Any ideas what the problem could be now. it keeps trying to start till the power drains out and from there it will start like 4 mins later after u jump the car. The battery is brand new.
BMWDriver86 is offline  
#6 (permalink) Old 01-18-2005, 09:10 PM
3rd Gear Member
 
Kowalski's Avatar
 
Join Date: Jan 2005
Location: Canada, British Columbia, White rock
Posts: 752
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Kowalski is an unknown quantity at this point
Send a message via MSN to Kowalski
Quote:
Originally posted by BMWDriver86@Jan 18 2005, 07:51 PM
yea I did that and it worked, my only other problem is starting the car when its cold, it was just in the shop for no spark and fuel, they traced the problem to the power distribution box and repaired electrical open at power distribution box. When I got it out it was doing fine and I just got it out of the shop on the 11th of january. Any ideas what the problem could be now. it keeps trying to start till the power drains out and from there it will start like 4 mins later after u jump the car. The battery is brand new.
[snapback]274446[/snapback]
could be your idle control valve, on my car its on the back and its a vacume valve thats controlled by the computer, it should make a click noise when the car is turned on or you can take it out and hook it up to your battery with 2 wires and it should flip open, if it doesn't its broken. you can get one at a pick apart for like 10-20 bucks. thats what im thinking off the top of my head, other then that, could be the fuel pump, and its taking forever to get up the fuel presure so it can actualy inject into the engine and it takes that long to do so. ill keep thinking and let ya know what it could be if anything else pops into mind

M42 Custom ground cams for sale PM me
264* roatation and 388 lift
Kowalski is offline  
#7 (permalink) Old 01-19-2005, 05:51 PM
Neutral Member
 
BMW@JMU's Avatar
 
Join Date: Jan 2005
Posts: 77
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMW@JMU is an unknown quantity at this point
Quote:
Originally posted by BMWDriver86@Jan 18 2005, 10:51 PM
yea I did that and it worked, my only other problem is starting the car when its cold, it was just in the shop for no spark and fuel, they traced the problem to the power distribution box and repaired electrical open at power distribution box. When I got it out it was doing fine and I just got it out of the shop on the 11th of january. Any ideas what the problem could be now. it keeps trying to start till the power drains out and from there it will start like 4 mins later after u jump the car. The battery is brand new.
[snapback]274446[/snapback]
And it runs after you jump it? How long does it take for the batter to go dead? I can't help you too much right now, but I'll look it up in my Bentley once I go home on Friday to get my car out of the shop. I can finally drive it after two weeks.

-1985 325e - 5000 RPM's of Fury
BMW@JMU is offline  
#8 (permalink) Old 01-19-2005, 06:21 PM
3rd Gear Member
 
Join Date: Jul 2004
Location: Poquoson, VA
Posts: 591
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bear is an unknown quantity at this point
Quote:
Originally posted by BMWDriver86@Jan 18 2005, 03:07 PM
I was driving my bmw today and I noticed that the right hand turn signal blinks really fast on the turn signal, but the left works normally, I looked at the the tail light and it was blinkin fast. Any ideas on what this might be? Get back to me please.
[snapback]274199[/snapback]
Bear is offline  
#9 (permalink) Old 01-19-2005, 06:24 PM
3rd Gear Member
 
Join Date: Jul 2004
Location: Poquoson, VA
Posts: 591
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bear is an unknown quantity at this point
How is the front parking light, does it work? These are dual filament bulbs (one filament for parking and one for turn) and on my Bimmer I had a wire broken for the parking light and though the turn signal worked, the parking light did not and I had a rapid turn signal on that side.
Bear is offline  
#10 (permalink) Old 01-21-2005, 01:12 PM
n00b
 
Join Date: Oct 2003
Location: Calgary, Canada
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
All wheels rolling is an unknown quantity at this point
Quote:
yea I did that and it worked, my only other problem is starting the car when its cold, it was just in the shop for no spark and fuel, they traced the problem to the power distribution box and repaired electrical open at power distribution box. When I got it out it was doing fine and I just got it out of the shop on the 11th of january. Any ideas what the problem could be now. it keeps trying to start till the power drains out and from there it will start like 4 mins later after u jump the car. The battery is brand new.
Sounds a lot like a problem that I had too. Not starting and ends up draining the batery. Check the COLD CRANKING AMPS of your battery. BMW's of this era required 650 Cranking amps which would mena that you would need at least 725 CCA's to get it going in the winter. I thought that my problem was worse but I got a new battery that has 985 CCA's and it starts like it's 1989 right now (aka brand new). I'd suggest that.

Preston
All wheels rolling is offline  
#11 (permalink) Old 01-21-2005, 11:48 PM
n00b
 
Join Date: Dec 2004
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWDriver86 is an unknown quantity at this point
(Thread Starter)
yes, the turn signal thing worked, it blinks normal now. But I dont know I got a 700 cca battery, got it from advanced auto parts, and last night I tried to start it and wouldnt start. it was really cold out and I jumped it with my other car and that did not work and then I noticed smoke comming from the tail pipe, then under the car, and then from the hood. I dont know if thats bad or what happend, but I didnt get it started that night.
BMWDriver86 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Problem, stuck on, not blinking. jek1955 3-Series (E36) 2 10-27-2005 06:48 AM
How To Make Fast Turn Signal Blinkers... diehard_vue 5-Series (E12,E28, E34, E39, E60) 18 04-18-2005 02:58 PM
1984 528e Turn Signal Questions. rock_martyr 5-Series (E12,E28, E34, E39, E60) 1 11-09-2004 11:47 PM
Turn signal problems beau 3-Series (E46, E90) 3 08-22-2004 09:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome