electrical issue, please help - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-21-2007, 11:28 PM
n00b
 
Join Date: Mar 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dr Tran is on a distinguished road
(Thread Starter)
electrical issue, please help

greetings in BimmerLand

i am not new to BMW, or the electrical gremlins that can pop up from time to time. however, due to the quickness of the situation, i am calling on anyone's ideas, and even registered with a forum to get them.

i recently bought a 1991 318iS and have really enjoyed it. it's condition is quite good for its age. however, i went to go on a trip tonight and have a problem. i pushed the rear defrst button in and it got jammed in really tight. i have seen various other buttons like this one jam on my two 1984 cars and didn't worry too much... i would just pop it back out later.

when i turned off the headlights, i noticed the dash lights stayed on. i could pull the headlight knob out and push it in and all worked as it should, save for the dash lights were always on. while i was stopped i started fiddling with the jammed defrost button. if i pressed super hard, the dash lights would go out as they should be. i finally wedged my fingernail in and was able to pop the switch back out, and am happy to report, the rear defrost button works like a charm now. and guess what??? the dash lights turned off!!! yay for me!!

well, almost. now they wont turn back on... at all. the headlight switch pulls in and out and the lights work fine. the guages all work fine. the fans, heat, AC, clock/tripmeter works fine, CD player works fine, defrost and hazzards work fine. all lights associated with them work. all idiot lights work, all swervice lights work, CD player lights, power window lights. everything seems to operate normally escept for two things

1. the dash lights and console lights wont come on anymore
2. the passenger side lights (side markers, tail lights) don't come on

headlights and blinkers and brights are fine.


WTF?? what could cause a weird issue like that? fuses LOOKED fine, but it is dark and the person i bought this from lost the manual so I don;t have a layout of the fuses and relays anyway..

ideas, help, suggestions, parts... if you can help, great. right now i have a great running car that i can't drive after sundown. so, i basically have no car at all...

thanks a bunch,

Dr Tran
Dr Tran is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-22-2007, 12:07 AM
n00b
 
Join Date: Mar 2007
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kenika65 is on a distinguished road
It Is A Fuse

I have the same car you should post some pics!!! As for your problem with your lights it is a fuse... bmw e30 network Maby number 23. Here is a layout of your fuses Diagram and another Fuse Chart as for your defrost button I had the same problem with it sticking until it finally split in two and the light was always on unless i pressed it in and cocked it to the side until i finally unhooked the switch for a while then i replaced it

Last edited by kenika65; 03-22-2007 at 12:19 AM.
kenika65 is offline  
#3 (permalink) Old 03-22-2007, 01:03 AM
n00b
 
Join Date: Mar 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dr Tran is on a distinguished road
(Thread Starter)
works!

i figured as much, but the fuse on #23 looked fine. but i rely on contacts, my roomie took a look and it was bad. replaced and all is well... after running and buying fuses. stupid i know. i have to keep them on hand for my other bimmers.

thanks for the fuse layout. i needed that. fuse or no, without that i would not have known what to pull for what systems. thanks a bunch

jarrod
Dr Tran is offline  
#4 (permalink) Old 03-22-2007, 01:34 AM
n00b
 
Join Date: Mar 2007
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kenika65 is on a distinguished road
Post some pics... Large pics if you could... any pics
kenika65 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory Hid Issue chaci328ci 3-Series (E46, E90) 2 06-16-2005 12:13 PM
Need The Experts-mysterious Electrical Problem??? JonnyM3 3-Series (E36) 6 12-06-2004 07:04 PM
Electrical Issue, Please Help!! Q_BMW 3-Series (E36) 8 10-20-2004 06:08 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome