check engine light - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-01-2007, 12:44 AM
Neutral Member
 
photoguy30523's Avatar
 
Join Date: Jan 2007
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
photoguy30523 is on a distinguished road
(Thread Starter)
check engine light

well ive notice that my check engine light comes on while i am on a red light,or when i come to a complete stop for like about 5 secs it comes on, and when i accelerated to go it goes off. any ideas i have check everything but i dont know what else to check for.

photoguy30523 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-01-2007, 12:50 AM
Festivus yes, bagels no..
 
yammahamma's Avatar
 
Join Date: Mar 2005
Location: SL,UT
Posts: 2,991
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold
Send a message via Yahoo to yammahamma
bad alternator?....


when mine went bad..a few of the dash lights would come on when at complete stops....the battery was still getting a little charge, but after a few weeks like this it stopped charging completly....

take your car to anywhere with a volt meter (like checker) and have them test it....I think it should read around 13-14 volts....but I'm not sure...

or it could be the rectifier or regulator...but I just replaced the whole alternator for $150 instead of trying to figure out which part was bad...


Last edited by yammahamma; 04-01-2007 at 12:56 AM.
yammahamma is offline  
#3 (permalink) Old 04-01-2007, 01:08 AM
Neutral Member
 
photoguy30523's Avatar
 
Join Date: Jan 2007
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
photoguy30523 is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by yammahamma
bad alternator?....


when mine went bad..a few of the dash lights would come on when at complete stops....the battery was still getting a little charge, but after a few weeks like this it stopped charging completly....

take your car to anywhere with a volt meter (like checker) and have them test it....I think it should read around 13-14 volts....but I'm not sure...

or it could be the rectifier or regulator...but I just replaced the whole alternator for $150 instead of trying to figure out which part was bad...
u think its the alt? i have HIds, 2 10s speakers with 1000WATS amp. the light comes on only when i stop.by the way i am getting code 1222 and 2 days ago i seal all vac leaks, replace my o2 sensor, added a new air filter. and still does it. any ideas?

ps. i also replace my fuel pump

photoguy30523 is offline  
#4 (permalink) Old 04-01-2007, 01:12 AM
Festivus yes, bagels no..
 
yammahamma's Avatar
 
Join Date: Mar 2005
Location: SL,UT
Posts: 2,991
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold
Send a message via Yahoo to yammahamma
^^^ I really don't know much about it....all I know is I had a similar problem and replacing the alt fixed it...besides, testing it is free...so what's there to lose?

maybe someone can give you better help...but that's just my $.02


yammahamma is offline  
#5 (permalink) Old 04-01-2007, 01:21 AM
Neutral Member
 
photoguy30523's Avatar
 
Join Date: Jan 2007
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
photoguy30523 is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by yammahamma
^^^ I really don't know much about it....all I know is I had a similar problem and replacing the alt fixed it...besides, testing it is free...so what's there to lose?

maybe someone can give you better help...but that's just my $.02


thanks for giving me ideas dude. ill have the alt check

photoguy30523 is offline  
#6 (permalink) Old 04-01-2007, 01:28 AM
Festivus yes, bagels no..
 
yammahamma's Avatar
 
Join Date: Mar 2005
Location: SL,UT
Posts: 2,991
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold yammahamma is a splendid one to behold
Send a message via Yahoo to yammahamma
great lookin' car by the way...

'89 e30 vert, represent!

yammahamma is offline  
#7 (permalink) Old 04-01-2007, 09:27 AM
5th Gear Member
 
Join Date: May 2004
Location: NC
Posts: 1,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Starmavin is a jewel in the rough Starmavin is a jewel in the rough Starmavin is a jewel in the rough Starmavin is a jewel in the rough
Check your IAT sensor in your AFM. And test your fuel pressure regulator.
Starmavin is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Desperately Need Your Help: BMW325i "Service Engine Soon" light problem CNMB250 3-Series (E46, E90) 4 12-19-2007 07:26 AM
Check Engine Light aheath 3-Series (E36) 1 04-27-2005 07:27 PM
Check Engine Light On, But Only When I Start Car BMW-ATI 3-Series (E36) 5 04-15-2005 10:40 PM
Red check engine light came on today YNGRVP 3-Series (E36) 9 05-28-2004 10:36 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome