89 325i wiring mixup - BMW Forum - BimmerWerkz.com
3-Series (E21, E30) Chat relating to the BMW 3-Series from 1975-1983 and 1984-1991 line. Specific models: BMW 315, BMW 316, BMW 318, BMW 318i, BMW 320/4, BMW 320i, BMW 320/6, BMW 323i, BMW 320i. E30 Family models include: BMW 325e, BMW 325i, BMW 325is, BMW 325ix.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-14-2008, 10:30 AM
n00b
 
Join Date: Dec 2008
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeffie8696 is on a distinguished road
(Thread Starter)
89 325i wiring mixup

Going through the wiring diagram last night I noticed the engine speed sensor and cylinder ID sender signal might be mixed up. What would this cause the engine to do if anything? Both connectors are located on the drivers side front of the engine below the intake and are the same connector for both. I believe the wire colors are the same for both.
jeffie8696 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-14-2008, 11:54 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Well one answer to that then! if you think they are incorrect swap them over, although over the years they have been there, the loom would have taken its shape, so if you take one off and it flicks to the left or right, you will then know there wrong!

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#3 (permalink) Old 12-14-2008, 12:14 PM
n00b
 
Join Date: Dec 2008
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeffie8696 is on a distinguished road
(Thread Starter)
I just had this engine installed by a less than stellar mechanic. Long story. I have had issues since then. I have had to fix his repairs several times.
jeffie8696 is offline  
#4 (permalink) Old 12-14-2008, 12:18 PM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Ok, so hows the engine running ? and have you changed the wires over ?

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#5 (permalink) Old 12-14-2008, 12:32 PM
n00b
 
Join Date: Dec 2008
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeffie8696 is on a distinguished road
(Thread Starter)
I just got back from under the hood. I see that the connectors are a one up one down arrangement, hopefully BMW would have no reason to change it for whatever reason. I did unplug the throttle position switch/sensor and it made no difference, funny since I just installed a new one last year. I will be looking into it when I get my multi meter back. Could be the wiring harness from the new engine has a break in it inside the loom.
jeffie8696 is offline  
#6 (permalink) Old 12-14-2008, 06:17 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
I would personally not go changing wiring around on an 89 325....gotta be something else and messing with the wiring (unless its' already been compromised) is not good....best of luck
silversled is offline  
#7 (permalink) Old 12-15-2008, 09:32 AM
n00b
 
Join Date: Dec 2008
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeffie8696 is on a distinguished road
(Thread Starter)
Thus my problem. I purchased this used engine from a HACK ,so called mechanic and he replaced the wiring harness with the one from the other engine. I have no idea what year the "new" engine is (or anything else for that matter) and he insisted that he install it to give any kind of warranty. so now I have a lot of money stuck in a "new" engine that I would have been better off replacing myself. In fact I had to make repairs to his handy work before I drove the car away from his shop!! And even then I didn't get one block away before I realized the windows wouldn't roll down!! Back to the shop and have him repair that (which he didn't admit he screwed up).
jeffie8696 is offline  
#8 (permalink) Old 12-15-2008, 09:57 AM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,699
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Did you check the window circuit breaker switch on the center console to make sure about the windows?

BMW

Sig by zeaq
witeshark is offline  
#9 (permalink) Old 12-15-2008, 09:12 PM
2nd Gear Member
 
Join Date: Oct 2008
Posts: 493
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
silversled can only hope to improve
yeah, that sounds like an issue..hmmm....what are you thinking of doing about this? inquiring minds want to know....kidding of course....good luck
silversled is offline  
#10 (permalink) Old 12-16-2008, 08:19 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
You really need to find out what year that engine is for future reference, as you may need a new part at sometime, sounds newer or could even be older if he had to change the wiring loom.

If you knew the engine year, that would be a good start as then you could cross examine the two loom diagrams to see whats different.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!

Last edited by marti5; 12-16-2008 at 08:21 AM.
marti5 is offline  
#11 (permalink) Old 01-09-2009, 01:01 PM
n00b
 
Join Date: Dec 2008
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeffie8696 is on a distinguished road
(Thread Starter)
update

I am still thrashing the electrical problems. Just had to replace the wiper motor because it got so hot it melted the plastic cover and made the car STINK like you couldn't believe. I have been avoiding driving it since then for obvious reasons. (need to check the fuse size obviously)
I see the ground for other parts of the loom is orange/brown and that is the #2 wire on the connector that is supposed to be ground. But I am still confused as to why I would be seeing battery voltage at #1 and #3. since according to the Haynes it is supposed to be only 5volts.
Next I will remove the computer connector and test #52 and #53 for proper voltage. I can only speculate that for some reason there was a change in the design and they used a resistor in the ground for the TPS and used battery voltage for signal.
I would love to identify this engine but the Hack and I have fallen out and I do not speak to him.
jeffie8696 is offline  
#12 (permalink) Old 01-13-2009, 11:18 AM
n00b
 
Join Date: Dec 2008
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jeffie8696 is on a distinguished road
(Thread Starter)
Well I retested the wiring again. This time the center plug on the 3 pin connector shows a good ground. Obviously the wire has an intermittent ground. So I will be running a new wire to it. I still can't explain why the other pins show battery voltage.
jeffie8696 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E21, E30)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 325i (E36) Amplifier wiring? speedbump Audio and Electronics 8 03-16-2014 09:02 AM
2003 325i radio wiring jaytheknight2003 3-Series (E46, E90) 6 07-17-2008 12:50 AM
Need wiring info on stereo upgrade in an 88 325i Devil-Z Audio and Electronics 2 06-07-2004 10:52 AM
Need wiring help Black03ci Audio and Electronics 0 08-29-2003 09:58 AM
Need wiring info on stereo upgrade in an 88 325i palefire 3-Series (E21, E30) 0 12-31-1969 07:00 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome